All White Screen after Log In!

Hello. After getting bored of the basic themes a trip to Gnome Look was a nice alternative.

Even in Ubuntu I am not a pro at installing Tarballs. I remember reading in some threads that you dragged the package to the appearances box. The metacity package installed on my GnomeSuse.

Okay I then wondered what had happened to the GTK and Metacity options that I had installed from the Software Installer. I wondered if they were in the Desktop Effects tab. I enabled advanced effects and then got a message saying something about my graphics adapter. I went ahead and enabled advanced effects and then the screen went all white.

I can’t see anything. I somehow rotate the screens and it’s a cube. I still can’t see anything. I want to disable advanced effects to revert back to my original settings. GRUB is viewable. It has the green background and I can see the log in names. It’s just when I log into my account it then turns all white and I can’t see again.


I may have an idea but am not too familiar with Suse 11.1 command lines.

I take it I could use the LiveDisc and make an edit to turn off the Advanced Desktop Effects that I foolishly enabled.

My Thinkpad has the X200M ATI on it which should be able to handle the Desktop effects. My guess is since I did not install the drivers package for it my display went kazooey.

Any suggestions?

It’s a punt, but if it’s running, but not displaying, you can just type blind. Open it, then hit alt-f2, wait a couple of seconds, type gnome-terminal, hit return, wait a couple of seconds, then type

metacity --replace&

There are a few other ideas in this thread;

Gnome Vs Kde - openSUSE Forums

Where do I type “blind” in at?

I can’t even log into Failsafe. I try entering my username and the password but it won’t let me!

I tried logging into my regular account and typing blind. Again I don’t know what this will do since I can’t see anything!

Any more ideas?


I also noticed in that link they mentioned CLI. What is that? As for the Failsafe mode I get all the way up to the prompt for Username and Password. I type them in correctly and it says they are incorrect.

I don’t mean type the word ‘blind’, I mean you can type things without seeing the feedback on the screen - as long as the system isn’t frozen, it doesn’t matter whether you can see what you’re typing, as long as you’re careful.

If the cube is rotating, then it doesn’t sound frozen. So load it up, log in, and hit alt-f2 (which means run), then type the things suggested in the previous post. Might work. (make sure you put a space between ‘metacity’ and the two hyphens)

If you need to get to the Command Line Interface (CLI), at the boot menu, where it lets you choose ‘openSUSE’ or ‘failsafe’, press escape to drop to text mode. You can then move the cursor down to ‘openSUSE’, and press ‘e’ for edit. Move the cursor onto the line that says ‘kernel’, and press ‘e’ again. Now add the number ‘3’ to the end of the line, with a space before it. Press return, then press ‘b’ for boot. That’ll load suse in runlevel 3, which is CLI. You can reboot again by typing ‘su’, pressing return, enterring your root password, and typing ‘reboot’.

Why it’s refusing your password I don’t know. First things first, try the above trick with alt-f2, and see what happens. Type carefully. :wink:


Yeah. I kinda figured there was some elaborate way of doing this :wink:

bbl going to try this out!

Okay I can see things now. The minimize, maximize, and close tabs are gone for everything.

I also can’t switch screens and can’t get that gnome-terminal icon off the taskbar. I tried reinstalling Metacity b/c I’m guessing Metacity is for the min, max, and close windows right?

The Metacity package finished downloading but never reinstalled. I just aborted and restarted the laptop.

Same thing again. White screen.

Opened up F2 and did the gnome-terminal command again.

That’s where I’m at now.

Unfortunately I’m not a Gnome SUSE user, so I don’t really know what you should do here.

Basically, there are two window managers used normally with gnome - metacity and compiz. Compiz is more advanced, and has whizzbang effects like the cube. Or it just crashes.

metacity --replace& just switches it over to metacity. So you’ve got two options - find a way to get it to default to metacity, or change the settings in compiz / your graphics driver so it can work without crashing. You might find if you can install compiz config settings manager it’ll help you adjust compiz - but the first thing I’d try to do is to undo whatever it was that caused this problem in the first place…

Good luck!

Isn’t there a command like sudo apt-get update that will fix the broken packages? or at least update it from that command?

Ugh. I’m locked out of using terminal also! I brought up gnome terminal to issue a command and it won’t let me do anything. I feel like I’m in some kind of safe mode or limited access mode.


Thanks for your help! I’ll just switch back over to another OS and work this out over time!

At root prompt do:

xgl-switch --disable-xgl


It’s been a long day.

Is the root prompt in Failsafe mode?

Or am I going to type blind again?

A su terminal in the running desktop will do, or if you have no desktop boot to level 3, login as user, switch to su and run the command.

level 3
Remove all the boot arguments from your default boot line and just type the number: 3


Nothings working.

How do I do a repair with an installation DVD???


It’s not as simple as that and not necessary.

You say nothing is working. Clarify…

I logged back into my groovy white screen and did the F2, gnome-terminal, and did

xgl-switch --disable-xgl

I tried rebooting from gnome terminal but it was a little hard since I’m basically guessing what I’m really typing and what shows up on the screen. Did I mention that I’m not an expert with Linux??? I couldn’t do anything really. I hit ctrl, alt, and backspace (x2) to get back into log in.

I logged back into the white screen.

I restart and enter CLI. I follow the directions for Level 3 and try the same code to switch off compiz. I try restarting and the CLI doesn’t recognize the command(s). I tried

restart -h
shutdown -h now

and various combinations to get the laptop to at least shutdown. I somehow manage to shut it down and restart. I log back into my account hoping by some miracle I did something right.

I get the white screen.

I’m pretty desperate by this point and go through the previous posts and go to the link provided by Confuseling. I read through them and get to the section of gnome .bak

I try what I think is rolling back gnome. The linked post had four different lines of code. I go through each one and only two of them don’t get an unrecognized or cannot find blah blah blah.

Anyway. After restarting I still get the white screen.

I really don’t know what else to do. I was hoping there was something in the livedvd that could repair the suse partition. That would be groovier than that ugly white screen!

Lets try this:

Pause the boot by moving the down arrow, then back up to the default boot. But now press backspace, it should delete any text where you can see: vga=0x…
Remove all text and now type just the number:
and hit enter
at the login type your user name and then password
now type:
then the root password
now type this:
sax2 -r -m 0=vesa
(N.B. the 0 is a zero not a letter)
now reboot: type: reboot
if you don’t get a gui login
login as user at cli and try this at the cli

Caf. I tried again. Same white screen. There was a box that popped up after the sax loading.

It asked if I wanted to keep the current settings or reconfigure. I went with the current. After which I rebooted.

Same white screen.

I had to take a break! I also had some studying to do (while listening to some good music) which took my mind off of Suse :slight_smile:

I did the blind gnome terminal commands and got a peek at what’s hiding behind that white slate. My desktop reverted back to the green background. Unfortunately this is a dead-end. One cannot change anything in the no-metacity state.

No choice but to reboot and try the sax2 again but choose the “change configuration” tab. Everything looked fine. Things were also grayed out such as the enable 3d accel tab. I left it as is and saved. Rebooted and the white screen again.

I’m relieved I got dual-boot going on here! I can’t imagine what would happen if I only had one OS on here! Needless to say I hope someone sees this thread and can make a miracle happen for me. I sure hate to give up on Suse. I liked the speed, clean layouts, and customization this distro offered.

ATI/Troubleshooting - openSUSE

lol!Thanks it WORKED.

Move the mouse pointer over the screen, when you get the cursor pointer, click, the cursor will be on the terminal.Then type blindly, metacity --replace& and then press enter. Within a few sec, the malfunctioning window manager will be replaced with metacity.

Good idea about moving the cursor around if you can see it - didn’t think of that.

Otherwise you just have to hope the terminal has focus…