Alignment problems with printer Brother MFC-7420

I upgraded to (= installed from scratch) openSUSE 11.3 / KDE 4.4 the other day, and while under the previous versions I never had problems with my printer, this time I get an alignment problem when printing out pages after reinstalling the driver (like this: http://thumbnails9.imagebam.com/9017/b2474790160045.jpg](http://www.imagebam.com/image/b2474790160045) )

What I did:

I got the lpr driver and cupswrapper from the Brother.co.jp homepage and installed them in this order (just as I did before, and without any problems). (Linux 対応状況|サポート|ブラザー)

I haven’t been able to compare versions since I didn’t pay attention last time, but the printer is an older model so I don’t think the driver / cupswrapper have been changed.

My questions:
(1.) What is the likely source of the problem?

      - the printer driver / cupswrapper (seems unlikely to me since I never had problems before)
      - something about openSuSE 11.3? (since things worked fine under 11.2, but aren't now)
      - something about cups?

(Did cups get updated to a different version in openSusE 11.3? I noticed that it looks different now: compare the old (http://thumbnails5.imagebam.com/9016/aff2ea90159560.jpg](http://www.imagebam.com/image/aff2ea90159560) ) and the new(http://thumbnails26.imagebam.com/9016/075bdc90159559.jpg](http://www.imagebam.com/image/075bdc90159559) ). Is this likely to cause problems?)

(2.) How can I fix this problem?

Thanks!

How can I fix this problem?

… goodness only knows …

Folks seem to believe each new release of a distro will be perfect; …hmmmmmmmmm …

You could subscribe to the CUPS forum … file a bug report to opensuse …

Naw, I know that there are always issues to work on. Unfortunately, it seems like the issues are getting progressively more with each release. I should probably cease updating.

Anyway, problems need to be addressed, so if someone could point me in the right direction, I’d be most grateful!

Hm, this one will remain a mystery. I reverted back to openSUSE 11.2 / KDE 4.3. Things work much better there … :frowning:

having the same problem with mfc8860dn. it used to work fine with 11.2 with the same drivers

Did you try the cupswrapper driver coming from Brother (Ver. 2.0.1-1)?

Brother Solutions Center : Brother Driver for Linux Distributions

Like he said in his first post, he installed it. :stuck_out_tongue:

I use a MFC-240C and HL-5250DN and if I recall, when you configure the driver via CUPS (localhost:631), there is sometimes different versions of the same driver : postscript, b-something (sorry, I am not in front of my openSUSE), etc. Did you try those different versions?

Like he said in his first post, he installed it.

Well, I was not so sure what he did install. My capabilities to read japanese are a bit rusty (have ever been so, sorry).

Yeah I understand…lol!

But I presumed that what he said was correct. I am like you, my japanese is more than rusty… :stuck_out_tongue:

@homoludens 1000: As this openSUSE bug report suggested, it is really a problem for Brother to correct their affected drivers. So report your problems to them, along with the CUPS version being used.

Now, a different approach is to use the ‘brprintconflsr2’ CLI utility to configure the paper size for your printer. It appears that Brother drivers don’t respect the CUPS settings properly. Have a look at this command guide. In particular, the ‘brpintconflsr2’ command options are listed here. (Other Brother models have a similar config tool available).

So, if you have a printer name ‘home_printer’ and want to print to A4 paper for example, you could try issuing

brprintconflsr2 -P home_printer -pt A4

Note: You will need root privileges, so use ‘su -’ command first.

Hi. I’ve encountered similar problem with my Brother HL-2240D laser printer, and I’ve just found a solution. For a HL-2240D, I modified /usr/local/Brother/Printer/HL2240D/lpd/psconvert2 as follows, and now the alignment seems correct:


*** psconvert2.bak      2010-06-03 14:20:10.000000000 +0900
--- psconvert2  2011-01-23 03:17:18.000000000 +0900
***************
*** 92,98 ****
  
  GHOST_SCRIPT=`which gs`
  OUTPUT_TYPE=bit
! GHOST_OPT="-q -dNOPROMPT -dNOPAUSE -dSAFER -sDEVICE=$OUTPUT_TYPE -sOutputFile=- - -c quit"
  
  if  "$pclresizecommand" != "" ];then
  
--- 92,98 ----
  
  GHOST_SCRIPT=`which gs`
  OUTPUT_TYPE=bit
! GHOST_OPT="-q -sGenericResourceDir=/usr/share/ghostscript/8.70/Resource/ -dNOPROMPT -dNOPAUSE -dSAFER -sDEVICE=$OUTPUT_TYPE -sOutputFile=- - -c quit"
  
  if  "$pclresizecommand" != "" ];then


I found “-sGenericResourceDir=…” option added here is necessary because ghostscript in OpenSUSE 11.3 seems to add warning message to the output data. You can see in the below experiment that the warning message is included before the desired output, if “-sGenericResourceDir=…” is not specified:


YashiroRed:~ # a2ps --output=- .bashrc | gs -sGenericResourceDir=/usr/share/ghostscript/8.70/Resource/ -r300 -g300x200 -q -dNOPROMPT -dNOPAUSE -dSAFER -sDEVICE=bit -sOutputFile=- - -c quit | hexdump -C 2>/dev/null | head -n10
.bashrc (plain): 1 page on 1 sheet]
[Total: 1 page on 1 sheet] sent to the standard output
00000000  00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00  |................|
00000010  00 00 00 00 00 07 80 00  00 00 00 00 00 0f 00 00  |................|
00000020  40 02 00 00 20 00 00 00  00 00 00 00 00 00 00 00  |@... ...........|
00000030  00 00 00 00 00 00 00 00  00 00 00 07 80 00 00 00  |................|
00000040  00 00 00 0f 00 00 40 02  00 00 20 00 00 00 00 00  |......@... .....|
00000050  00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00  |................|
00000060  00 07 82 02 02 02 fa 82  02 0f 00 00 40 02 00 00  |............@...|
00000070  20 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00  | ...............|
00000080  00 00 00 00 00 00 00 07  80 00 00 03 f8 e0 00 0f  |................|
00000090  00 00 40 02 00 00 20 00  00 00 00 00 00 00 00 00  |..@... .........|
YashiroRed:~ # a2ps --output=- .bashrc | gs -r300 -g300x200 -q -dNOPROMPT -dNOPAUSE -dSAFER -sDEVICE=bit -sOutputFile=- - -c quit | hexdump -C 2>/dev/null | head -n10.bashrc (plain): 1 page on 1 sheet]
[Total: 1 page on 1 sheet] sent to the standard output
00000000  0a 2a 2a 2a 20 57 61 72  6e 69 6e 67 3a 20 47 65  |.*** Warning: Ge|
00000010  6e 65 72 69 63 52 65 73  6f 75 72 63 65 44 69 72  |nericResourceDir|
00000020  20 64 6f 65 73 6e 27 74  20 70 6f 69 6e 74 20 74  | doesn't point t|
00000030  6f 20 61 20 76 61 6c 69  64 20 72 65 73 6f 75 72  |o a valid resour|
00000040  63 65 20 64 69 72 65 63  74 6f 72 79 2e 0a 20 20  |ce directory..  |
00000050  20 20 20 20 20 20 20 20  20 20 20 20 20 74 68 65  |             the|
00000060  20 2d 73 47 65 6e 65 72  69 63 52 65 73 6f 75 72  | -sGenericResour|
00000070  63 65 44 69 72 3d 2e 2e  2e 20 6f 70 74 69 6f 6e  |ceDir=... option|
00000080  00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00  |................|
00000090  00 00 00 00 00 07 80 00  00 00 00 00 00 0f 00 00  |................|

Hope this works for other Brother-printer users as well :slight_smile:

Let me note a little more on this issue. It’s probably better to correct psconvert2 as follows, as “-sGenericResourceDir=/usr/share/ghostscript/8.70/Resource/” is dependent on Ghostscript version (8.70).


--- psconvert2.bak      2010-06-03 14:20:10.000000000 +0900
+++ psconvert2  2011-01-24 16:43:18.000000000 +0900
@@ -92,7 +92,7 @@

 GHOST_SCRIPT=`which gs`
 OUTPUT_TYPE=bit
-GHOST_OPT="-q -dNOPROMPT -dNOPAUSE -dSAFER -sDEVICE=$OUTPUT_TYPE -sOutputFile=- - -c quit"
+GHOST_OPT="-q -dNOPROMPT -dNOPAUSE -dSAFER -sDEVICE=$OUTPUT_TYPE -sOutputFile=%stdout -sstdout=%stderr - -c quit"

 if  "$pclresizecommand" != "" ];then


I’ve notified this issue to the Brother Corp., and they kindly answered to me that they will fix this in later driver versions as well as providing this information as FAQ :slight_smile:

Nice work Yashiromann :slight_smile:

I’m actually looking for a brother mfc 7420 printer. I can’t find one anywhere in Indianapolis and I’m pretty sure I’m going to end up resorting to buying one online. The only website I know of that sells the brother mfc 7420 is Concord but I want to do some price comparisons, can anyone suggest other websites that sell the printer?
Thanks for the help!