ALC889 + OpenSuse 11.2 x86_64 = No sound

I have followed the opensuse sound troubleshoot pages and can’t get it to work. The onboard sound does work in Sudix, out-of-the-box so I know it’s not me plugging in my headphones in the wrong socket. Maybe Sidux works because it’s newer?

I did update opensuse 11.2 before I started again and I did install the new alsa, but that still didn’t fix it, I only installed the latest stable build. Is there a development branch that may support my sound card?

Anyway, here is the vital info:

lspci -v:

00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
        Subsystem: Giga-byte Technology Device a102                
        Flags: bus master, slow devsel, latency 32, IRQ 16         
        Memory at fe024000 (64-bit, non-prefetchable) [size=16]   
        Capabilities: [50] Power Management version 2              
        Kernel driver in use: HDA Intel
aplay -l:

**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC889 Analog [ALC889 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 1: ALC889 Digital [ALC889 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

inux-7xp6:/home/dean # rpm -qa | grep alsa
linux-7xp6:/home/dean # rpm -qa | grep pulse
linux-7xp6:/home/dean # rpm -q libasound2
linux-7xp6:/home/dean # uname -a
Linux linux-7xp6 #1 SMP PREEMPT 2009-10-26 15:49:03 +0100 x86_64 x86_64 x86_64 GNU/Linux

linux-7xp6:/home/dean # cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.20.
linux-7xp6:/home/dean # cat /proc/asound/modules
 0 snd_hda_intel
linux-7xp6:/home/dean # cat /proc/asound/cards
 0 [SB             ]: HDA-Intel - HDA ATI SB
                      HDA ATI SB at 0xfe024000 irq 16
linux-7xp6:/home/dean # head -n 1 /proc/asound/card0/codec*
Codec: Realtek ALC889


Run alsamixer from a terminal and bring all sliders up, experiment with the settings. From what I see in the posted output the card is detected and configured correctly, so it must be some mixer setting, maybe not shown in kmix

Found something maybe interesting. In alsamixer my headphone doesn’t have a volume slider, could this be the issue?

That might be controlled by the Master volume. Is there a checkbox for the headphones? Does it say MM ( muted )? Values can be toggled with spacebar and “m”.

everything is 00 and not MM and all 100% volume.

This is odd.


It maybe that I have plugged my headphones in the wrong socket.

I just moved plugs and got sound.

Before I moved them they worked in win7…

Gonna reboot to windows to see if it works in it’s new location.

what a muppet I am.

Sound working in suse and win7, with my headphones plugged in right port.

I have wasted all day on this, what a muppet…

EDIT: ok, maybe I ain’t a muppet. I had the headphones plugged into the headphone jack originally and it worked great in win7 but not in opensuse. Moved the headphones to front speaker and jack and sound is working in both.

Just need to test SPDIF in the morning.

I just stumbled across this thread now …

Interesting …

I did a search on the ALC889 on the alsa site to see if there were any fixes for this, and while there is a minor update for the ALC889 in of alsa, nothing specific to what you encountered. Search results - AlsaProject

What you could do, if you have time, is write a bug report on openSUSE component “sound”, reporting this different behaviour between Windows7 and openSUSE-11.2.

Attach (don’t copy and paste, but attach) to the bug report the text file from running:

/usr/sbin/ --no-upload

and that will create the file /tmp/alsa-info.txt which can be added as an attachment. That has bunch of technical info that may show the alsa dev what is wrong with the alsa driver, IF you also describe the audio symptoms.

Note the openSUSE packager for sound is also an alsa developer, and if he fixes this, the fix gets sent upstream and ALL linux distributions will benefit.

There is guidance here for raising bug reports: Submitting Bug Reports - openSUSE … The alsa developer/openSUSE packager, may ask that you try a few different alsa versions, and hence if your schedule is too busy for such support (and I definitely know what that can be like) then its probably best NOT to write such a bug report.

Don’t reference this thread, as the openSUSE packager/alsa developer will refuse to read forum threads.

I will do that this week. I have since used s SPDIF lead into my AV reciever and use my recievers headphone jack to drive my headphones, I get a much better soundstage.

I will do what you suggest to help others.