ALC888S sound not working

Hello,

My sound isn’t working, and never has. OpenSuse 11.0 64bit.

According to the motherboard manual, it is a Realtek ALC888s chipset. The board is a Biostar TPower I45.

Here is some relevant info :
**
cat /proc/version **
Linux version 2.6.25.16-0.1-default (geeko@buildhost) (gcc version 4.3.1 20080507 (prerelease) [gcc-4_3-branch revision 135036] (SUSE Linux) ) #1 SMP 2008-08-21 00:34:25 +0200

dmesg | grep hda_codec

hda_codec: Unknown model for ALC883, trying auto-probe from BIOS...
ALSA sound/pci/hda/hda_codec.c:3021: autoconfig: line_outs=4 (0x14/0x15/0x16/0x17/0x0)
ALSA sound/pci/hda/hda_codec.c:3025:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3029:    hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3030:    mono: mono_out=0x0
ALSA sound/pci/hda/hda_codec.c:3038:    inputs: mic=0x18, fmic=0x19, line=0x1a, fline=0x0, cd=0x0, aux=0x0

**
cat /proc/asound/version**
Advanced Linux Sound Architecture Driver Version 1.0.16rc2 (Thu Jan 31 16:40:16 2008 UTC).

**
lsmod | grep snd**

snd_pcm_oss            68992  0 
snd_mixer_oss          35584  1 snd_pcm_oss
snd_seq                83600  0 
snd_seq_device         26516  1 snd_seq
snd_hda_intel         497580  3 
snd_pcm               115208  2 snd_pcm_oss,snd_hda_intel
snd_timer              45072  2 snd_seq,snd_pcm
snd_page_alloc         28688  2 snd_hda_intel,snd_pcm
snd_hwdep              28424  1 snd_hda_intel
snd                    96248  14 snd_pcm_oss,snd_mixer_oss,snd_seq,snd_seq_device,snd_hda_intel,snd_pcm,snd_timer,snd_hwdep
soundcore              26000  1 snd

**
cat /proc/asound/cards**

 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xfe8f8000 irq 22
 1 [HDMI           ]: HDA-Intel - HDA ATI HDMI
                      HDA ATI HDMI at 0xfe9ec000 irq 17

I am new to OpenSuse … what are some things I can try?

TIA

Welcome to openSUSE and welcome to our forum.

I did a search on the ALC888 on the alsa web site (where alsa provides your sound driver) Search results for ALC888 - AlsaProject and noted there were updates made to the driver (to fix some ALC888 problems) in 1.0.17 and also 1.0.18RC3 of alsa (just last week). Its relatively easy to update to the lastest alsa rpms with openSUSE because one of the alsa developers provides rpms for us :slight_smile:

BUT before we go down that route, I would like to check if this is a mixer problem, or a software configuration problem, and in order to do that I need some more information, that you have not provided. So please, to provide more information, with your PC connected to the internet copy and paste the following into a gnome-terminal / konsole:

wget http://home.cfl.rr.com/infofiles/tsalsa && su -c 'bash ./tsalsa' 

when prompted for a password please enter your root password. Please try to accurately answer the question on the number of plugs/jacks on your PC (for example my PC has 3 i/o plugs/jacks). When the script completes it will pass you a URL. Please post that URL here.

Also, please copy and paste the following into a gnome-terminal/konsole and post the output here.rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

Once I have that information, I believe I will be able to provide helpful recommendations.

I have not heard anything from you , so I don’t know if you succeeded? or if you gave up?

I was looking at purchasing a Dell Studio Slim (540ST) and I was told by Dell purchasing support that its audio codec (if one selects the Integrated 7.1 Channel High Definition Audio) is also an ALC888S. So needless to say, I am now very curious if you solved this problem.

I read of a Ubuntu-8.04 user who had a problem with the ALC888S. Ubuntu-8.0.4 comes with 1.0.15 of alsa and with the 2.6.24 kernel. They claim they updated alsa, but they do not give the version of alsa they tried, … but they do note their alsa update attempt failed. Then they posted that they were successful by installing Ubuntu-8.10. Ubuntu-8.10 comes with 2.6.27 kernel, and 1.0.17a of alsa.

So its possible openSUSE-11.1 will work for you. openSUSE-11.1 comes with the 2.6.27 kernel and 1.0.18 of alsa.

Hi, I have the same audio onboard card, and the same problem under openSUSE 11.1 with latest alsa drivers. I have the same problem with no audio. And also I have a graphics card with sound, namely ATI HDMI from Radeon HD2600.

cat /etc/modprobe.d/sound

options snd slots=snd-hda-intel,snd-hda-intel
# 5Dex.CP5fkjPuSe5:SBx00 Azalia (Intel HDA)
alias snd-card-0 snd-hda-intel
# 2Oa+.JPS6WT8bfU4:RV630/M76 audio device [Radeon HD 2600 Series]
alias snd-card-1 snd-hda-intel

When i reset the cards I get sound back, but I have to do that every reboot.

cat /proc/asound/cards returns this after reset, but only ATI HDMI before reset:

 0 [SB             ]: HDA-Intel - HDA ATI SB
                      HDA ATI SB at 0xfe9f4000 irq 16
 1 [HDMI           ]: HDA-Intel - HDA ATI HDMI
                      HDA ATI HDMI at 0xfebec000 irq 19

dmesg | grep hda_codec returns this after reset, but nothing before reset:

hda_codec: Unknown model for ALC883, trying auto-probe from BIOS...
ALSA sound/pci/hda/hda_codec.c:3047: autoconfig: line_outs=4 (0x14/0x15/0x16/0x17/0x0)
ALSA sound/pci/hda/hda_codec.c:3051:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3055:    hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3056:    mono: mono_out=0x0
ALSA sound/pci/hda/hda_codec.c:3064:    inputs: mic=0x18, fmic=0x19, line=0x1a,fline=0x0, cd=0x0, aux=0x0
hda_codec: Unknown model for ALC883, trying auto-probe from BIOS...
ALSA sound/pci/hda/hda_codec.c:3047: autoconfig: line_outs=4 (0x14/0x15/0x16/0x17/0x0)
ALSA sound/pci/hda/hda_codec.c:3051:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3055:    hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3056:    mono: mono_out=0x0
ALSA sound/pci/hda/hda_codec.c:3064:    inputs: mic=0x18, fmic=0x19, line=0x1a,fline=0x0, cd=0x0, aux=0x0
hda_codec: Unknown model for ALC883, trying auto-probe from BIOS...
ALSA sound/pci/hda/hda_codec.c:3047: autoconfig: line_outs=4 (0x14/0x15/0x16/0x17/0x0)
ALSA sound/pci/hda/hda_codec.c:3051:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3055:    hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3056:    mono: mono_out=0x0
ALSA sound/pci/hda/hda_codec.c:3064:    inputs: mic=0x18, fmic=0x19, line=0x1a,fline=0x0, cd=0x0, aux=0x0

I think that the problem may be the same driver of these 2 devices, but I am not sure, and yet I don’t have any solution for this problem.

Sorry Kizo.

Please start a new thread. I’ve ‘had it’ having to hunt back and forth in threads where new person after new person after new person adds a question. Its too difficult for me, as I typically have a lot of checking/research, etc … to do to give a new answer, …

So start a new thread and I will respond. I will not in this thread. Its too much for me as typically 3 or 4 users then jump in and its very much to the detriment of the original user.

Kizo, in your new post/thread, please advise if typing:su -c 'rcalsasound restart’after a new reboot will kick start your sound?

If so, add that as the last line in the file:/etc/init.d/boot.localreboot and advise us in the new post/thread if that does not work.

Good luck. … Apologies for the grumpiness … I was fatigued after working thru a thread where 4 users with different problems, jumped in saying they all had the same problem (and they were ALL different). It was very difficult for me to sort the thread/users with multiple posts from many.

Posted my problem in new thread as advised, here is the link: ALC888 no sound under openSUSE 11.1 - openSUSE Forums
No apologies needed. I have some experience in being a mod. :slight_smile: