ALC888 sound problem

After getting my sound card to work i face another problem regarding the sound it produces. whenever i play a music in amarok or in xmms the sound has this cracking noise. i tried changing the options in /etc/modprobe.d/sound for model to acer(my laptop is acer aspire 4530) and position_fix to 1 and 2 still the sound has this cracking noise.

btw, the driver that iam using is the driver that on the realtek site and distro opensuse 11.0

any help is appreciated. :slight_smile:

Try backing off your volume to about 60% (master and pcm volume) in your mixer, and in your application.

I know nothing about the quality of a driver provided by realtek (I always use the open source alsa driver).

i tried it still the cracking noise is there. it seems the soundcard produces cracking noise only when i play music in amarok/xmms but if i watch movie theres no cracking noise.

If try to use the driver provided by dvd-installer or by the online repository ill have no sound at all.

This suggests problems with your mixer settings, or with the settings internal to those two applications (ie back off on the software sound levels).

In the unlikely (IMHO) event this is driver related, then I can’t help, as you are using a RealTek driver.

According to the alsa change history (from the alsa site) alsa was updated to accomodate the ALC888, so sound should work with the alsa driver.
Search results for ALC888 - AlsaProject

i’ll try to compile the sources from alsa site. hope it will work :slight_smile:

Thats the difficult way to do this. It is much easier to install via rpm:
Alsa-update - openSUSE

Note one needs to install the nominal alsa applications: alsa, alsa-utils, alsa-tools, alsa-firmware, libasound2 off of one repos, and ALSO install alsa-driver-kmp-you_kernel_version off of another respos.

as i expected installing the alsa from repos my sound is gone.

i guess ill be sticking to the driver from realtek even if ill be hearing the cracking noise.

thanks for your help oldcpu i really appreciate it. :slight_smile:

No necessary. Its quite possible a simply hand edit to your /etc/modprobe.d/sound file is all that is needed now to restore your sound with the ALC888.

With the new alsa rpms installed, can you please do the following to provide more information so I can provide a good recommendation. … To provide more information, then with your PC connected to the internet, please copy and paste the following into a gnome-terminal or to a konsole:

wget http://home.cfl.rr.com/infofiles/tsalsa && su -c 'bash ./tsalsa' 

when prompted for a password please enter your root password. Please try to accurately answer the question on the number of plugs/jacks on your PC (for example my PC has 3 i/o plugs/jacks). When the script completes it will pass you a URL. Please post that URL here.

Also, reference your headphone problem, please copy and paste the following, one line at a time, into a gnome-terminal or to a konsole and post the output here.
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

With that information, I may be able to make a recommendation to get your sound working fully under alsa on your ALC888.

ok…

wget http://home.cfl.rr.com/infofiles/tsalsa && su -c 'bash ./tsalsa'

tsalsa.txt - nopaste.com (beta)

$ rpm -qa | grep alsa
alsa-firmware-1.0.16-24.1
alsa-tools-1.0.16-47.1
alsa-plugins-1.0.16-57.1
alsa-devel-1.0.16-39.1
alsa-plugins-pulse-1.0.16-57.1
alsa-utils-1.0.16-35.1
alsa-driver-kmp-pae-1.0.18.20081031_2.6.25.18_0.2-1.1
alsa-oss-1.0.15-48.1
alsa-1.0.16-39.1

$ rpm -qa | grep pulse
libpulse0-0.9.10-26.5
alsa-plugins-pulse-1.0.16-57.1

$ rpm -q libasound2
libasound2-1.0.16-39.1

$ uname -a
Linux randz 2.6.25.18-0.2-pae #1 SMP 2008-10-21 16:30:26 +0200 i686 athlon i386 GNU/Linux

$ cat /etc/modprobe.d/sound
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel

OK, your sound card is not recognized.

And you failed to update alsa properly. You have a mix here of 1.0.16 and 1.0.18 alsa versions. Please note my post:

You did not update alsa, alsa-utils, alsa-tools, alsa-firmware, libasound2 >:(
You need to install the nominal alsa applications: alsa, alsa-utils, alsa-tools, alsa-firmware, libasound2 off of one repos, and ALSO install alsa-driver-kmp-you_kernel_version off of another respos. Its all explained here: Alsa-update - openSUSE Do you need me to pickup the exact zypper commands you have to send from the URL/guide I provided?

Once you fix your alsa version, and then reboot, and test your sound, assuming it is still not working, there is an edit to be done to your /etc/modprobe.d/sound file. Below are the possible model options, and we need to pick the one suitable for your PC (where the following is from the alsa documentation file ALSA-Configuration.txt for 1.0.18 of alsa):

	ALC883/888
	  3stack-dig	3-jack with SPDIF I/O
	  6stack-dig	6-jack digital with SPDIF I/O
	  3stack-6ch    3-jack 6-channel
	  3stack-6ch-dig 3-jack 6-channel with SPDIF I/O
	  6stack-dig-demo  6-jack digital for Intel demo board
	  acer		Acer laptops (Travelmate 3012WTMi, Aspire 5600, etc)
	  acer-aspire	Acer Aspire 9810
	  medion	Medion Laptops
	  medion-md2	Medion MD2
	  targa-dig	Targa/MSI
	  targa-2ch-dig	Targs/MSI with 2-channel
	  laptop-eapd   3-jack with SPDIF I/O and EAPD (Clevo M540JE, M550JE)
	  lenovo-101e	Lenovo 101E
	  lenovo-nb0763	Lenovo NB0763
	  lenovo-ms7195-dig Lenovo MS7195
	  lenovo-sky	Lenovo Sky
	  haier-w66	Haier W66
	  3stack-hp	HP machines with 3stack (Lucknow, Samba boards)
	  6stack-dell	Dell machines with 6stack (Inspiron 530)
	  mitac		Mitac 8252D
	  clevo-m720	Clevo M720 laptop series
	  fujitsu-pi2515 Fujitsu AMILO Pi2515
	  3stack-6ch-intel Intel DG33* boards
	  auto		auto-config reading BIOS (default) 

Lets say we pick “auto”, then your /etc/modprobe.d/sound file needs to be changed to:

alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel model=auto 

and then restart your PC and test your sound. If that fails then try (instead of “auto”) some of the other options (such as “acer” or “3stack-dig”) …

Im soo stupid. sorry about that i thought i was able to update it. :frowning:

now my sound is working great and also the cracking noise is now gone…

many thanks oldcpu. :wink:

Fantastic! Glad to read this. Congratulations!