ALC888 no sound under openSUSE 11.1

My problem is explained here in a previous thread (for anyone that might read this): ALC888S sound not working - openSUSE Forums

To answer a question from oldcpu,

su -c 'rcalsasound restart'

doesn’t start the sound, and there is only ATI HDMI listed in cards list.

As additional information I have done


and the info is at

Please respond if any other info is needed.
Thank you for your help.

Thanks for the diagnostic script output URL. I’m thinking this could be a tough “nut to crack” wrt your sound. The ALC888S is not very common. Could you also, after a fresh reboot, with your PC connected to the internet, provide the output URL from copying and pasting this command into a gnome-terminal or kde konsole:dmesg > dmesg.txt && curl -F file=@dmesg.txt
and provide the URL here.

I note from the previous post you had a method to get sound back:

When i reset the cards I get sound back, but I have to do that every reboot.

cat /proc/asound/cards returns this after reset, but only ATI HDMI before reset
… could you also, after getting sound back, again type:dmesg > dmesg.txt && curl -F file=@dmesg.txt
(in case you missed anything in your dmesg quote when sound is functioning) followed by again running the diagnostic script when sound is functioning:/usr/sbin/
and post here the URL provided.

Your PC needs to be connected to the internet for the above commands to work.

Can you also provide the output of the following commands (so I can see what rpms you have installed and also get a look at your /etc/modprobe.d/sound file):rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q padevchooser pavucontrol pavumeter paman paprefs
uname -a
cat /etc/modprobe.d/sound

Are you a gnome or a KDE3 or a KDE4 user?

  1. before reset-
dmesg > dmesg.txt && curl -F file=@dmesg.txt

link: dmesg.txt - (beta)

  1. after reset-
dmesg > dmesg.txt && curl -F file=@dmesg.txt

link: dmesg.txt - (beta)

  1. after reset


  1. all these are after reset:
    :~> rpm -qa | grep alsa

:~> rpm -qa | grep pulse


:~> rpm -q padevchooser pavucontrol pavumeter paman paprefs

package padevchooser is not installed
package pavucontrol is not installed
package pavumeter is not installed
package paman is not installed
package paprefs is not installed

:~> uname -a

Linux linux-jwzh #1 SMP 2008-12-04 18:10:04 +0100 x86_64 x86_64 x86_64 GNU/Linux

:~> cat /etc/modprobe.d/sound

options snd slots=snd-hda-intel,snd-hda-intel
# 5Dex.CP5fkjPuSe5:SBx00 Azalia (Intel HDA)
alias snd-card-0 snd-hda-intel
# 2Oa+.JPS6WT8bfU4:RV630/M76 audio device [Radeon HD 2600 Series]
alias snd-card-1 snd-hda-intel

Thanks for the help.

OK, thanks for the output. Lots of stuff there, most of which is well above my head, although I suspect the alsa dev’s could make sense of it.

When you state you “reset” you sound, how are you doing that? With YaST ?

I did a search on the ALC888, and noted there were some recent changes: Search results - AlsaProject
and its possible not all of those have been back ported to the 1.0.17 alsa driver in openSUSE-11.1 (I don’t know). So rather than mess around now with /etc/modprobe.d/sound edits (which we could do) I recommend you first update to a cutting edge version of alsa that is packaged for openSUSE by one of the alsa devs. You can do that by open a konsole and then type “su” to get root permissions (enter root password) and then with your PC connected to the Internet, copy and paste in sequence, the following 6 zypper commands (one at a time).

zypper ar multimedia 
zypper install alsa alsa-devel alsa-oss alsa-oss-32bit alsa-utils alsa-tools alsa-tools-gui alsa-firmware alsa-plugins alsa-plugins-32bit alsa-plugins-pulse alsa-plugins-pulse-32bit libasound2
zypper rr multimedia
zypper ar multimedia 
 zypper install alsa-driver-kmp-default 
 zypper rr multimedia 

Then restart your PC, and test your sound (while checking your mixer) with the sound test: speaker-test -c2 -l5 -twavand ideally you should hear a ladies’ voice saying ‘FRONT LEFT’,‘FRONT RIGHT’ five times.

If you do not, then lets try a series of iterative edits to your /etc/modprobe.d/sound file (trying one at a time until we find one that works). I note this list in the ALSA-Configuration.txt file for 1.0.18a of alsa:

	  3stack-dig	3-jack with SPDIF I/O
	  6stack-dig	6-jack digital with SPDIF I/O
	  3stack-6ch    3-jack 6-channel
	  3stack-6ch-dig 3-jack 6-channel with SPDIF I/O
	  6stack-dig-demo  6-jack digital for Intel demo board
	  acer		Acer laptops (Travelmate 3012WTMi, Aspire 5600, etc)
	  acer-aspire	Acer Aspire 9810
	  medion	Medion Laptops
	  medion-md2	Medion MD2
	  targa-dig	Targa/MSI
	  targa-2ch-dig	Targs/MSI with 2-channel
	  laptop-eapd   3-jack with SPDIF I/O and EAPD (Clevo M540JE, M550JE)
	  lenovo-101e	Lenovo 101E
	  lenovo-nb0763	Lenovo NB0763
	  lenovo-ms7195-dig Lenovo MS7195
	  lenovo-sky	Lenovo Sky
	  haier-w66	Haier W66
	  3stack-hp	HP machines with 3stack (Lucknow, Samba boards)
	  6stack-dell	Dell machines with 6stack (Inspiron 530)
	  mitac		Mitac 8252D
	  clevo-m720	Clevo M720 laptop series
	  fujitsu-pi2515 Fujitsu AMILO Pi2515
	  3stack-6ch-intel Intel DG33* boards
	  auto		auto-config reading BIOS (default) 

so we will try one at a time, each of those models assignments until you get one to work (after a reboot, without reseting your sound initially).

I note that it was this originally:

So please change that file (add a line at the start) to:

options snd-hda-intel model=auto
options snd slots=snd-hda-intel,snd-hda-intel
# 5Dex.CP5fkjPuSe5:SBx00 Azalia (Intel HDA)
alias snd-card-0 snd-hda-intel
# 2Oa+.JPS6WT8bfU4:RV630/M76 audio device [Radeon HD 2600 Series]
alias snd-card-1 snd-hda-intel

and then either reboot your PC, or try restarting your alsa from a konsole with root permissions with “rcalsasound restart”. Restart your mixer. Test your sound.

If “auto” does not work, then in the /etc/modprobe.d/sound file, replace “auto” with “3stack-dig” and start working your way down the list. You need to reboot or restart alsa after each change, restart your mixer (if not running) and test your sound. Note “3stack” typically corresponds to “3 audio I/O jacks/plugs” on one’s pc. “6stack-dig” would typically correspond to a PC with “6 audio I/O jacks/plugs”.

Let me know if that is not clear (its a lot of testing).

Sorry I haven’t been able do test these things earlier.
To answer your questions, I use KDE4, and the reset procedure I use is following:

  1. Go to Yast->Hardware->Sound
  2. Select the first sound card(SBx00 Azalia (Intel HDA))
  3. Click Edit, and then click Reset all, followed by Next.
  4. When prompted that the sound system must be restarted click Ok.
  5. Click Ok to save the changes.
  6. Repeat steps 1-5 for second card.

I have updated the alsa drivers to latest version as instructed, and there is no result.
Also I have edited /etc/modprobe.d/sound with all those specific sound cards of ALC883/888 list you provided, restarting with “rcalsasound restart”, and no luck.

Maybe I should have mentioned, that I don’t need the second sound card(ATI HDMI), so if you could instruct me to delete it, or block it. Maybe there is some conflict because they use the same driver module. Maybe I could switch the second sound card to other module (ex. a blacklisted one), but I don’t know how.

I don’t think the HDMI should make any difference. Many users have that with no impact. The “trick” I found (with both HDMI and analog sound) was placing the “options snd-hda-intel model=auto” entry on the 1st line, and that appears to work for users with both HDMI and the nominal analog sound.

If you provide the output of the diagnostic script, with what you believe to be the optimal setting to get your sound to work, and I can take a look at it and also check to confirm you updated alsa correctly. That would mean providing the output url (with pc connected to internet) of:/usr/sbin/
and also output of:rpm -qa | grep alsa
rpm -q libasound2
cat /etc/modprobe.d/sound… and I’ll do a quality/sanity check on what I see.

My recommendation at this stage is to write a bug report on alsa and on openSUSE to get attention of the developers:

I just solved the problem. I have the AMD with ATI graphics card. Installing flgrx changes the alsa driver. Yast sees the sound card but the model option is blank! added 6stack as the model and re-started. That did it.

When I followed the instructions to upgrade alsa to the latest build, it removed my flgrx graphics kernel! Put the flgrx back in and mess the the model setting on snd_hda_intel instead, it’s safer.