Akonadi doesn't start with system

As in title mentioned, I think that my Akonadi server has some trouble to start with system.

journalctl:


-- Logs begin at Sat 2020-03-28 09:49:11 CET, end at Fri 2020-10-16 11:12:25 CEST. -- 
paź 16 10:57:33 openSUSE akonadiserver[1986]: **org.kde.pim.akonadiserver: Cannot connect to agent instance with identifier 'akonadi_maildir_resource_0', error message: ''**


The symptom is that I see no notifications about mail unless I open Kmail, but I can see calendar reminders. Is this proper behavior?

Show what akonadi thinks:

karl@3400G:~> akonadictl status
Akonadi Control: running
Akonadi Server: running
Akonadi Server Search Support: available (Remote Search, Akonadi Search Plugin)
Available Agent Types: akonadi_akonotes_resource, akonadi_archivemail_agent, akonadi_birthdays_resource, akonadi_contacts_resource, akonadi_davgroupware_resource, akonadi_ews_resource, akonadi_ewsmta_resource, akonadi_followupreminder_agent, akonadi_google_resource, akonadi_ical_resource, akonadi_icaldir_resource, akonadi_imap_resource, akonadi_indexing_agent, akonadi_kalarm_dir_resource, akonadi_kalarm_resource, akonadi_knut_resource, akonadi_kolab_resource, akonadi_maildir_resource, akonadi_maildispatcher_agent, akonadi_mailfilter_agent, akonadi_mbox_resource, akonadi_migration_agent, akonadi_mixedmaildir_resource, akonadi_newmailnotifier_agent, akonadi_notes_agent, akonadi_notes_resource, akonadi_openxchange_resource, akonadi_pop3_resource, akonadi_sendlater_agent, akonadi_tomboynotes_resource, akonadi_unifiedmailbox_agent, akonadi_vcard_resource, akonadi_vcarddir_resource
karl@3400G:~> 

Try ‘akonadictl restart’.

Please take a look in ‘~/.local/share/akonadi/’ – you should see something like this:


 > l
total 16
drwxr-xr-x   7 xxx users  189 Oct 16 10:19 ./
drwx------  79 xxx users 4096 Oct 16 09:46 ../
-rw-r--r--   1 xxx users    0 Oct 16 10:19 Akonadi.error
-rw-r--r--   1 xxx users  140 Oct 16 10:19 Akonadi.error.old
drwxr-xr-x   6 xxx users  273 Oct 16 09:33 db_data/
drwxr-xr-x   2 xxx users    6 Aug 20 11:52 db_misc/
drwxr-xr-x 102 xxx users 4096 Aug 23 16:39 file_db_data/
drwxr-xr-x   2 xxx users    6 Sep  4 18:18 file_lost+found/
-rw-r--r--   1 xxx users 3423 Aug 20 11:52 mysql.conf
drwxr-xr-x   8 xxx users  105 Aug 20 11:52 search_db/
lrwxrwxrwx   1 xxx users   22 Oct 16 09:33 socket-yyy-default -> /run/user/«*the user's UID*»/akonadi/
 > 

Take a look in the Akonadi error logs for anything which points more specifically to the issue you are experiencing.

  • In the ‘db_data/’ directory there are some database logs which may also help to resolve this issue.

Further, in ‘~/.local/share/’ there should be at least one directory named ‘akonadi_maildir_resource_0’ – if this directory isn’t present, the KMail e-Mail resource hasn’t been set up correctly.
[HR][/HR]The bad news:

  • I suspect that, neither “akonadictl fsck” nor “akonadictl vacuum” will repair this issue – try them but, no guarantee that, it’ll help …
  • I suspect that, you may have to setup the affected e-Mail resource again – if it’s an IMAP account you may have luck and, the e-Mail traffic will be still stored on the IMAP server.

If your luck ran out, hopefully you have archived copies of your e-Mail traffic …

Thank you all for such fast response! These are steps I have made:

  1. So, I have all my account folders properly created in .local/share (those akonadi_maildir_resource).
  2. I have read Akonadi.error log and there were logs about this error (but i haven’t focused much on that, my bad).
  3. I run fsck and vacuum, it did some hard work, then I rebooted and my journal is empty!
  4. Then, I checked akonadictl status (because, I dicovered that two of you guys replied to my post) and it is same as @karlmistelberger pasted, saying control and server running (with all agent types), so I assume that it’s OK now.
  5. I have read Akonadi.error log again and there is nothing relevant to my problem (that’s why I cant paste what was before).
  6. I have sent a test email to myself when kmail wasn’t open yet and I recived notification about new mail.

I think that my problem is solved. Thank you guys very much. That’s why I love openSUSE and people around it. Always with helpful hand.
(sorry for my English, it’s not my native language)