Airlink wireless card

I need help getting my wireless card enabled.

New install opensuse 11 kde 4.0.4. AWLH4030 Super G Wireless PCI Adapter Adapters – AWLH4030

… recognized by opensuse as AR5212/5213


00:09.0 Ethernet controller: Atheros Communications Inc. AR5212/AR5213 Multiprotocol MAC/baseband processor (rev 01)

/sbin/lspci -n

00:09.0 0200: 168c:0013 (rev 01)

/bin/dmesg | less

ath5k_pci 0000:00:09.0: registered as ‘phy0’


wlan0 IEEE 802.11g ESSID:""
Mode:Managed Frequency:2.427 GHz Access Point: Not-Associated
Tx-Power=27 dBm
Retry min limit:7 RTS thr:off Fragment thr=2352 B
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

/sbin/lspci -v

00:09.0 Ethernet controller: Atheros Communications Inc. AR5212/AR5213 Multiprotocol MAC/baseband processor (rev 01)
Subsystem: Device 1948:3a02
Flags: bus master, medium devsel, latency 168, IRQ 17
Memory at e3000000 (32-bit, non-prefetchable) [size=64]
Capabilities: <access denied>
Kernel driver in use: ath5k_pci
Kernel modules: ath5k

How do I fix the wireless connectivity? I cannot connect to the internet or lan for tools or software.

If this is too difficult (for me), I guess I could enable the onboard wired SiS ethernet adapter, but that would require reconfiguring my wired network.

I could ethernet wire the box, download some software, then enable the wireless and disable the wired, but I was hoping for something easier.

Mike Easter[/size]

have you configured it via YaST - network devices - network settings ?


I’m trying to access a wireless access point which is WPA-PSK. The same hardware connects on the WinXP partition 5x5.


Yast network settings overview sez:
AR5212/5213 blahblah (Not connected)
Mac address blahblah
Device name: wlan0
Started automatically at boot
IP address assigned using DHCP

… but I’m not gettting an IP address assigned and the ifconfig doesn’t
show any rx/tx.

/etc/sysconfig editor
line called: Setting of WIRELESS_WPA_PSK
has the correct value for the passphrase


Now I have ethernet wired the onboard SiS and I still am unable to get an IP address with eth0.

This is the first distro install I’ve had that didn’t recognize the ethernet automatically, that requires all kinds of commandline manipulations to try to get connectivity. I may have to give up on opensuse if it is too difficult for me.

I’ll try asking again/some more in the alt.os.linux.suse newsgroup.



I changed my network topology somewhat so that I could (temporarily) wire this opensuse11, but I still want to be able to choose either the wired or the wireless mode so that I can move the box away from the wired LAN.

The wired is an onboard SiS chipset. The wireless is still Airlink atheros chipset. The detection business during a reinstall was able to find and enable the wired even tho’ I wasn’t able to configure that with the existing install for some reason.

Here is some information about the current status:

/usr/sbin/hwinfo --wlan

02: PCI 09.0: 0282 WLAN controller
[Created at pci.310]
UDI: /org/freedesktop/Hal/devices/pci_168c_13
Unique ID: y9sn.ZBIt0EdR4SB
SysFS ID: /devices/pci0000:00/0000:00:09.0
SysFS BusID: 0000:00:09.0
Hardware Class: network
Model: “Atheros AR5212/AR5213 Multiprotocol MAC/baseband processor”
Vendor: pci 0x168c “Atheros Communications, Inc.”
Device: pci 0x0013 “AR5212/AR5213 Multiprotocol MAC/baseband processor”
SubVendor: pci 0x1948
SubDevice: pci 0x3a02
Revision: 0x01
Driver: “ath5k_pci”
Driver Modules: “ath5k”
Device File: wlan0
Features: WLAN
Memory Range: 0xe3000000-0xe300ffff (rw,non-prefetchable)
IRQ: 17 (no events)
HW Address: 00:18:02:0c:84:03
Link detected: no
WLAN channels: 1 2 3 4 5 6 7 8 9 10 11
WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462
WLAN encryption modes: WEP40 WEP104 TKIP CCMP
WLAN authentication modes: open sharedkey wpa-psk wpa-eap
Module Alias: “pci:v0000168Cd00000013sv00001948sd00003A02bc02sc00i00”
Driver Info #0:
Driver Status: ath5k is active
Driver Activation Cmd: “modprobe ath5k”
Config Status: cfg=no, avail=yes, need=no, active=unknown

sudo /usr/sbin/iwlist wlan0 scan

wlan0 No scan results

/bin/dmesg | less

ath5k_pci 0000:00:09.0: registered as ‘phy0’
phy0: Selected rate control algorithm ‘pid’
IT8705 SuperIO detected.
parport_pc 00:09: reported by Plug and Play ACPI
parport0: PC-style at 0x378 (0x778), irq 7, dma 3 [PCSPP,TRISTATE,COMPAT,ECP,DMA]
ath5k phy0: Atheros AR5213A chip found (MAC: 0x79, PHY: 0x45)

/sbin/ifconfig eth0

eth0 Link encap:Ethernet HWaddr 00:11:5B:49:B3:C2
inet addr: Bcast: Mask:
inet6 addr: fe80::211:5bff:fe49:b3c2/64 Scope:Link
RX packets:861 errors:0 dropped:0 overruns:0 frame:0
TX packets:943 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:490172 (478.6 Kb) TX bytes:169387 (165.4 Kb)
Interrupt:19 Base address:0xe000

/sbin/ifconfig wlan0

wlan0 Link encap:Ethernet HWaddr 00:18:02:0C:84:03
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

Shouldn’t I be able to choose between the eth0 and the wlan0 with the knetwork tool? What do I have to do to get the wlan0 to be able to see the access point with the scan?


I actually have the exact same model of Wireless NIC in my computer and I was about to embark on configuring it myself. Did you have any luck?

So I don’t know how to ‘quote’ someone yet but ok here goes. Measter you said that this was your first distro where the ethernet wasn’t automatically detected. Did you mean the wired or the wireless ethernet wasn’t detected?
My wired ethernet worked automatically but my WLAN card had troubles connecting (hence the reason I need to config it).

Do you remember what version of SUSE you had at the time? I have 11.2 currently.