Ahhh, not booting! Help!

I have a toshiba satellite pro A210. I’ve been running Suse 11 64-bit on it for 6 or so months. I decided to do a fresh install of 32-bit. I wiped the drive and did a fresh install that looks successful. However, when I reboot for the first time after install completes, all I get is a black screen with a flashing cursor, no grub menu. I’m stumped, I’ve tried this install 3 times and don’t really know what could be wrong. Ideas? Help would be appreciated!! Thanks

Anybody?? This is just weird, where is my grub??!!

There’s probably some remnant of the old Grub installation lying somewhere on your drive - probably in the MBR, and it’s either incompatible with 32-bit or it’s just pointing to the old Grub boot files which aren’t there anymore. How many drives? How many partitions? Where are you installing Grub to (to the MBR or elsewhere)? Another possibility: Grub lets you override/swap your BIOS designations of primary/secondary drives and/or partitions. If that’s what you had in your previous install, you should now correct the BIOS settings accordingly.
Anyway, it’s hard to guess what’s going wrong without knowing anything about your system.:stuck_out_tongue:
P.S. Next time, don’t “wipe” the drive; reformat it!

Ok, this is a def possibility. Just one question? I used the toolkit that came with my toshiba do a “full wipe” of my hard drive (all sectors and partitions, took about 3 hours). Would that overwrite the MBR? On my previous install I had one SATA drive and three partitions:

a 2g for swap
a 20 gig for root
and the remainder(?) for /home

If needed, how would I reset my bios? Sorry, this is new territory to me.

Also, if this helps:

I had another hard drive with a 32-bit install(from another machine) and when I swapped the hard drives out and booted up(on my non-working machine) it went straight to Grub as normal. But again, that hard drive image was made on another computer, if that makes sense.

Your Toshiba tool probably didn’t wipe the master boot record (MBR); the MBR is a smallish (512-byte) disk block at the very beginning of the drive and is independent of the operating system(s) or file system(s) you subsequently install on the drive itself. It contains just the partition table of your drive plus a tiny piece of code that “calls” a boot loader which then boots the machine. Officially, this boot loader must be located on the “active partition” for things to work. I think it’s this MBR that you needs fixing.
You proceed as follows:
You slip in the OpenSuSE CD and boot from it; at the boot prompt you select safe mode. When the boot process ends, you type su to get root. Then you type
grub. This will get you into Grub’s command-line interface.
You now type geometry (hd0)
to get the configuration of your drive. Then you post the result here. The next command to issue is find /boot/grub/stage1. Again, you post the results inhere so we can proceed from there.
Good luck!:slight_smile:

About the BIOS bit: in all probability you don’t need to reset anything, seeing that you only had those three partitions on your previous install.
As for the other drive that worked on your system: generally, this is to be expected from liGNUx – since it’s not Windows, a correctly installed hard drive should work in any PC you move it to.

I will do this tonight, thanks for the advice. I’m sure this is probably what it is.