Again, steam will not start after new install of TW

I’m sorry to bring this up because it has been written about before, but I had to do a complete new reinstall of TW because my hard drive crashed. Steam will not run after install from command line. I have tried to research this but there are so many takes on this issue. I have read several entries from several forums about this. I have not had this problem before. I know that I had to replace some 32 bit libraries at some point because TW does not supply them. But now it looks like there is a driver problem too. What do I need to do STEP-BY-STEP. Thank you all very much!!!

Running Steam on opensuse 20171125 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(0)
libGL error: unable to load driver: radeonsi_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: radeonsi
libGL error: unable to load driver: radeonsi_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: radeonsi
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast

Just in case something in this thread is of help to you…

https://forums.opensuse.org/showthread.php/519256-Steam-crashing-on-Tumbleweed-after-log-in

I saw that and I tried some of workarounds and that did not work. But thanks!

In particular, did you try a creating a new user, or (removing or renaming ~/.local/share/Steam/ to ~/.local/share/Steam.old/), and then try launching steam again?

this seemed to have worked:

Thanks all!!!

Thanks for letting us know what worked for you. It may help others who come searching. :slight_smile:

That did not work after a re-boot. Any ideas?

Now getting this error:
Running Steam on opensuse 20171129 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(0)
/home/ringokde/.local/share/Steam/ubuntu12_32/steam: symbol lookup error: /usr/lib/libxcb-dri3.so.0: undefined symbol: xcb_send_request_with_fds
/home/ringokde/.local/share/Steam/steam.sh: line 444: no match: ssfn*

I understand there are some 32 bit files to be loaded.

would this be of help?
cd ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu
mkdir ~/xcb
mv xcb ~/xcb

Is this package something that I need?
https://software.opensuse.org/download.html?project=games%3Atools&package=steam

Thanks all for your help.

A bug report may be the best course of action IMO.
https://bugzilla.opensuse.org/enter_bug.cgi?classification=openSUSE

try


LIBGL_DRI3_DISABLE=1 steam

in a terminal