Again: First day of week - Sunday vs. Monday

Hi,
I want to use GNOME 2.28.2 in English but not with Sunday but Monday as first day of the week in the calendar of the “Clock 2.28.0” item/app in the panel (If you use only KDE you will only smile on that… :shame:).

I have just switched to en_DK and also logged in with KDE4 and changed the fist day of the week but with no sucess at all in gnome.

And the Gnome “Clock” seems to ignore /etc/sysconfig also.

The solution presented in First day of week - Sunday vs. Monday - openSUSE Forums seems not to work anymore

  • I cannot find any " /usr/share/i18n/" directory if I start gnomesu nautilus.

Do I have to get completely out of GNOME and switch to init 1?

Any ideas?

Greetings pistazienfresser

Thunderbird+Lightning+gnome clock - FedoraForum.org

Novell Documentation - 16.3 System Configuration via /etc/sysconfig

Novell Documentation - 18.4 Language and Country-Specific Settings

Hi
Just set the LC_TIME variable in your user .profile for example, I’m on
en_US, so to set my day to Monday add the following to ~/.profile


export LC_TIME="en_GB.UTF-8"

logout/login


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.45-0.1-default
up 19 days 6:57, 3 users, load average: 0.99, 0.75, 0.67
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 195.36.15

Hi
I logged in with English-UK and the week begins with Monday!
Bye
pistazienfresser

OOps, I saw this only later.
Works even with Englisch_USA in grahical login-mask.
Thank you a lot.
Cheerio!
pistazienfresser

Hello
I’m using OpenSuse 11.4 in italian.
I’ve added the line

export LC_TIME="en_GB.UTF-8" 

to ~/.profile. Now the first day of the week is monday, but the names of months and days are all in english :expressionless:
How can I set the language of calendar in italian?

Thanks

On 2011-07-31 19:46, PincaPalla wrote:
>
> Hello
> I’m using OpenSuse 11.4 in italian.
> I’ve added the line
>
> Code:
> --------------------
> export LC_TIME=“en_GB.UTF-8”
> --------------------
>
> to ~/.profile. Now the first day of the week is monday, but the names
> of months and days are all in english :expressionless:
> How can I set the language of calendar in italian?

You have asked for times to be British, so that’s what you got. The system
is obeying your orders.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

On 07/31/2011 07:46 PM, PincaPalla wrote:
>
> Now the first day of the week is monday, but the names
> of months and days are all in english :expressionless:
> How can I set the language of calendar in italian?

that may give you Italian language…but, not keep monday as first day
of week…try to set the day of the week to begin the week by opening
[NOTE: these directions are specific for KDE4 only, you didn’t say what
DE you use, so you may have to be a little creative] Personal Settings -
Configure Desktop > Common Appearance and Behavior > Locale >
Country/Region and Language > Calendar and spin the “First day of week
to Lunedi”

and, i think somewhere near there you will also find a place to pick
Italian…but, if not you can undo your direction to use British English
(en_GB, American English is en_US) with


export LC_TIME="it_IT.UTF-8"


DD
openSUSE®, the “German Engineered Automobiles” of operating systems!

On 2011-08-01 07:57, DenverD wrote:
> On 07/31/2011 07:46 PM, PincaPalla wrote:

> and, i think somewhere near there you will also find a place to pick
> Italian…but, if not you can undo your direction to use British English
> (en_GB, American English is en_US) with
>
>


> export LC_TIME="it_IT.UTF-8"
> 

Right.

Notice that these locales have normally the settings choosen by the
authorities of each country as correct for that country and language. If
you think that the first day of the week is incorrect for that locale, open
a bugzilla.

However, searching, the italian locale might be “it_IT@euro” or “it_IT” or
“it_IT.utf8” (lower case), if you have a look at “/usr/lib/locale/”.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

you’re right but hope springs eternity. :stuck_out_tongue:

well, with export LC_TIME=“en_GB.UTF-8” I got Monday as first day of the week in English language.
with export LC_TIME=“it_IT.UTF-8” and export LC_TIME=“it_IT@euro” I got Sunday as first day in Italian.

I’ve forgotten to say it: I use gnome and there is not such option.
I’ve googled long time and this is the result: in gnome (I don’t remember since the exactly version) there is not anymore the choice of the first day of the week.

so, it doesn’t matter, thanks to everybody for the help :slight_smile:

On 08/26/2011 11:46 PM, PincaPalla wrote:
> I’ve forgotten it: I use gnome and there is not such option.
> I’ve googled long time and this is the result: in gnome (I don’t
> remember since the exactly version) there is not anymore the choice of
> the first day of the week.
>
> so, it doesn’t matter, thanks to everybody for the help :slight_smile:

welcome…you can hope that in Gnome3 you have an easy way to begin your
calendar’s week on monday…

have you asked the Gnome devs <http://www.gnome.org/> for such a feature??


DD
openSUSE®, the “German Engineered Automobile” of operating systems!

No, I don’t, it’s not so important imho.
Out of curiosity I’ll install kde 4 lol!
Thanks