Again a newbie needing help with wireless


again a newbie with wireless problems
Just installed Suse 11.0 on a IBM Thinkpad T30 with a 3CRPAG175 wireless card.
As so many, I don’t get wireless to work. In the meantime I’ve browsed a lot of forums including this one and I’ve also studied stickys thread about ‘Getting Your Wireless To Work’.

I’ve not setup the card with Yast, I’m using KNetworkmanager. iwlist scan shows the access point (Belkin) correctly. So, the card at least is working and can receive data. Connection to the AP however fails. dmesg shows, that authentification fails.

The AP uses WPA1 personal with PSK. All coordinates are correctly setup in KNetworkmanager, but it doesn’t work.

Now I’d need some help, how to find out what exactly is the problem with the authentification.

A IBM thinkpad T40 with built in Intel wireless device worked out the box with the same distribution and the same AP and the same settings. So it appears to be either the card or the driver (ath_5k).

Thanks in advance.


Webpin - results for “compat-wireless” on openSUSE 11.0

Did you try without WPA or other security in the AP to see if it connects?

Beaten by Akoellh. Will leave it anyway in case it might help. :slight_smile:

…disabled security now at the AP, but still doesn’t connect. dmesg says ‘authentification to …timed out’.

interesting link. However for a Linux newbie a little bit more explanation might help. ;).


Have a look at the output of

uname -r

and choose the right


to install.

Flavor = default, pae, …

Version = 2.6.25something

ok. Flavor = ‘pae’
Kernel-version =

Repository downloaded and succesfully installed with Yast.

And now? What’s next?

Next would be to describe what you installed and give more information by (re)reading the “Sticky” threads in this subforum.

Wireless - openSUSE Forums

I installed the file you told me:

compat-wireless-kmp-pae (20080615_2.6.25.5_1.1)

Don’t it’s content, but obviously it includes a driver change for the wlan card. The new driver is now ath_pci and the interface name changed from wlan0 to ath0. Also the status LED of the card is supported now.

So far, so good. But still no connection possible, neither with WPA Personal nor without encryption.

What comes strange to me from the iwconfig output is, that it says “Encryption key:off” though it was run under WPA encryption enabled in knetworkmanager.
I checked the wpa-supplicant package and it’s installed.

So here I really don’t know, what I can do more. So, if you can additional advice, it’s welcome.

tried to post the output of the iwconfig, but didn’t, because of an error message, saying that it contains to many images (?).

iwconfig output:

lo no wireless extension

eth0 no wireless extension

wifi0 no wireless extension

ath0 IEEE 801.11g ESSID: “LouNet” Nickname: “”
Mode:Managed Frequency:2.442 GHz Access Point:
Bit Rate:1Mb/s Tx-Power:16 dBm Sensitivity=1/1
Retry:Off RTS thr:off
Encryption key:off
Power Management:off
Link Quality=24/70 Signal level=-69 dBm Noise level=-93 dBm
Rx invalid nwid:1333 Rx invalid crypt:0 Rx invalid frag:0 Tx excessive retries:0 Invalid misc:0 Missed beacon:0

ahh, ok, clear now, the colons have been the problem…

No it is not, you must have also installed some madwifi-package.

Why do “newbies” ask for help and then do other stuff than what people suggest you?

The card will also work with madwifi, but now you have two drivers “fighting” for the card unless you did not blacklist one of them.

More information is also appreciated, this is by far not all the info needed.


Why are you saying this to me?
You recommended to run uname -r. I did, output:

You recommended to select the appropriate ‘kmp’ - file for this kernel version from the page you posted. I did, selected file:

‘compat-wireless-kmp-pae (20080615_2.6.25.5_1.1)’

You recommended to install this file. I pushed the install button next to the file and installed it with Yast. That’s where we are now. So, in which respect didn’t I follow your recommendations?

But besides this: I took the laptop to my office this morning, because we do have an open wlan net for guests here. Tried to connect and !It worked!. In fact I’m posting from the laptop now. So, maybe the issue is with the AP. Can you recommend furhter analysis tools to find out, where the problem is?

Because I know that you must have installed some other driver, too.

Be it as it may, but the driver “ath_pci” is not inside compat-wireless and does not give you ath0 and wifi0 (it would give you wlan0 and wmaster0).

As I said, madwifi will also work, but two drivers at the same time ar no good idea.

So either remove madwifi or blacklist ath5k.

yes, I tried to fix the problem by installing the madwifi-package.
But this is already weeks ago.

I installed the package from the opensuse-support page, but couldn’t make it work. Though blacklisting ath_5k, no other driver had been loaded (checked it with Yast) ever. So I thought, that the madwifi package did not include the driver itself, just the utility software. Also when reading, that Suse distributions do not include this package since 10.1 because of licensing issues.
After installing
compat-wireless-kmp-pae (20080615_2.6.25.5_1.1)
the madwifi driver is loaded now, but I did not recognize it as such.
Pls consider, that I’m an Linux newbie. When installing something, I just press an install-button without knowing, what really happens in the background.

After being succesfull to connect to the public wireless network in my company (not encrypted), I worked myself through the iwconfig manual and did some tests with the card.
I recognized, that it is not possible to switch on encryption. Every try to enable encryption with

iwconfig ath0 key on (or with the key itself)

fails with error message (invalid argument). Is there anything known about such an issue with the card and/or madwifi? Do I need to install more software (wpa-supplicant is installed)?

P.S.: ath_5k is blacklisted.

In the meantime, I tried everything I read about in various posts and supportpages.

driver ath5k:
the card does not connect at all

driver ath_pci (madwifi):
the card works and does connect to not encrypted AP’s, but not to WPA encrypted AP. Not when configured with KNetworkmanager, as well as with Yast.

driver: Windows driver with ndiswrapper:
same result as with ath_pci

To me it looks like a problem with the encryption support for WPA. The AP uses WPA1-PSK and the card connected to that AP under Windows, using exactly the same driver as used together with ndiswrapper.

Thanks for any further idea that could help.