After zypper dup windows 10 boots instead of Tumbleweed

So After zypper dup, winsows 10 boots instead of Tumbleweed. :frowning:

This has happened to me before. The solution was always to then boot suse through my mobo bootmenu,.then go into yast, bootoptions, check if its set right and exit by clicking oke.

So I tried to do the same again but this time I got an error.

Uitvoeren van opdracht '"/usr/sbin/shim-install", "--config-file=/boot/grub2/grub.cfg"]]' mislukt.
Exitcode: 5
Foutuitvoer: Installeren voor x86_64-efi-platform.
Installatie is afgerond. Er werden geen fouten gerapporteerd.
Could not prepare Boot variable: No space left on device

After some googling, I went into yast again and uncheck something about vram.

This helped to some extent, there was no error anymore, but after a reboot I see that bloody windows throbber again.
Not what I should see, a grub menu with tumbleweed.

Hi
What is the output of;


efibootmgr -v

I suspect the windows entry is in the list first…

There are 3 hard disk, one windows, one with opensuse leap, and a SSD 980 with tumbleweed.

BootCurrent: 000B 
Timeout: 1 seconds 
BootOrder: 0001,0006,000B,0011 
Boot0001* Windows Boot Manager  HD(2,GPT,70e1d660-fa10-4c6b-af84-2f6220bf4308,0x109000,0x31800)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS.........x
...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...a................ 
Boot0006* Hard Drive    BBS(HD,,0x0)..GO..NO........u.S.T.1.0.0.0.D.M.0.1.0.-.2.E.P.1.0.2....................A.................................>..Gd-.;
.A..MQ..L. . . . . . . . . . . . .N.Z.0.1.9.W.H.5........BO..NO........q.S.a.m.s.u.n.g. .S.S.D. .9.8.0. .1.T.B....................A....................
.......%8....i.....4..Gd-.;.A..MQ..L.S.6.4.9.N.F.0.R.7.1.9.4.2.6.V........BO..NO........u.W.D.C. .W.D.1.0.E.Z.E.X.-.0.8.W.N.4.A.0....................A.
................................>..Gd-.;.A..MQ..L. . . . .W. .-.D.C.W.6.C.2.Y.R.T.3.1.6.F........BO 
Boot000B* opensuse      HD(1,GPT,e309de90-d4c1-41a4-bf93-1838b4eeb944,0x800,0x100000)/File(\EFI\OPENSUSE\GRUBX64.EFI)..BO 
Boot0011* opensuse      HD(1,GPT,a986b7af-7e9a-4f0a-a483-a57562332f53,0x800,0x100000)/File(\EFI\OPENSUSE\GRUBX64.EFI)..BO



In YAST tumbleweed is set as default os.

Hi
So which one do you want first 000B or 0011? I see you booted to 000B…


efibootmgr -o 000B,0011,0001,0006

I have no idea which one is my ssd (tumbleweed) That should be the one to start first.

So how to find out if I want 000B or 0011to boot first ? :slight_smile:

Although its not working now, so I probably want to boot 0011?

Hi
Well your last boot showed 000B, you need to run blkid as root user to see the number to compare in the efibootmgr output, 0006 is the 1TB Samsung SSD, again visible in the output :wink:

So set 0006 first, or use boot next to confirm;


efibootmgr -n 0006

And reboot, if all ok;


efibootmgr -o 0006,000B,0011,0001

If you edit each /etc/default/grub’s GRUB_DISTRIBUTOR= to include a unique string, such as “opensusetw” and GRUB_DISTRIBUTOR=“opensuse154”, then your /boot/efi/EFI/ directories will acquire directories opensusetw and opensuse154 when next the two Grubs have again been updated. After that, there won’t be any confusion in efibootmgr output if you remove the opensuse directory that each is stomping over the other in in the BIOS NVRAM. That ought to stop the BIOS from seeing the confusion as a reason to jump ship to the unique Windows EFI directory.

The above never happened to me, presumably because I figured out what I am doing.
http://mistelberger.net/chillin.svg
When being confused it’s always a good idea to stick to the facts and post them in your comment:

6700K:~ # fdisk -lo Device,Size,Type
Disk /dev/sda: 465.76 GiB, 500107862016 bytes, 976773168 sectors
Disk model: Samsung SSD 850 
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 90C1973B-4A41-4E96-85BA-B7358EA77CCC

Device      Size Type
/dev/sda1   101M EFI System
/dev/sda2    30G Linux filesystem
/dev/sda3    30G Linux filesystem
/dev/sda4   106G Linux filesystem
/dev/sda5  48.8G Linux filesystem
/dev/sda6    16M Microsoft reserved
/dev/sda7  29.7G Linux filesystem
/dev/sda8  59.6G Linux filesystem
/dev/sda9    30G Linux filesystem
/dev/sda10   16G Linux swap
/dev/sda11 56.3G Linux filesystem
/dev/sda12 58.7G Microsoft basic data
/dev/sda13  524M Windows recovery environment
6700K:~ # 

Restarting Windows instead of shutting it down does change the boot order. To fix this you may boot into Windows and go from there to UEFI boot menu. Move Tumbleweed to the top, save the change and quit. This will fix the boot order and queue Windows as the second entry of the boot order:

6700K:~ # efibootmgr 
BootCurrent: 0000
Timeout: 1 seconds
BootOrder: 0000,0007,0002,0003,0004,0005,0006
Boot0000* tumbleweed
Boot0002* manjaro
Boot0003* leap154
Boot0004* Fedora
Boot0005* arch
Boot0006* sled
Boot0007* Windows Boot Manager
6700K:~ # 

BTW You may want to disable fast boot: https://www.laptopmag.com/how-to/turn-off-fast-startup-on-windows-11

Fast boot is disabled, did that already when I build this pc. (unless windows has turned it on again)

Maybe I am gonna disable windows update. I hardly use windows, its only there for some older games, and since those work, I don’t need windows to update.

This time something went wrong after a tumbleweed update , but 9 out 10 times when this happens its after a windows update.

Last night I started to wonder, but you already answered the thing I was wondering about.
If I booted 0006 it is the right hard disk, because I selected the opensuse tumbleweed disk in my bios boot menu.

Gonna try now. -n and -o … fingers crossed.

efibootmgr -n 0006

Does not work, when I tried the bios ? told me to insert a boot device.

Maybe it needs to be 0006B ?

**localhost:/home/guus #** blkid

/dev/nvme0n1p1: UUID="3AB8-553F" BLOCK_SIZE="512" TYPE="vfat" PARTUUID="e309de90-d4c1-41a4-bf93-1838b4eeb944"

/dev/nvme0n1p2: UUID="9c8140f9-0b81-41eb-ab94-d7342c38d218" UUID_SUB="516ade50-eb26-462b-9e77-8fd81a3fe2d5" BLOCK_SIZE="4096" TYPE="btrfs" PARTUUID="72
155361-856f-4c12-8325-119e9b78931c"

/dev/sdb4: UUID="9f94c7ef-ce94-4d99-8ebd-187f0d37b0e1" TYPE="swap" PARTUUID="f807f567-763c-4238-b024-4ac78866afda"

/dev/sdb2: UUID="5a26a5e5-5a43-4deb-9eae-f6e82d358dc2" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="4001277c-e5f4-4312-b7a0-ec9ce2a8aba7"

/dev/sdb5: UUID="b9cf1de0-e38d-46a4-ba88-08665ca8d340" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="3e75a9fd-3629-41c9-bfbc-fdd2a166a01d"

/dev/sdb3: UUID="64d5c6b8-8098-497b-b56a-beb464958102" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="6ff8609f-3e67-4523-81a8-1340953daba5"

/dev/sdb1: UUID="9A90-3F07" BLOCK_SIZE="512" TYPE="vfat" PARTUUID="a986b7af-7e9a-4f0a-a483-a57562332f53"

/dev/sda4: BLOCK_SIZE="512" UUID="EA0E76BE0E76837D" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="5927130e-8679-43f1-9d62-5d879be74451"

/dev/sda2: UUID="9474-CF21" BLOCK_SIZE="512" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="70e1d660-fa10-4c6b-af84-2f6220bf4308"

/dev/sda3: PARTLABEL="Microsoft reserved partition" PARTUUID="0f63e829-852b-4034-97c7-0d95b4013ac1"

/dev/sda1: LABEL="Herstel" BLOCK_SIZE="512" UUID="A63A73D93A73A549" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="30a4fa2a-4d6a-49f6-b576-f85c
3c39644b"




0006 is legacy BIOS boot which was most likely never set up. No surprise it does not work.

For now the problem might be solved.

I booted win 10, then from there went into the uefi, and set tumbleweed as first os to boot. (windows was set as the first os to boot)

The very existence of a boot variable doesn’t guarantee that the referenced boot is available. Tinkering with devices may result in dangling boots. NVRAM doesn’t update automatically.

I booted win 10, then from there went into the uefi, and set tumbleweed as first os to boot. (windows was set as the first os to boot)

Great. With more recent hardware this procedure never fails (to my experience since 2014).

I think, I did not have to boot windows, because the way my pc is set up.

First screen you see at my pc, is a screen with an asrock logo and then bottom right 4 lines.
F something to enter the UEFI,
F11 to enter the boot menu, and two more lines.

Then if all is well, grub pops up after 8 seconds.

I do know however some pc are setup so you will not see that first screen.
Then you will have to go into windows and from there enter the UEFI.

Learned something new, before I used to fix this through YAST, but for reason unknown (and not important), that did not work this time.

Totally happy again, if I just turn on my pc, Tumbleweed will start. If I want to boot windows I need to select it in grub.

I am starting to wonder more and more if my next pc will still be dual boot Linux / Windows.
It might be dual boot but no more windows.

Last week had a big issue
I tried to start windows, and had a lot of trouble to get my password right. lol!
This proofs mostly how long ago it was I had booted windows. it took around 1.5 hours for windows to update… ( do not turn of your pc… >:( )

Log in to windows once, and you instantly remember why you went to Linux.

When I bought a ThinkBook I heard the fan only when updating Windows: https://forums.opensuse.org/showthread.php/574148-Lenovo-Thinkbook-Windows-11-Tumbleweed-dual-boot I followed the suggestion of malcolmlewis. That makes Windows more palatable.

Thank and this reminds me of all the trouble I had, to install windows with UEFI on this pc.

It ended with me in the bios enabling UEFI, then install windows, and after this because of an issue enable legacy mode…

OpenSUSE, not even one problem. :slight_smile:

I have never understood why updating on windows is so annoying, compared to updating on Linux.

Microsoft and me don’t seem to agree on who owns this pc either…

My reason for needing windows is gaming but that list is shrinking day by day. (Proton db)

It might be time for Tombraider here which runs native on Linux.