After upgrading to OS11.2 all USB stop work

I did an upgrade from 11.1 to 11.2 trough console with “zypper dup”(Followed the OpenSUSE guide for upgrade).
When it was finished i rebooted and the new 11.2 came up. But no mouse, keyboard or other USB-devices work.
I try different USB-mouses wireless and wire and none of them works. I also plugged in an external usb-keyboard that also doens’t work.

The computer is a Dell Latitude D830 Laptop. The only thing that work is the internal touchpad. The internal keyboard does not work eighter. The computer is quite useless now :frowning:

Did you checked if all USB-Device Drivers are installed correctly?

It would help if you could post me your kernel version which is installed right now.
Just type:

uname -r

Also i would appreciate a


from you.

Thanks a lot.

> uname -r (32bits)

So my big problem is that no keyboard works, so i have to use another computer to write this.
What i did is to boot up into init 3 and now keyboard works so i can login. If i run “lsmod” then it lists up a long list and a can’t write it all down here, so i did “lsmod | grep usb”:
Thats all…

If i execute init 5 and start KDE, then it seems all USB is disconnectet. If i connect an usb keyboard the Num Lock light dosn’t lid up. I think its something with KDE. OS11.2 downgraded my KDE from 4.3.3 to 4.3.1 so it can be something with that.

BTW: When KDE start an error-msg shows up:

KDEInit couldn’t start “gnome-starter.bsh”.:
Could not find ‘gnome-starter.bsh’ executable.

Gnome-starter in KDE ???

As far as i am not using Gnome Starter, my KDE is not missing that. I think it has something to do with the downgrade of KDE 4.3.3 to 4.3.1. I will have a look on my Computer tonight and hope that i can tell you which package is missing.
Otherwise you have the possibility to install the complete KDE4 Base scheme via yast2, because i think something is missing in your installation. It is also possible tor run yast2 without X11 in init3.

Ok Please check the install schemes in yast:
KDE 4 Base System, KDE 4 Desktop Environment and X Window System. Perhaps that would solve your problem. After that remove outside from X /home/~/.skel.
This will write a new configuration. Its a good idea to backup first.

Thank you for helping me!

Im sorry to say but you need to be more specific. Im not that advanced Linux-user.
How do i check installed schemes?

I run Yast2 and they all KDE4 Base, KDE4 Desktop and X seems installed.
I don’t have enough knowledge to see if something is missing.

Right now i do not trust this system, so what if i delete / and install OS11.2 from beginning? I keep /home, but wich files/folders do i need to delete in my Home-dir to get a clean system-boot?


If you want a clean KDE Login just delete:
/home/~/.skel where ~ is your userfolder,
then delete ~/Desktop and ~/kde

You have to do this outside of KDE and outside of X.

rm -r /home/~/.skel
rm -r /home/~/*Desktop
rm -r /home/~/kde*

Attention, all KDE settings will be turned to default, kmail mails and data will be lost. Also kwallet passwords or any kopete settings.