After upgrading to 13.2 bootloader start text mode system instead graphical

I’ve downloaded the new OpenSUSE 13.2 ISO file (for 32 bit) to create a DVD install disk.
Then I used the DVD to upgrade the existing 13.1 OpenSUSE system.

During the upgrade using the DVD two suspicious facts arisen:

  1. I got a message box informing that network is not configured.
    The message box includes a “Would you like to configure it?” question.
    But answering “Yes” didn’t start network configuration.
    It just prompted the same message window again (and again…).
    Maybe something is missing in the install/upgrade live system?
    I just answered no to go on with the upgrade process.
    (after confirming the message window informing "Cannot download list of repositories, no network configured).

  2. At Performing Upgrade, the process was stuck for a long time in the “Install boot manager” - Saving bootloader configuration.
    Finally, after a long time, the process moved on (including “Saving kdump configuration”, preparation for initial boot and finishing).
    It was suspicious, but I didn’t care that much: I’ve similar thread on this in the past, and I knew I could use Yast to make any need repairs after the upgrade.

  3. After install process and initial boot, I got the bootloader screen.
    I expected to have a new 13.2 entry, but I had a 13.1 and several others 3.11.10-7 and kernel.
    Not that bad.
    But when I tried to start any one of them, the system goes up in text linux mode!
    That’s bad!
    None of the options lead to the graphical OpenSUSE interface!?
    Not even in Safemode.
    It seems they are actually 13.2 versions (harlequim) but in text mode only.

Note that i have a NVidia graphic card.
That means that in the past I had to manually add the correspondent NVidia repository.
It always worked.
In 13.2 release notes, it seems that nouveau is finally included in the initial installation.

But actually something didn’t work.
Note that according to (1), the installation process was totally off-line (because network could not be configured).
So maybe some important install content that should be downloaded during the process is missing.

Any idea how to solve the issue?

Thanks and enjoy the new release!
Miguel

sounds like my issue here

The grub menu is similar to another unrelated issue i had which is easily fixed when you finally log in so that looks to be a red herring for now, it’s all down to the nvidia stuff i’d say :slight_smile:

nouveau has been included in the base install for a long time. It just was not good with some NVIDIA hardware. It is getting better and NVIDIA is giving some support to it.

But that’s about the nvidia driver, the G02 in particular.
I thought you use nouveau?

And a fixed version is already in the repo.
If you have a network connection in text mode, just run “sudo zypper up” and you should get it if you installed the nvidia driver from the repo.
If not, I’d suggest to uninstall the driver again (with YaST e.g., it works in text mode too, or with “zypper rm x11-video-nvidiaG02”), boot to “recovery mode” (it should work then), and install it again (“sudo zypper in x11-video-nvidiaG02”).

If that doesn’t help, you should probably start with telling what graphics card you actually have.
And clarifying whether you installed the nvidia driver now or not might help as well.

Maybe you still have the 13.1 version of the driver installed? (It won’t be removed automatically when you upgrade)
That might fail to work on 13.2.
So try to do the same as above.

Well… I’ve just run “sudo zypper up”.
And I got “Something goes wrong” screen when I tried to boot…

Actually I checked the driver version using “zypper se -s x11-video-nvidiaG02” and I got driver version 304.108.
According another thread it seem it should be 304.123 !? Is that right?
And it should be available in the repo, didn’t it?

So what is wrong here?
Do you think I should try to remove it using “zypper rm x11-video-nvidiaG02” ?
And then re-install it ?

BTW - when I tried “sudo zypper in x11-video-nvidiaG02” I had a “Nothing to do” result, bacause “it’s not available in your repositories”.
Which repository should it be?

I think the main issue, as you said, is that the driver of 13.1 is not automatically removed.
So, after removing it as you said “zypper rm x11-video-nvidiaG02” I just
redefined Nvidia repository (# zypper ar -f ftp://download.nvidia.com/opensuse/13.2/ Nvidia)
and reinstalled the driver (zypper install x11-video-nvidiaG02)

Thank you !!

Right.
And the 304.108 version does not work with the new Xorg in 13.2.

So, after removing it as you said “zypper rm x11-video-nvidiaG02” I just
redefined Nvidia repository (# zypper ar -f ftp://download.nvidia.com/opensuse/13.2/ Nvidia)
and reinstalled the driver (zypper install x11-video-nvidiaG02)

So you probably removed the nvidia repo before upgrading, that’s why it wasn’t found when you ran “zypper up” and “zypper in x11-video-nvidiaG02”.

Thank you !!

Glad to hear that it works now. :slight_smile: