After upgrade to Plasma 6, Kile does not find the Okular library anymore

Dear Forum members, after a recent upgrade to Plasma 6 in Suse Tumbleweed, which I now apparently completed with your help, the Latex editor Kile does not find the Okular library anymore. I have already uninstalled and reinstalled both applications. Does anybody have suggestions?

Please open a terminal and launch kile from there, then copy/paste the result here between preformatted text tags (the </> key above the editing area) so we can see what errors the system outputs.

The output in the terminal is only kf.notifications: Playing audio notification failed: Destroyed

But there is also a pop-up window opening, which states literally (in German):

Kile kann nicht starten, da keine aktuelle Version der Okular-Bibliothek gefunden wurde.

Installieren Sie bitte die Okular-Bibliothek, bevor Sie Kile starten.

In English, this says: Kile cannot start, as there was no current version of the okular library found. Please install the okular library before you start Kile.

Did you make sure you have the correct versions of these for Plasma 6? I imagine you have checked that, but just in case …

Maybe it is something similar to
https://forums.opensuse.org/t/okular-print-preview-broken/173252

Hello Fraser, I am not sure what you are saying here. I have Tumbleweed installed, so I am getting quite a few updates daily, which I install without much consideration. The versions that I have installed are the ones that came to me this way. I have also recently uninstalled and reinstalled both Kile and Okular.

Hello Bruno, that might be. How would I know which links to set?

Concerning a previous answer from you, the menus that I am seeing in the applications, for example in Dolphin, are still a wild mix between English and German. Does that indicate that my installation of Plasma 6 is in fact not yet complete?

You need an Okular and/or Kile user to check that (sorry, it would install a godzillion of packages on my system) but you may try and find something called like libOkular6Core… in /usr/lib64/ or one of its subdirectories.

Sounds similar to
https://forums.opensuse.org/t/no-italian-language-in-kde-after-update-to-plasma-6/173113/2

I was referring to the possibility that the upgrade to Plasma6 might not have changed one of them, there have been missed dependencies in some items.

Wait a moment, I see that kile has not been updated to use Plasma6 yet ant it still requires a bunch of Plasma5 libraries:

bruno@LT-B:~> zypper --no-refresh info --requires kile
Loading repository data...
Reading installed packages...


Information for package kile:
-----------------------------
Repository     : Main Repository (OSS)
Name           : kile
Version        : 2.9.93-3.1
Arch           : x86_64
Vendor         : openSUSE
Installed Size : 8,0 MiB
Installed      : No
Status         : not installed
Source package : kile-2.9.93-3.1.src
Upstream URL   : http://kile.sourceforge.net/
Summary        : A LaTeX Source Editor and TeX Shell
Description    : 
    Kile is a user-friendly TeX/LaTeX editor by KDE.
<snip>
Requires       : [53]
<snip>
   libKF5CoreAddons.so.5()(64bit)
    libKF5I18n.so.5()(64bit)
    libKF5ConfigCore.so.5()(64bit)
    libKF5WidgetsAddons.so.5()(64bit)
    libKF5ConfigWidgets.so.5()(64bit)
    libKF5XmlGui.so.5()(64bit)
    <snip>

so I think that you have two options:
1- wait for an updated kile
2- keep a frozen Plasma5 system just for kile meanwhile (in a Virtual machine perhaps?).

@ysommerh1
@OrsoBruno

Ahhh, yes. This is the kind of issue I was suspecting.

Thank you, Bruno! I fortunately have another relatively new computer running Suse Leap 15.4, so I will use that one for a while until Kile gets updated. Do I understand correctly that the response to your command would that read “…KF6…” instead of “…KF5…”?

I also have the same issue as the user who reported this bug

https://bugs.kde.org/show_bug.cgi?id=483641

which indeed makes a big difference in working with the desktop. So I will probably wait for a solution to that one, too.

Yes, I think so.

Thank you, Bruno!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.