After upgrade to LEAP 15.2 Plasma default Plasma Style can no be selected.

I have upgrade from LEAP 15.1 to LEAP 15.2.
Everything went smoothly and with no problems …
Except … when I started LEAP 15.2 …

Problem 1-
No support for UTF8/Unicode on many KDE apps namelly Dolphin.
I started the new LEAP 15.2 to make sure everything was ok, just change a bit the regional options and it was a complete Mess … to the point were the Windows switch would show windows with no Text, all blurred text. A complete mess.
also gpg encrypted files would not work anymore …a complete mess.
Dolhpin did not even show entire directories due to the fact they were written with non-ascii chars.
Okular did not open files …
A complete mess.
And worse of all: gpg files on disk would not decrypt!
The problem with the files on disk not decrypted was solved by Forcing utf-8 on the Terminal.
I searched online and found this :
I manage to delete the file :
and then forced the Terminal sessions to become utf-8 capable by editing the ~/.bashrc file with :

export LC_ALL=en_US.UTF-8

Also on the local profile file: ~/.profile
I added

export LC_ALL="en_US.UTF-8"
export LC_CTYPE="en_US.UTF-8"

I also made sure /etc/vconsole.conf was set with the correct keyboard mapping in my case:


After this everything was ok with utf8 support and I could decrypt my encrypted files on Terminal.

Then it was time to deal with KDE utf8.
I simply reviewed on yast the system-> language, I had English US and on the details button it mentioned support for utf8.
then going to yast->System->Sysconfig Editor-> System → Environment-> Language and checked RC_LANG was: en_US…UTF-8
I did not mess any other settings.
I also opened KDE System Setting and on RegionalSettings I chose language American English as default and removed everything from Formats.
I logged off, restarted X server (ctrl + backspace twice)
And the problem with utf is aparently gone.

Problem 2 … Can not change Plasma Styles, not yet solved.

I can not Change Style to OpenSuSE Default Style!
That I can not change.
I always had the Default OpenSuSE Theme/Style.
I open for example mc on a Terminal and it is Horrendous! Coloring of the thing is terrible.
There is also no Color set option named openSuSE …
On the Plasma Style I can choose Air OpenSuSE but everytime I click on OpenSuSE it simply selects Air OpenSuSE and I can not delete any Style or choose the OpenSuSE Style.
Did this happen to anyone else?
Anyone with any idea what the cause can be and how to solve it?

How did you upgrade (openSUSE Leap 15.2 installation media, repository change + zypper dup, …)?

Did you keep your /home (which you used with openSUSE Leap 15.1)?

Do the same problems occur with a new user as well?




I indeed need to provide more context.
I upgraded online, changed all the repos manually , rechecked everything went to runlevel 3, and the upgrade went smoothly.
After the upgrade finish then I re-enabled some repo’s I had, electronics, packman and maybe hardware … nothing related to plasm5.
I did indeed kept the /home and actually it is on a separate disk and filesystem.
To complicate matters further this was a system upgraded online from 42.4 to 15.0 then to 15.1 and never had a single problem.
About other users:
All user new and old have the same problem: Plams 5 config is :

  • Global theme: OpenSuSE
  • Plasma Style:I can Not select OpenSuSE … it makes automatically Air OpenSuSE the choice.
    Also I can not delete any plasma Style.
  • Application Style: Breeze (there is also no option for Opensuse)
  • Colors, I use Breeze or OpenSuSE.

I tried already to uninstall and re-install on yast the Opensuse Plasma packages to no avail. The behavior is the same and I am careful to restart the X server.
I have no idea what can have happened to the system, I fear many could have the same problem, specially due to the consecutive upgrades.

In the meantime i tried this on my openSUSE Tumbleweed system and it behaves exactly as your openSUSE Leap 15.2 system (i.e. “Air openSUSE”-style seems to be just another name for “openSUSE”-style)

This might be a “feature”. If you consider it a bug you should open a bug report (



Thank you for your reply and effort to try and reproduce the issue.
And yes I think this is a bug.
If the style was the same as OpenSuSE I would be ok with it but it does change many of the graphical interfaces I’m so used to.
Could you please confirm that there are no OpenSuSE Colors, Application Style and Icons. on the Appearance Plasma options.
Because this might be another issue.
Thanks in advance.

On my openSUSE Tumbleweed system

systemsettings5 -> (Appearance) -> Application Style shows three styles: Breeze, Fusion and MS Windows 9x plus a button Configure Icons and Toolbars at the bottom left corner. Each style presents (when the mouse hovers over it) a small pencil in the bottom right corner. Pressing it will allow to configure the style (Transparency, Scrollbars, …).

systemsettings5 -> (Appearance) -> Colors shows seven colours including openSUSE. However chances are that i installed some colours manually.

By the way: Did you do the update (after you changed your repos) with zypper dup (as far as i know zypper up will not suffice in that situation)?



I just did a fresh installation of openSUSE Leap 15.2 (no /home from previous installation) and had no problems with UTF8 or language (German) or encryption so far.

systemsettings5 -> (Appearance) Colors includes openSUSE.

But in systemsettings5 -> (Appearance) Plasma Style only “Air openSUSE”-style can be selected (“openSUSE”-Style is there but cannot be selected).




On my side I see 3 options that are the same on SystemSettings5 -> Appearance -> Application Style : Breeze, Fusion, MS Windows 9x,Adwaita, Adwaita-Dark, gtk2, qt5ct-style
and another 4 that I may have added from previous installs.

My systemssettings5 Appearance -> Colors show:
Arc, Arc Dark, Aritim Dark, Breeze, Breeze Dark, Breeze High contrast, Breeze Light, openSUSE, openSUSEdark, openSUSEdarkalternate
Note: I have previously removed and re-installed plasma5 openSUSE components.
Also I note that the openSUSE colors are not the same as before at all …

And yes I manually changed all repo’s to the lattest LEAP 15.2 version, then disabled the OBS repo’s.
made sure everything was correct.
Went to runlevel3 and made zypper dup
Everything went smoothly.
what did I miss on the process?

Thanks once again for your effort.
The problems I had with the wrong Character set on encryption were troublesome since they were related to the Regional Settings, same as for the problems on for example Dolphin not showing directories with UTF8 characters on their name.
I was forced to delete the file mentioned earlier but now everything is ok.
I must admit that those problems could have been cause by a mistake I made changing unknowingly the settings while making sure they were correct. I simply can not verify now what the Exact cause of the problem was. That is, what was the Particular settings that cause the malfunction.
But I corrected the problem now and on systemsetting5 there is no option selected on Regional Settings.
And on Yast the default Language is en_US as I explained before and the support for utf8 is also enabled.
Moreover the Konsole as well as the terminal are now forced to have the correct setting for my case, locale shows utf8 support and localectl show the correct keyboard mappings in my case PT.
About the Air Opensuse
Well maybe that is now the default Plasma Style … in any case I truly do not like it at all …
It forced me to actually change on Konsole the entire settings for say Midnight Commenter (mc) as well as Terminal profile.
The default mc was horrendous while working on Konsole! Same for Tmux …
I was forced to learn and remake the entire configuration for : Tmux, mc and the Terminal …
All of that simply because of a horrendous color on the Konsole …
I had to make tmux support 256 colors … requires the creation of the ~/.tmux.conf file and setting

tmux show -g | sed 's/^/set -g /' > ~/.tmux.conf

And than Add the following to the .tmux.conf file:

set -g default-terminal "screen-256color"

that enabled tmux virtual consoles to have 256 color support.
Then I could start my many tmux sessions and windows and enable mc to have a decent color scheme …
I chose F9 -> Options-> Appearence -> modarin256
I also made modarin256 default by editing
and making the skin=modarin256
And Only after all of this does the mc console look ok. Funny note, editing ~/.config/mc/ini with mc (mcedit) does not Change the file! I had to use nano to edit the file!
Of couse on the Terminal 256 colors are not supported and mc returns to the default 16 color mode but there it is ok.
That is reason I think there is a Huge problem with the color settings (Plasma Styler, colors ou something else) after the up-grade.