after upgrade to 15.4 systemsettings crash

Hi, on my desktop PC I upgraded to 15.4 following the instructions here
https://en.opensuse.org/SDB:System_upgrade_to_Leap_15.4
and everything seemed to went fine, but today I started systemsettings and it crashed with this message:
https://paste.opensuse.org/87558225
and if it could be useful it genereted also this trace:
what can I do to have a working systemsettings?

Application: System Settings (systemsettings), signal: Segmentation fault

[KCrash Handler]
#4  0x00007f9b93099b9d in ?? () from /usr/lib64/dri/iris_dri.so
#5  0x00007f9b9309a7d8 in ?? () from /usr/lib64/dri/iris_dri.so
#6  0x00007f9b932790e7 in ?? () from /usr/lib64/dri/iris_dri.so
#7  0x00007f9b930725e7 in ?? () from /usr/lib64/dri/iris_dri.so
#8  0x00007f9b93073cb6 in ?? () from /usr/lib64/dri/iris_dri.so
#9  0x00007f9b92a7e98f in ?? () from /usr/lib64/dri/iris_dri.so
#10 0x00007f9b92a7eb21 in ?? () from /usr/lib64/dri/iris_dri.so
#11 0x00007f9b92a82683 in ?? () from /usr/lib64/dri/iris_dri.so
#12 0x00007f9b92a83778 in ?? () from /usr/lib64/dri/iris_dri.so
#13 0x00007f9b924ba522 in ?? () from /usr/lib64/dri/iris_dri.so
#14 0x00007f9b924bb43a in ?? () from /usr/lib64/dri/iris_dri.so
#15 0x00007f9b92662a47 in ?? () from /usr/lib64/dri/iris_dri.so
#16 0x00007f9b92664830 in ?? () from /usr/lib64/dri/iris_dri.so
#17 0x00007f9bb5146b3e in ?? () from /usr/lib64/libQt5Gui.so.5
#18 0x00007f9bb5146ee8 in ?? () from /usr/lib64/libQt5Gui.so.5
#19 0x00007f9bb546789e in QPlatformBackingStore::composeAndFlush(QWindow*, QRegion const&, QPoint const&, QPlatformTextureList*, bool) () from /usr/lib64/libQt5Gui.so.5
#20 0x00007f9ba4a01a0b in ?? () from /usr/lib64/libQt5XcbQpa.so.5
#21 0x00007f9bb5a6cecd in ?? () from /usr/lib64/libQt5Widgets.so.5
#22 0x00007f9bb5a6dd9b in ?? () from /usr/lib64/libQt5Widgets.so.5
#23 0x00007f9bb5a709e0 in ?? () from /usr/lib64/libQt5Widgets.so.5
#24 0x00007f9bb5a70c77 in ?? () from /usr/lib64/libQt5Widgets.so.5
#25 0x00007f9bb5abd70c in ?? () from /usr/lib64/libQt5Widgets.so.5
#26 0x00007f9bb5abe37c in ?? () from /usr/lib64/libQt5Widgets.so.5
#27 0x00007f9bb5a603ac in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQt5Widgets.so.5
#28 0x00007f9bb5a671a0 in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQt5Widgets.so.5
#29 0x00007f9bb4591ac3 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /usr/lib64/libQt5Core.so.5
#30 0x00007f9bb510f437 in QGuiApplicationPrivate::processExposeEvent(QWindowSystemInterfacePrivate::ExposeEvent*) () from /usr/lib64/libQt5Gui.so.5
#31 0x00007f9bb510f69d in QGuiApplicationPrivate::processWindowSystemEvent(QWindowSystemInterfacePrivate::WindowSystemEvent*) () from /usr/lib64/libQt5Gui.so.5
#32 0x00007f9bb50e748b in QWindowSystemInterface::sendWindowSystemEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Gui.so.5
#33 0x00007f9ba4a0bc9a in ?? () from /usr/lib64/libQt5XcbQpa.so.5
#34 0x00007f9bacbda7fb in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#35 0x00007f9bacbdaba0 in ?? () from /usr/lib64/libglib-2.0.so.0
#36 0x00007f9bacbdac2c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#37 0x00007f9bb45f40dc in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#38 0x00007f9bb459033a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#39 0x00007f9bb4599b37 in QCoreApplication::exec() () from /usr/lib64/libQt5Core.so.5
#40 0x000055f0c3e0da3e in ?? ()
#41 0x00007f9bb3ae72bd in __libc_start_main () from /lib64/libc.so.6
#42 0x000055f0c3e0de6a in ?? ()
[Inferior 1 (process 31315) detached]


Segfault in iris_dri.so intel video driver.

See this thread: https://forums.opensuse.org/showthread.php/573917

Specifically posts #27 & #30

There is also a current bug report: https://bugzilla.opensuse.org/show_bug.cgi?id=1202501

Hmm… Actually I may have prematurely jumped to conclusions there :\ …

Could you provide details of your video hardware and driver.

As said by Tannington.

To be a bit more specific: as a by-pass until this is fixed, add the following line to the user’s file .profile (best is at the end):

export MESA_LOADER_DRIVER_OVERRIDE=i965

log-out/log-in.

(well, that is exactly in post #30 there, but better explained twice).

manythanks, I have an INTEL HD GRAPHICS 630 card with driver i915 (taken fron yast hardware info)
I added at the end of .profile user’s file the

export MESA_LOADER_DRIVER_OVERRIDE=i965

and now systemsettings works,

but the desktop’s icons flickers, they disappear and reappear every about 10 seconds, (sometime about half icons sometimes all) only desktop is affected, other applications like browsers and systemsettings are ok.

how do you think I can to keep an eye on when this bug is fixed?
it’s ok to follow this link?
https://bugzilla.opensuse.org/show_bug.cgi?id=1202501
or other?

I would initially try a re-boot.

If after that the icons still flicker:

Try temporarily disabling compositing by using Alt-Shift-F12 - if that “cures” the flickering then re-enable compositing (Alt-Shift-F12) and
try changing the Rendering Backend ( KDE System Settings -> Display and Monitor -> Compositor - Rendering backend ) - It’s probably currently set to GL3.1, drop that to GL2.0, if still an issue drop to xrender.

It will be necessary to log out / in of KDE between the changes to the rendering backend.

how do you think I can to keep an eye on when this bug is fixed?
it’s ok to follow this link?
1202501 – [iris] SKL-GT2: segfaults with KDE applications
or other?

Yes, of course, just subscribe to the bug.

manythanks tannington, I rebooted twice but icons continue to flicker
using alt-shift-F12 cure the flickering
I went to KDE System Settings -> Display and Monitor -> Compositor - Rendering backend but there isn’t no rendering backend option
https://paste.opensuse.org/64338113
I also remember that there was this option but seems disappeared also from my laptop with 15.3 neon

ok thanks

Hmm… just looked on my TW machine running Plasma 5.25.4 / Frameworks 5.96.0 and the Rendering Backend option has indeed been removed.

Check “~/.config/kwinrc” under the “[Compositing]” section for:

“OpenGLIsUnsafe=”

It will probably be set to “OpenGLIsUnsafe=false”

Whilst logged out of KDE change that to “OpenGLIsUnsafe=true” (if “OpenGLIsUnsafe=” is not present, then create it)

Log back in to KDE and see if that effects a cure.

That of course would just be a cludge, it might be better to just disable compositing at startup until a real solution is found.

You might be better off reporting a bug over at KDE.

If you do, it would probably be useful to include the output of:

qdbus-qt5 org.kde.KWin /KWin supportInformation