after upgrade from open leap 42.1 to openleap 42.2 DVD is not reading DVDs

Hello, I upgradedd my openlepa42.1 64bit to openleap 42.2 64bit using zypper dup flawlessly.
But, I noticed that my DVD drive does not read DVDs. the same device on the same comp opens those DVDs normally in other OS. I Guess that some lib or so is not properly installed. RPm -qa dvd shows that all necessary programs are installed. Please advise

Hi, I noticed that Leap 42.2 cannot read (even recognize nor mount) SOME DVDs: please try several DVDs with different features/lenght/audio content… to see if yours like mine can indeed mount and play SOME of them at least.
I was not able to find a pattern and since I normally don’t watch DVDs on this system I didn’t bother too much.
I can confirm that on the same system, with the proper libdvdcss, packman codecs etc., Leap 42.1 was able to play ANY DVD I tried, as did other more multimedia-friendly distros.
Should you choose to open a bug report I might join for testing.

I tried 4 different different DVDs that I have got from different sources and non of them was opened.
What I have to do in order to open bug report?

Please post the output of the following CLI commands executed by the user “root”:

  • hwinfo --cdrom
  • lsscsi
  • scsi_ready --verbose /dev/sr0

(Assuming that, ‘lsscsi’ is indicating that “/dev/sr0” is the CD-ROM / DVD device.)

In the KDE Info Center, in the “Devices” section, is there any information with respect to “Optical Drives”?

Please post the output of the following systemd journal query (also to be executed by the user “root”): journalctl --this-boot | grep -iE 'cdrom|DVD’

Please check the following pastebin in which you can find outputs to commands that you suggested:

here are other outputs:
[0:0:0:0] disk ATA ST3160815AS A /dev/sda
[1:0:1:0] cd/dvd HL-DT-ST DVDRAM GH24NSD1 LG00 /dev/sr0

scsi_ready --verbose /dev/sr0
sg_turs -v /dev/sr0
test unit ready cdb: 00 00 00 00 00 00
test unit ready:
Fixed format, <<<deferred>>>; Sense key: Not Ready
Additional sense: Medium not present - tray open
device not ready
I do not use KDE. I use XFCE.

journalctl --this-boot | grep -iE ‘cdrom|DVD’
Mar 06 17:36:58 linux-c4jm systemd-sysctl[118]: Couldn’t write ‘0’ to ‘dev/cdrom/autoclose’, ignoring: No such file or directory
Mar 06 17:36:59 linux-c4jm kernel: ata2.01: ATAPI: HL-DT-ST DVDRAM GH24NSD1, LG00, max UDMA/133
Mar 06 17:36:59 linux-c4jm kernel: scsi 1:0:1:0: CD-ROM HL-DT-ST DVDRAM GH24NSD1 LG00 PQ: 0 ANSI: 5
Mar 06 17:36:59 linux-c4jm kernel: sr 1:0:1:0: [sr0] scsi3-mmc drive: 48x/48x writer dvd-ram cd/rw xa/form2 cdda tray
Mar 06 17:36:59 linux-c4jm kernel: cdrom: Uniform CD-ROM driver Revision: 3.20

Basically, it seems that Linux as such has detected and can use the DVD / CD-ROM drive.

Given that I’m using KDE Plasma 5 on this Leap 42.2 and, do not have any issues accessing and/or reading DVDs, DVD-RAMs or CDs, it may be that there’s an issue with the GUI.I use KDE Plasma exclusively and am therefore jumping out of this discussion.

IT is possible that GUI is causing issues, but in OpenLeap 42.1 everything worked well with XFCE like in 42,.2


When I test DVDs, I separate them into the following classifications…

  • Commercial DVDs - Nowadays, the majority of them will be digitally protected against copying which can sometimes cause a disk not to be readable. These test disks must be “original” purchase, eg from a store and not a copy.
  • Copied Commercial DVDs - These disks would have had to have had encryption broken during the copy process.
  • Home made data disks - Start with a blank disk, write something to it, generally folders and files like on a hard drive.
  • Home made media DVDs - Home made (or at least non-commercial) created with content menu so it can look something like a commercial DVD, but is home made.

If your problem is <only> Commercial DVDs, then your problem is likely related to the app used to play, and the libraries associated with it. There is no guarantee, but try using a widely used player like VLC.

If you are unable to play DVDs from every one of the above categories, and especially if they are readable in another OS, then the problem is more difficult to pin point.


The problem is persistent with all types of DVD except blank DVDs. I installed K3B and K3B sees that there is medium inside and that there is no space left on it. But, it cannot enter into it and show folders/files on it.
So, I think that the point is in librray/process that reads content, but not only information on media.


Start here and follow this guide

I have done that. You can test if you like.

@veki: please show the result of

zypper lr -d

maybe you still have an old (42.1) repository enabled?