After upgrade from 42.3 to 15.0, nmon does not run

Gnome desktop

Running the app “nmon” in a terminal now produces the error “Error opening terminal: xterm-256color.” The terminal window is Gnome terminal which is also the one used for remote logins.

nmon works properly if I open it in an xterm window.

Questions:

  1. Is there a way to restore the 256color feature to the default terminal?
  2. How do I configure remote logins to use an xterm window?

I don’t have “nmon” installed and I mostly use KDE, so I have tried to check.

Most likely “nmon” does not like the terminfo data for an xterm-256color terminal.

Maybe try:

TERM=xterm nmon

Hmm.

$ echo $TERM
xterm-256color

Adding the following to .bashrc resolved the issue.

export TERM=xterm

if that was a live upgrade I’d check if all packages are for LEAP 15 ie there are no 42.x packages left behind

rpm -qa --queryformat "%{Name}:%{Distribution}
" | grep -F "42"

edit
I didn’t read the whole post it’s good that you fixed it

Well, sort of fixed it. The output is rather uneven. Maybe another TERM value?