After updating X fails

I got a laptop (ACER 4820GT) with an integrated intel HD graphic card (which comes with the i3-350M processor) and a ATI mobility R HD5650. I installed OpenSUSE 11.3 last night and everything works fine though drivers were not installed and desktop effects can not be enabled. However, after connected to the internet and got updated this morning, the system just can not start again, it ran into black screen half way of startup and then lost response. What I really want to see is I can block up the ATI graphics and the system running properly with the intel one. However, after searching this forum, I found there may not be proper driver for some intel graphics.
I’m now trying to install the ATI driver and block the intel graphics using BIOS option and see what will happen. Hope it works.:frowning:

Now I can get to see the desktop but with a horrible delay when scroll in Firefox, needless to say desk effects still inapplicable. I think the driver is still not properly installed though it reported as so. What is ironic is that when I first tried the 11.3 OS on the live CD, everything is fine – desktop effects runs smoothly; after fully installed from DVD, I lost desktop effects while application still runs smoothly; and after running updates, things just won’t work any more and even after it works, it jams like a computer comes from ten years ago.

It’s a well known issue: You have to recompile the ATI fglrx driver after a kernel update. Unfortunately it doesn’t work. You’ll find many comments and solutions (there are at least 3 or 4) in this thread
ATI Catalyst graphics driver install failure in SuSE 11.3
or in that one
Permanent solution to FGLRX/Kernel issue?.
And there a couple other threads focusing on this problem too.

Thank you for your respond which is beyond my expectation. To my, the current release is not yet robust, I’m going to uninstall the OS and run it on a virtual machine. I’m pleased to see the improvement of Linux system over time, but new hardware always take time to be fully supported in the world of Linux, especially those of laptops. I think I have the patient to wait and hope the problem will be fixed in the next release.