After updating to KDE 4.4.2 from KDE repos, Phonon only displays pulseaudio which doesn't work

My sound card disappeared from Phonon upon the update and the pulseaudio “sound card” doesn’t work.

Any idea what to do with this? How can I get my sound card back?

I also updated to KDE 4.4.2 and my sound card was not present as well. However, I discovered that alsa was un-installed and the yast-sound application was removed during the KDE 4.4.2 update. I got sound back by reinstalling yast-sound and alsa and other related files that showed up when searching on sound and alsa.

I still do not show anything but plusaudio in the Personnel Settings>Computer Administration>Multimedia section, but sound works just fine in everything. I think the problem is with Phonon & Alsa, and most likely will be working properly by the time openSUSE 11.3 comes out. However, this is one of the issues you can run in to when trying to use the latest KDE version.

Thank You,

My update didn’t remove any packages, but I just managed to restore the original functionality by using:

setup-pulseaudio --disable

So when you used the command “setup-pulseaudio --disable” did this cause anything to show up in your multimedia section?

Thank You,

Yes, my soundcard is back.

Well I gave the pulse audio disable command a try and it indeed worked for me as well. For those that might have this problem, here is the solution provided to us by Let_Me_Be.

Start a Terminal Session:

su
Password:
setup-pulseaudio --disable

You get a lot of action after the command. When complete, log out of KDE to restart a new session and then check to see if your sound card has been restored to your Multimedia section.

Thank You,

Let_Me_Be, pulseaudio isn’t installed by default, at least from 11.2 on. Are you using an older version than 11.2?

Anyway, glad you got it working but I would just uninstall all of the pulseaudio packages.