After updated, my opensuse kde can't start graphic interface

I just installed opensuse kde 11.1 and updated system. before updating, it just work fine.after updated and when i reboot, opensuse can just run the text mode.
i tried to reboot again and use “init 5” ,it just did seems it had been running level 5.
there isn’t any error during system booting. i don’t know what goes wrong.
i just want my graphic mode back. can somebody help me, please~?or know what’s the problem?

rotfl! i hope you can understand what i said. anybody correct my syntax should be welcome lol! or if there’s somebody know Chinese?

my system
opensuse 11.1 kde 4.1.3 32bit
my PC components:
CPU:AMD PhenomII X3 710
MOTHERBOARD:Gigabite MA770T-UD3P with 770chipsets
GRAPHIC CARD: Powerland Radeon 4830 with 512MB memory
MEMORY:Kingstone DDR3 1333 2G*2
HARDDISK:WD Greendisk 1TB work under AHCI MODE

You must have manually installed graphics drivers. I always have this issue when updating kernel.

So, reinstall your graphics drivers and run

init 3
sax2 -r -m 0=fglrx

Then, restart window manager by running

init 5

My guess is you updated your kernel as well and your graphics driver needs to be reconfigured for the new kernel. Are you using the official ati driver? If so, did you install it straight from yast or did you download it from the ati website? If you downloaded from the ati website, su into the root account and run

Also, if you run startx from the console, some error or other should pop up.

I had just new installed a standerd package suse and didn’t install anything else, either the development packages or graphic card driver. I saw that it’s recommand “update your system to the newest,and then install the graphic card driver”. So I first updated suse first after installed.
And now, I don’t know whether my system is installed with all the packages which will be need during installing the graphic card driver, like kernel Source and Kernel Headers.
I think maybe I should try to install the graphic card driver first.

You mentioned that you updated KDE…What version did you update from, and what version did you update to?

This problem can be totally independent from the kernel update. When the system is starting in the default runlevel, do you see the login screen, or it’s switching to command line login?

I just run the system’s updater and installed all the fixes. The version is opensuse 11.1 KDE 4.1.3 before updated, but I don’t know what version I have updated to.

Now I have tried to install the newest driver downloaded from AMD official website, and the KDE GUI started again! But there’s a problem that the KWin is just keep crashing. I’ll try to put a screen print.

I can even not close the windows now. All the windows title bar are disapear.

Finally, I find the reason why the GUI didn’t work! It all because the graphic card driver. The first time I tried to install the driver was in the graphic mode, and it just said install finished but didn’t show what went wrong during installing. In fact, the driver didn’t install successfully. It is why the KWin kept crashing.
Hopefully, I still can install the GNOME environment. After installed GNOME, I installed all the packages needed during installing griphic card driver. At the end, I installed the driver successfully! now, the system is running well, and the KWin doesn’t go crash anymore.

Don’t believe the AMD driver says it can support your system with precompiled package. You should just install all the packages follow:
Kernel Source *
Kernel Headers
gcc *

  • : must be installed
    Just check one by one and install the missing packages.
    The driver can be compiled automatically when installing by recommand way.
    After all, the official driver now is good enough.