After update, XEN DomU lost all tcp connection

Not a very experienced XEN user here. I googled a lot, and can’t find any relevant answer.

I set up an OpenSUSE 15.4 XEN server with 3 Dom0. It has 2 ethernet card and a wifi card.

It worked perfectly until updating. After updating the DomU lost all tcp connections.

The configuration is: 1 ethernet card connected to ISP’s dsl modem, the other connected to local net, and is a member of the br0 bridge. Other members are vif0, vif1, vif2, tap0 (openvpn) and wlan0 (hostap). The brctl show it. Connection to internet, routing, the vpn, the dhcp server and the Dom0s works perfectly, but I can’t ssh, vnc, webmin to DomU, virt-manager can’t connect, the ifconfig (ip addr), route (ip route) hang up. The nmap and netstat shows all needed ports open. The ping works. The load is extremely high (more than 20). The libvrtd’s CPU load is 100%. I upgraded the DomU to 15.5, but no difference. The shutting down time is about 1 hour. Without XEN kernel everything works properly.

Any suggestions to fix?

Thanks for any suggestions.

P.S Sorry for my bad English.

Sorry, I mixed the Dom0 and DomU naming. :slightly_frowning_face:
The problem is in hostapd.config file. Sorry.

Do you mean you’ve managed to fix this now?

And if not, which update are you referring to in your original post?

Yes, I fixed it. The hostapd must be start at the end of booting. I don’t know why.
The kernel update was to 5.14.21-150400.24.81-default

OK, glad you sorted it. I asked about the update, because there have been some problems because of that update, and OpenSuse have retracted it.

See, for example: Lots of kernel warnings after kernel update