After update to xorg-x11-server-7.5_1.9.0-76 black screen

Hi there,

using two screens frequently I’m curious to find out whether Randr 1.4 performs without some bugs of v. 1.3

So I tried to install the new x-server: http://download.opensuse.org/repositories/X11:/XOrg/openSUSE_11.3/i586/xorg-x11-server-7.5_1.9.0-76.1.i586.rpm

and the other packages it depends upon. But the X-server crashes. I add the log, shortened to beginning and end of the log.

As you might notice, the software looks for fonts, e.g. “/usr/share/fonts/TTF/”, which are not available, sets them to /usr/share/fonts/misc:unscaled,
which are available, but for unknown reasons it does not work. What a pity!

For any help I’d be thankfull,

Regards,
Alexander

    20.985] 
X.Org X Server 1.9.0
Release Date: 2010-08-20
    21.011] X Protocol Version 11, Revision 0
    21.011] Build Operating System: openSUSE SUSE LINUX
    21.011] Current Operating System: Linux linux-yg22 2.6.35.1-1-desktop #1 SMP PREEMPT 2010-08-13 02:39:29 +0200 i686
    21.011] Kernel command line: root=/dev/disk/by-id/ata-ST9500420ASG_5VJ11B15-part2 resume=/dev/disk/by-id/ata-ST9500420ASG_5VJ11B15-part1 splash=silent quiet vga=0x345
    21.011] Build Date: 25 August 2010  01:40:36PM
    21.011]  
    21.011] Current version of pixman: 0.18.0
    21.011] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
    21.011] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    21.011] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Aug 26 11:21:58 2010
    21.012] (==) Using config directory: "/etc/X11/xorg.conf.d"
    21.081] (==) No Layout section.  Using the first Screen section.
    21.081] (**) |-->Screen "Default Screen" (0)
    21.081] (**) |   |-->Monitor "Default Monitor"
    21.081] (**) |   |-->Device "Default Device"
    21.081] (==) Automatically adding devices
    21.081] (==) Automatically enabling devices
    21.082] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
    21.082] 	Entry deleted from font path.
    21.082] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
    21.082] 	Entry deleted from font path.
    21.082] (WW) The directory "/usr/share/fonts/misc/sgi" does not exist.
    21.082] 	Entry deleted from font path.
    21.082] (==) FontPath set to:
	/usr/share/fonts/misc:unscaled,
	/usr/share/fonts/Type1/,
	/usr/share/fonts/100dpi:unscaled,
	/usr/share/fonts/75dpi:unscaled,
	/usr/share/fonts/URW/,
	/usr/share/fonts/cyrillic:unscaled,
	/usr/share/fonts/truetype/
    21.082] (==) ModulePath set to "/usr/lib/xorg/modules/updates,/usr/lib/xorg/modules"
    21.082] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
    21.082] (II) Loader magic: 0x8237940
    21.082] (II) Module ABI versions:
    21.082] 	X.Org ANSI C Emulation: 0.4
    21.082] 	X.Org Video Driver: 8.0
    21.082] 	X.Org XInput driver : 11.0
    21.082] 	X.Org Server Extension : 4.0
    21.083] (--) PCI:*(0:1:0:0) 1002:7145:17aa:2006 rev 0, Mem @ 0xd8000000/134217728, 0xee100000/65536, I/O @ 0x00002000/256, BIOS @ 0x????????/131072
    21.083] (II) Open ACPI successful (/var/run/acpid.socket)
    21.083] (II) LoadModule: "extmod"
    21.099] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
    21.106] (II) Module extmod: vendor="X.Org Foundation"
    21.106] 	compiled for 1.9.0, module version = 1.0.0
    21.106] 	Module class: X.Org Server Extension
    21.106] 	ABI class: X.Org Server Extension, version 4.0
    21.106] (II) Loading extension ...

...

    21.144] (II) [KMS] Kernel modesetting enabled.
...
...    21.221] (II) RADEON(0): Supported detailed timing:
    21.221] (II) RADEON(0): clock: 90.0 MHz   Image Size:  305 x 228 mm
    21.221] (II) RADEON(0): h_active: 1400  h_sync: 1448  h_sync_end 1560 h_blank_end 1688 h_border: 0
    21.221] (II) RADEON(0): v_active: 1050  v_sync: 1051  v_sync_end 1054 v_blanking: 1066 v_border: 0
    21.221] (II) RADEON(0): Unknown vendor-specific block f
    21.221] (II) RADEON(0):  LP150E05-A2
    21.221] (II) RADEON(0): EDID (in hex):
    21.221] (II) RADEON(0): 	00ffffffffffff0030ae434000000000
    21.221] (II) RADEON(0): 	000f0103801e1778eaaf009958538c2a
    21.222] (II) RADEON(0): 	25505421080081800101010101010101
    21.222] (II) RADEON(0): 	010101010101302a7820511a10403070
    21.222] (II) RADEON(0): 	130031e41000001828237820511a1040
    21.222] (II) RADEON(0): 	3070130031e4100000180000000f0090
    21.222] (II) RADEON(0): 	4332904328140600320c0000000000fe
    21.222] (II) RADEON(0): 	004c503135304530352d41320a20009b
    21.222] (II) RADEON(0): Printing probed modes for output LVDS
    21.222] (II) RADEON(0): Modeline "1400x1050"x60.0  108.00  1400 1448 1560 1688  1050 1051 1054 1066 -hsync -vsync (64.0 kHz)
    21.222] (II) RADEON(0): Modeline "1400x1050"x50.0   90.00  1400 1448 1560 1688  1050 1051 1054 1066 -hsync -vsync (53.3 kHz)
    21.222] (II) RADEON(0): Modeline "1280x1024"x59.9  109.00  1280 1368 1496 1712  1024 1027 1034 1063 -hsync +vsync (63.7 kHz)
    21.222] (II) RADEON(0): Modeline "1280x1024"x60.0  108.00  1280 1328 1440 1688  1024 1025 1028 1066 +hsync +vsync (64.0 kHz)
    21.222] (II) RADEON(0): Modeline "1280x960"x59.9  101.25  1280 1360 1488 1696  960 963 967 996 -hsync +vsync (59.7 kHz)
    21.222] (II) RADEON(0): Modeline "1280x854"x59.9   89.25  1280 1352 1480 1680  854 857 867 887 -hsync +vsync (53.1 kHz)
    21.222] (II) RADEON(0): Modeline "1280x800"x59.8   83.50  1280 1352 1480 1680  800 803 809 831 -hsync +vsync (49.7 kHz)
    21.222] (II) RADEON(0): Modeline "1280x720"x59.9   74.50  1280 1344 1472 1664  720 723 728 748 -hsync +vsync (44.8 kHz)
    21.222] (II) RADEON(0): Modeline "1152x768"x59.8   71.75  1152 1216 1328 1504  768 771 781 798 -hsync +vsync (47.7 kHz)
    21.222] (II) RADEON(0): Modeline "1024x768"x60.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz)
    21.222] (II) RADEON(0): Modeline "1024x768"x59.9   63.50  1024 1072 1176 1328  768 771 775 798 -hsync +vsync (47.8 kHz)
    21.222] (II) RADEON(0): Modeline "800x600"x60.3   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz)
    21.222] (II) RADEON(0): Modeline "800x600"x59.9   38.25  800 832 912 1024  600 603 607 624 -hsync +vsync (37.4 kHz)
    21.222] (II) RADEON(0): Modeline "848x480"x59.7   31.50  848 872 952 1056  480 483 493 500 -hsync +vsync (29.8 kHz)
    21.222] (II) RADEON(0): Modeline "720x480"x59.7   26.75  720 744 808 896  480 483 493 500 -hsync +vsync (29.9 kHz)
    21.222] (II) RADEON(0): Modeline "640x480"x60.0   25.20  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz)
    21.222] (II) RADEON(0): Modeline "640x480"x59.4   23.75  640 664 720 800  480 483 487 500 -hsync +vsync (29.7 kHz)
    21.228] (II) RADEON(0): EDID for output DVI-0
    21.228] (II) RADEON(0): Output VGA-0 disconnected
    21.228] (II) RADEON(0): Output LVDS connected
    21.228] (II) RADEON(0): Output DVI-0 disconnected
    21.228] (II) RADEON(0): Using exact sizes for initial modes
    21.228] (II) RADEON(0): Output LVDS using initial mode 1400x1050
    21.229] (II) RADEON(0): Using default gamma of (1.0, 1.0, 1.0) unless otherwise stated.
    21.229] (II) RADEON(0): mem size init: gart size :1fdff000 vram size: s:8000000 visible:7a1c000
    21.229] (II) RADEON(0): EXA: Driver will allow EXA pixmaps in VRAM
    21.229] (==) RADEON(0): DPI set to (96, 96)
    21.229] (II) Loading sub module "fb"
    21.229] (II) LoadModule: "fb"
    21.230] (II) Loading /usr/lib/xorg/modules/libfb.so
    21.244] (II) Module fb: vendor="X.Org Foundation"
    21.244] 	compiled for 1.9.0, module version = 1.0.0
    21.244] 	ABI class: X.Org ANSI C Emulation, version 0.4
    21.244] (II) Loading sub module "ramdac"
    21.244] (II) LoadModule: "ramdac"
    21.244] (II) Module "ramdac" already built-in
    21.244] (II) Loading sub module "exa"
    21.244] (II) LoadModule: "exa"
    21.244] (II) Loading /usr/lib/xorg/modules/libexa.so
    21.253] (II) Module exa: vendor="X.Org Foundation"
    21.253] 	compiled for 1.9.0, module version = 2.5.0
    21.253] 	ABI class: X.Org Video Driver, version 8.0
    21.253] (II) UnloadModule: "fbdev"
    21.253] (II) Unloading /usr/lib/xorg/modules/drivers/fbdev_drv.so
    21.253] (II) UnloadModule: "fbdevhw"
    21.253] (II) Unloading /usr/lib/xorg/modules/libfbdevhw.so
    21.253] (II) UnloadModule: "vesa"
    21.253] (II) Unloading /usr/lib/xorg/modules/drivers/vesa_drv.so
    21.253] (--) Depth 24 pixmap format is 32 bpp
    21.253] (II) RADEON(0): [DRI2] Setup complete
    21.253] (II) RADEON(0): [DRI2]   DRI driver: r300
    21.253] (II) RADEON(0): Front buffer size: 5808K
    21.253] (II) RADEON(0): VRAM usage limit set to 107308K
    21.253] (==) RADEON(0): Backing store disabled
    21.253] (II) RADEON(0): Direct rendering enabled
    21.253] (II) RADEON(0): Render acceleration enabled for R300/R400/R500 type cards.
    21.253] (II) RADEON(0): Setting EXA maxPitchBytes
    21.253] (II) EXA(0): Driver allocated offscreen pixmaps
    21.253] (II) EXA(0): Driver registered support for the following operations:
    21.253] (II)         Solid
    21.253] (II)         Copy
    21.253] (II)         Composite (RENDER acceleration)
    21.253] (II)         UploadToScreen
    21.253] (II)         DownloadFromScreen
    21.253] (II) RADEON(0): Acceleration enabled
    21.253] (==) RADEON(0): DPMS enabled
    21.253] (==) RADEON(0): Silken mouse enabled
    21.253] (II) RADEON(0): Set up textured video
    21.253] (II) RADEON(0): RandR 1.2 enabled, ignore the following RandR disabled message.
    21.254] (--) RandR disabled
    21.254] (II) Initializing built-in extension Generic Event Extension
    21.254] (II) Initializing built-in extension SHAPE
    21.254] (II) Initializing built-in extension MIT-SHM
    21.254] (II) Initializing built-in extension XInputExtension
    21.254] (II) Initializing built-in extension XTEST
    21.254] (II) Initializing built-in extension BIG-REQUESTS
    21.254] (II) Initializing built-in extension SYNC
    21.254] (II) Initializing built-in extension XKEYBOARD
    21.254] (II) Initializing built-in extension XC-MISC
    21.254] (II) Initializing built-in extension SECURITY
    21.254] (II) Initializing built-in extension XINERAMA
    21.254] (II) Initializing built-in extension XFIXES
    21.254] (II) Initializing built-in extension RENDER
    21.254] (II) Initializing built-in extension RANDR
    21.254] (II) Initializing built-in extension COMPOSITE
    21.254] (II) Initializing built-in extension DAMAGE
    21.267] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
    21.267] (II) AIGLX: enabled GLX_INTEL_swap_event
    21.267] (II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
    21.267] (II) AIGLX: enabled GLX_SGI_make_current_read
    21.267] (II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
    21.268] (II) AIGLX: Loaded and initialized /usr/lib/dri/r300_dri.so
    21.268] (II) GLX: Initialized DRI2 GL provider for screen 0
    21.268] (II) RADEON(0): Setting screen physical size to 370 x 277
    21.268] [dix] Could not init font path element /usr/share/fonts/misc:unscaled, removing from list!
    21.268] [dix] Could not init font path element /usr/share/fonts/Type1/, removing from list!
    21.269] [dix] Could not init font path element /usr/share/fonts/100dpi:unscaled, removing from list!
    21.269] [dix] Could not init font path element /usr/share/fonts/75dpi:unscaled, removing from list!
    21.269] [dix] Could not init font path element /usr/share/fonts/URW/, removing from list!
    21.269] [dix] Could not init font path element /usr/share/fonts/cyrillic:unscaled, removing from list!
    21.269] [dix] Could not init font path element /usr/share/fonts/truetype/, removing from list!
    21.269] [dix] Could not init font path element built-ins, removing from list!
    21.269] 
Fatal server error:
    21.269] could not open default font 'fixed'
    21.269] 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
    21.269] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
    21.269] 
    21.269] (II) AIGLX: Suspending AIGLX clients for VT switch

Yes the new version of the X11: forked my entire system I had to re-install everything from sratch, then again I was running a candidate kernel 2.6.35.1 which worked beautifully up until I upgraded to x release 7.5. From command prompt you should have complete access to yast try searching for X11 and look at your video drivers, which may not be your case? try xstart to start windows I would make a backup of your xorg.conf file i.e xorg.oldconfig and run the reconfiguration tool for x and then try restarting x.

Hello,

a new attempt using the version of x-org-server /-driver /-input from August 29th failed again, exactly same result. But I realise somebody is working heavily on the new x-server at openSuse, so: good luck!

I just stumbled over same problem: the release numbers of the packages are reset to 1 bevore they role over 100. Therefore newer packages are no longer installed.

I removed all packages which are present in this repository and reinstalled all of them. Of course of you can check each package and replace only the old ones.

Now X is working again :slight_smile:

HTH,
Bernhard

Indeed, that did the trick.

Thank you very much!

Regards,

Alexander