after update plasmashell and many KDE apps black

After a normal zypper dup yesterday (zypper history at the end of post) I get only a blank plasmashell and krunner after login and some KDE apps (e.g. KMail, SystemSettings) only show a blank window. Other KDE apps like dolphin or Konsole and pure Qt apps are working fine though.
In practice, it looks like that:

As you can see plasmashell (including logout overlay and lockscreen) and krunner show no content, KMail and SystemSettings show a mostly black window. KMail also shows this issue when running standalone e.g. under IceWM

plasmashell is started after login, but gets killed a restarted after a while (see plasmashell log at the end of post). The log is full of QPainter errors

I’m running openSUSE tumbleweed on a ThinkPad X230 with Intel graphics and am still using the X11 session of KDE

KMail log

$ kmail                                                                                                                                                                                                     147 ↵
No protocol specified
[0208/] Failed to open file: /home/myuser/#269540592 (deleted)
  Error: No such file or directory
No protocol specified
No protocol specified
1 : "Uncaught ReferenceError: qt is not defined"
1 : "Uncaught ReferenceError: qt is not defined"

plasmashell log:

zypp history:

This is due to a bug in Mesa which has already been fixed, updated package has been pushed through the Update repo.
But … you need to remove both /var/lib/sddm/.cache and your users’ ~/.cache , since the broken packages have already writen a corrupted cache. After doing so, all should be back to normal.

I had this issue and this fix worked for me.

snapper rollback

saved me. :slight_smile:

Nice, that fixed it.

Is there a way to find out about additional steps todo like these? Gentoo for example has a news messaging system built in to their package manager for caseslike these.

This case is a very rare exception. IMNSHO it should never have been done like this, i.e. that manual user interference is needed. For emergency cases we have the Update repo, to push out security fixes and urgent bug fixes. Zypper does not have such a messaging system.

Thanks. This just worked for me today.