After update Firefox 115.0esr (64-bits) shows black at window top


Did a YaST > Online Update. this morning and got Firefox 115.0esr (64-bits). All of a sudden the top of the FF windows (the part with the main menus (like “File”, … “Extra”, “Help”) and the row of tabs went negative: white characters on black.

That wasn’t before. I will not rant here about developers that change interfaces without asking the users, but how can this be undone. I hope with one (or two) of the hundreds of parameters in about:config, but which one?

Did a zypper updateand got business as usual:

leap154:~ # journalctl -b -1 -u init.scope -g upd
Jul 24 21:04:11 leap154 systemd[1]: Started Distribution Update.
Jul 24 21:11:26 leap154 systemd[1]: upd.service: Deactivated successfully.
leap154:~ # 

Firefox 115.0esr works as every previous version. No tinkering required.

Hi Henk. Different FF version but same symptoms after update….

Hopefully relevant to your situation.

Thanks for the hint. While it looks like mine, it is about things happening two years ago.

I tried a few of those there, but it does not help (or I am chagning things the wrong way, I never know if thes changes will be vissible immediately or after restarting FF).

What i notice only now is that when the window is not active, it changes to light grey on darker grey (sigh!) instead of white on black. It thus changes together with the window borders that change colour when (de)activating the window. I am not even sure that that is something that should happen at all, the application acting on what the window manager does.

And they talk there about “a dark theme” it apparently seeks to adapt to. I am not aware of any “dark theme” that I should have (do not even know how to get that).


Henk, which Desktop GUI are you using?

Here on Leap 15.5 and KDE Plasma with the following Desktop settings:

  • Global design: openSUSE
  • Application style: Oxygen
  • Plasma style: Air openSUSE
  • Colours: my variant of the openSUSE colour scheme …
  • Window decoration: Oxygen
  • Symbols: Oxygen
  • Pointer: Oxygen-White

With this totally against the current KDE Plasma default settings scheme, I’m not experiencing your Firefox issue.

Did you check what theme is set in firefox? You could set a seperate “dark theme” just for firefox. I think while trying LXQt I had some similar issues and it was because firefox didn’t adjust to the settings of my openbox themeing or something like that.

You can find the firefox theme settings in about:addons

“light”, “dark” and “system theme” are always included I think, even without installing anything in addition.

Edit: I am not so familiar with KDE but in LXQt I also used Kvantum, I think that’s a KDE software. I just don’t know if it is used by default.

The same issue you were experiencing happened here. I stumbled upon a way to fix it, although I do not know why it works.

With me the title bar is blue and the top of the screen went blue. So I tried if it would change with the color settings of KDE. And it did. But when i returned to the settings I prefer, the blue part of the window reverted to what I had before the update (black text on grey and white backgrounds). No guarantees, but what worked for me, may work for you.

I preferred the old formatting, but I can live with this change.

The bigger changes is when I use Private Browsing, and with that the entire browser turns black.

Hello all who are trying to help me.

I will address your hints individually. But first I want to add that there is more that just the black areas (btw, my wife is furious, she has the same).

In the image you can see two ff windows. The one at the right is the active window (see the purple window border) and has the black area. The one at the left doesn’t.

But there is more. At the left with the red circle, there is a FF logo which says on hover over “Firefox View”. It wasn’t there before. At the far right there is sort of jigsaw puzzle piece which says “Extensions”. Wasn’t there before. About the third red circle “store to Pocket” I am not sure (it is difficult to compare with the past if you haven’t it anymore). My wife even had another one.

On my wife’s system I was able with right click on the icon “Remove from Bar” to remove all except the “Extensions” one where this is grayed out.

Thus I will be able to remove most of them on my FF also, but the black is still there.

You mean you have the same as I have?

Until now you are the first one to say so.

Yes, except that it looks to be dark gray rather than black.

I think they moved the TAB bar up. At one time it was near the top, and they made a big fuss about moving it down. And now it is back at the top.

Thanks for trying to help.

My first line of the first post above says: KDE.
I am interested in compairing your settings with mine. But I have no ifea where to find the list you show. I always have a bad relation with the KDE system settings. Things are never on the place you think they should be. And then there is the translations which make it difficult to find what is pointed to in English.

I tried one named “Uiterlijk”, (which means so much as "what you see from outside) and it seems to have at least some of what you show.
Globaal thema: openSUSE
Plasma-stijl: Air
Kleuren (colours): Breeze Classic
Vensterdecoraties: CDE (I know that is about the only thing I ever changed)
Pictogrammen (Icons): Oxygen
Cursors (Pointer?): Breeze

No idea what this does with FF. I any case until this morning it never did.

I followed you directions and found about:addons > Themes > switched on: System theme- automatic.

And I do not want a “dark theme”, I want to get rid from the black backgrouds in my menu bar and my tab bar when the window is the active one.

Sorry, but I can not follow you. I am a luddite when it comes to KDE settings and always have done as less as possible with them (and that a long time ago and yes, I managed to switch off all desktop effects). So which “color settings of KDE” do you mean? Where to find them?

For me it always was at the top, just below the menu bar.

But my wife says she can not remember ever have seen the tab bar (she works with FF windows, not with tabs), but I am not sure she is correct there. It could be that the very shock of things being different lets you focus on things you did not notice earlier.

I think that is correct.

Now I have removed the extra FF icon at left and the other one (the “extensions” one is still there), it looks to me that only the “dark Grey” that is shown when the window is active (or is that called “in focus”?) should be stopped and stay as it is in all other windows.

It is the window manager that should tell me which window is active, not the application.

That seems to be just the dark theme of firefox. It looks like that for me as well. When I set the light theme in about:addons the dark parts are bright grey. If your firefox was in light theme before and is now dark and set to “system theme-automatic” then I would assume that your theme has changed with the last update. And well the design of firefox in general has changed a bit for me as well (on Gnome), but that just seems to be the new version.

That would also explain why not everyone has that issue as people probably use different themes.

That seems to confirm this. So, if you just switch this settings:

Save and then switch back it might be back to your preferences, I guess. I cannot confirm because of the different DE.

That could be the theme for the window manager, no? But again, I am not familiar with where exactly the settings in Plasma are.

That is indeed something for the window manager. You can see the result in the image I posted somewhere above.

1 Like

Leap 15.5, KDE. I also got the dark FF top when updated to 115; had been light before. The 115 enabled theme was " System theme — auto" immediately after the update. In the Themes tab, I scrolled down to the “Light” theme and enabled it. That changed back to the old look.

1 Like

Oh boy, that was it!

Back to normal now. I will go down to my wife and change it for her also.