After upating some packages and restart sddm/plasma is not starting, just a black screen

i have a NVIDIA gtx 680 graphic card and iam using the proprietary driver, installed “the hard way” as described in the wiki. So everything worked until 20 minutes ago as i applied an update using the update applet which popped up in my tray bar (normally i use zypper dup on tumbleweed so iam not sure if thats the problem), then after the pc restarted everything was black after all of the systemd prompts where finished.
I checked the systemd logs and there is indeed a failed plymouth-start.service but i do not think thats the problem, there is also an entry:
session-1.scope - loaded active abondoned - Session 1 of user sddm

Maybe this is related to the NVIDIA driver and Mesa, because i found this post on the archlinux forum:

I do not know what to do anyway, can someone help me with this?

Btw: i am using the latest kernel: 4.3.3-6-default
and i did rekompiled the kernel and included the nvidia module after installing, i also did mkinitrd and everything worked fine (restarts and shutdowns included) until i applied the update 20 minutes ago.

When you install the hard way you have to reinstall on any kernel update. If you install from the NVIDIA repository then all are kept in sync

But tumbleweed changes too often for the repos to keep up so you must reinstall

Press e at boot find line stating linux or linuxefi go to true end (it wraps) add a space and a 3 press F10 to continue boot
log in as root go to location of the installer and run

I know and i do reinstall the nvidia driver the hard way after every kernel update, and it worked fine so far.
the last update i did, after which the black screen problem occurred, did not affected the kernel anyway.
I just wanted to make clear that i have the newest kernel, and that everything was fine with it, the problem has to be something else. Probably related to the display manager.

Is there an xorg update?

Anything in the xstack will require a reinstall

I do not know if there was a xorg update in one of the updates to be honest, but when i try to reinstall the NVIDIA driver by the sh script i downloaded i get the message/error that the mpodule is already loaded, so the current kernel was not touched, the only thing i can do is to run mkinitrd (edit: i just did it, and it does not change anything).

Ok i just switched from sddm to lightdm, this kind of worked. I saw the graphical login, was able to log in and plasma started, but immediately crashed, i mean it is still kind of running, but no tray bar and i get some Plasma error boxes relating to plasma (3, 2 and ‘’) and krunner.

But my conky background was successfully loaded. This is probably because plasma 5 is only compatible to sddm, right? But how to fix the sddm problem then?

Plasma5 works with every displaymanger out there.

But (likely) your nvidia driver installation is broken. If you install “the hard way”, nvidia’s installer replaces system files from Xorg and Mesa. If there’s an update to those packages (not only the kernel), you get the original files back which breaks the nvidia driver.

So try to reinstall the driver, this should fix your problem.

In opensuse there is log of every package installed or removed which I find pretty useful.
If you don’t know which package got upgraded do: sudo tail -n200 /var/log/zypp/history

I had similar problems with black screen when upgrading to leap 42.1, I think it had to do with my specific nvidia and/or monitor set up.
But I found out Plasma 5 had too many issues so I decided to permanently switch to XFCE, it was either that or stay with 13.2 for me.
I’ve used XFCE for a few months now and I’ve never been more happy, I also can still run KDE programs, ive’ also installed it on all my desktop computers.