After tumbleweed update x11 is not starting...

Hi all,

After a hefty update (2750) packages the system is not loading x11 and seems to hang.

Not very good after hours of updates !

I run tumbleweed 32 bit on an ancient msi netbook connected to an external monitor. The updates sometimes are a nightmare, but until now I was allways able to boot into gui. This time not so !

Studying the x11 log the driver failed to load with an unknown symbol error!

I’m an it guy so I can figure this out, but how are ordinary peeps supposed to tacle this…

I reverted to an earlier snapshot as the system had become totally FUbar and updated the xfce packages through yast. It now seems to have returned to a stable state. Will hold off updating the 2500 packages until I feel more confident. Looks like the update is updating the x11 drivers, but they don’t load WTF !

Any other people here having trouble after installing the TW updates ?

A known issue (as a Tumbleweed user, consider following the Factory mailing list?) and

Xorg works OK on 32bit Intel IGP here:

# inxi -GISaz
  Kernel: **5.16.15-1-default arch: i686** bits: 32 compiler: gcc v: 11.2.1
    parameters: root=<filter> ipv6.disable=1 net.ifnames=0 noresume
    mitigations=auto consoleblank=0 
  Desktop: KDE v: 3.5.10 tk: Qt v: 3.3.8c info: kicker wm: kwin vt: 7
    dm: KDM Distro: openSUSE **Tumbleweed 20220515**
  Device-1: **Intel 82865G Integrated Graphics** vendor: Dell driver: i915
    v: kernel ports: active: VGA-1 empty: none bus-ID: 00:02.0
    chip-ID: 8086:2572 class-ID: 0300
  **Display**: x11 server: **X.Org v: 21.1.3 driver: X: loaded: modesetting**
    failed: intel alternate: fbdev,vesa gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1680x1050 s-dpi: 108 s-size: 395x246mm (15.55x9.69")
    s-diag: 465mm (18.32")
  Monitor-1: VGA-1 model: Lenovo L2251x Wide serial: <filter> built: 2011
    res: 1680x1050 hz: 60 dpi: 90 gamma: 1.2 size: 474x296mm (18.66x11.65")
    diag: 559mm (22") ratio: 16:10 modes: max: 1680x1050 min: 720x400
  **OpenGL**: renderer: llvmpipe (LLVM 14.0.3 128 bits) v: 4.5 Mesa 22.0.3
    **direct render: Yes**
Info:...Shell: Bash v: 5.1.16 running-in: konsole **inxi: 3.3.15**

Have you tried booting any prior kernels, or using modesetting DIX instead of intel DDX?

Is running fine now with latest kernel and driver from feb2022…,:slight_smile:

Holding off update 2500 packages for now ! >:(

inxi -SIGay
  Host: tumbleweed Kernel: 5.17.5-1-pae i686 bits: 32 compiler: gcc v: 11.2.1
  parameters: root=/dev/sdc2
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.33 info: xfce4-panel wm: xfwm 4.16.1 vt: 7
  dm: LightDM 1.30.0 Distro: openSUSE Tumbleweed 20220509
  Device-1: Intel Mobile 945GSE Express Integrated Graphics
  vendor: Micro-Star MSI driver: i915 v: kernel bus-ID: 00:02.0
  chip-ID: 8086:27ae class-ID: 0300
  Display: x11 server: compositor: xfwm4 v: 4.16.1 driver:
  loaded: intel unloaded: fbdev,modesetting,vesa
  resolution: <missing: xdpyinfo>
  OpenGL: renderer: i915 (: 945GME) v: 2.1 Mesa 22.0.3 direct render: Yes
  Processes: 218 Uptime: 18h 2m wakeups: 1945 Memory: 1.95 GiB
  used: 1.16 GiB (59.4%) Init: systemd v: 250 runlevel: 5
  target: tool: systemctl Compilers: gcc: 11.2.1 alt: 10/11
  Packages: N/A note: see --pkg flatpak: 0 Shell: Bash v: 5.1.16
  running-in: xfce4-terminal inxi: 3.3.07