After switching from KDE Neon to openSUSE Leap 15.1, Firefox is missing large amount of bookmarks

I suppose I’ll add a TL;DR now: Switched my mom’s computer from KDE Neon to openSUSE Leap when KDE Neon started glitching out, kept /home partition, and somehow lost a significant chunk of Firefox bookmarks for some reason. Didn’t make a backup before making the switch, due to circumstances not making such a process easy. Firefox’s own backups may have been deleted or overwritten. Are they lost forever?

Now onto the details.

Back on October 25, my mom’s computer, which was running KDE Neon, started messing up. It happened at the same time I was desperately trying to fix my own computer, which runs Tumbleweed. So, bad luck all around.

Anyway, I couldn’t figure out how to fix her install, so I installed openSUSE Leap 15.1 on her computer instead of KDE Neon. I had her system set up with a separate /home partition. I installed Leap and set it up to use the existing /home partition, with the same username and such.

One quirk I noticed was that, when I launched Firefox, it created a new profile even though the existing one still existed. Thunderbird did the same thing. I used the command firefox -p to switch back to the original profile. When I was using that profile, Firefox kept crashing after closing. The window would close, then the process would hang for about 30 seconds before crashing. I created a new profile (I deleted the one that was created on the first launch in Leap) and ended up trying to move data files from the old profile to the new one, but I couldn’t figure out which one would cause it to start crashing. So I ultimately used the Firefox Sync feature to get the bookmarks, history, saved passwords, etc. transferred between the profiles.

Only after all of this was it discovered that a significant number of bookmarks are missing. I went to the bookmarkbackups folder in the Firefox profile, and the last backup was from December 2018. There was one backup made after Leap was installed, but that seems to be missing the bookmarks already. Something happened to the original Firefox profile, upon installing Leap and before running Firefox Sync, that removed all those bookmarks.

The problems that caused me to carry out the distro change didn’t seem to have anything to do with Firefox. Something happened to KDE, in that Qt apps stopped launching. I rebooted, and found that the login manager, sddm, wouldn’t display, even though it was apparently running. Firefox was open when all this started, but it seemed to affect Qt apps, and I think Firefox is GTK. I suppose it could have corrupted Firefox’s files somehow. But I don’t get why bookmarks would go missing. I would think that if it affected the file that has the bookmarks stored, all the bookmarks would be gone.

Does anyone know if I can get these bookmarks back?

Search all profiles for backups, such as:

karl@erlangen:~> ll .mozilla/firefox/dg41bxc6.default-1555704094520/bookmarkbackups/
insgesamt 1180
-rw------- 1 karl users 81500 27. Apr 2019  bookmarks-2019-04-27_366_d8sIsV+IJPj5VBpy6hALMw==.jsonlz4
-rw------- 1 karl users 81499 28. Apr 2019  bookmarks-2019-04-30_366_8yKQzsbH13ft4H1-FOPYWA==.jsonlz4
-rw------- 1 karl users 81475 18. Jun 17:08 bookmarks-2019-06-19_366_PvhE35IngKL6s7ybDKplXQ==.jsonlz4
-rw------- 1 karl users 81421 20. Jun 05:16 bookmarks-2019-06-20_364_xFaLmJTi2zUNNU+YohmjPA==.jsonlz4
-rw------- 1 karl users 81423 21. Jun 05:37 bookmarks-2019-06-21_364_Sz5OzA8xoC-1Kqo5Le53Dg==.jsonlz4
-rw------- 1 karl users 81680 22. Jun 06:37 bookmarks-2019-06-26_366_ArqJcoE9XP-5nSRjsJ5DhQ==.jsonlz4
-rw------- 1 karl users 81980 27. Jun 06:44 bookmarks-2019-06-27_368_VY5DKqCBbD1MsIi15O9A2g==.jsonlz4
-rw------- 1 karl users 82279 28. Jun 06:13 bookmarks-2019-06-28_369_XLSv-8FJd4KiLNcHB8U5hg==.jsonlz4
-rw------- 1 karl users 83150 29. Jun 05:07 bookmarks-2019-06-29_373_gHL79NNEcQBLdCCTvzDV3g==.jsonlz4
-rw------- 1 karl users 83888 30. Jun 05:39 bookmarks-2019-06-30_378_V-1fE7fZ2aFy8okco8JsDA==.jsonlz4
-rw------- 1 karl users 83982  1. Jul 06:31 bookmarks-2019-07-01_379_k3XTqxdOlIrdEWUmYMd08A==.jsonlz4
-rw------- 1 karl users 84124  2. Jul 06:52 bookmarks-2019-09-16_378_XvE+5V9hvnKM5qHIF3sWGg==.jsonlz4
-rw------- 1 karl users 84088 17. Sep 06:57 bookmarks-2019-10-31_378_Z1C7xkmtbKEqzocO-S8EEQ==.jsonlz4
-rw------- 1 karl users 54578  1. Nov 07:02 bookmarks-2019-11-01_379_oKSz5lZjRbzFTlO6nmsw2Q==.jsonlz4
-rw------- 1 karl users 54736  2. Nov 06:59 bookmarks-2019-11-03_380_1oHkkmoym5kYKCGIKEAEaQ==.jsonlz4

See also

Yeah, I said in my post that I checked the bookmarkbackups folder. There are zero backups between December 3, 2018, and October 26, 2019. I think all the bookmarks that are missing were added after December, as that backup doesn’t seem to have them.

And I know what sqlite file has the bookmarks. I tried copying over Places.sqlite (though not Places.sqlite.wal) from the original profile to the new one. But the damage was apparently done before I copied the file.

So I’m guessing there isn’t any other way to get the bookmarks back?

Is there at least any theory as to why this happened in the first place?

I tried:

linux-u5ye:~ # locate '*.default-*/book*'|wc
    264     298   35242
linux-u5ye:~ # locate places.sqlite|wc
     46      54    3220
linux-u5ye:~ # 

You may try an extensive search. Else Google may know how that can happen.

Backup your files before proceed.
In your /home folder open hidden /.mozilla folder.
Folder looks like /.mozilla/firefox/*.default/ .
Search there for a files with extensions *.mozlz4, *.jsonlz4 and *.baklz4.
Look into folder “sessionstore-backups” and try all files it contains.
Install addon for a Firefox mozlz4-edit to load these files and look into them.
Look into these files to an end - they may contain useful information at “recently deleted” tag.