After Suse 11.1 Upgrade no sound in kde 4.1 desktop

This really sucks.
There is sound in amarok but not in desktop.>:(

Do you use Xine ou GStreamer as phonon backend ?

I didn’t do anything special the sound just worked in suse 11.0 after running alsa conf. Now the sound only comes on during booting. the windows used to make sounds when minimizing. that sound is gone. web pages on the internet can no longer play sound. neither can vmware xp virtual pc. Weird thing is amarok can only still play sound.

have you try to re-run alsaconf ?

yep and it didn’t work.
and it is strange because like i said
amarok can play mp3s.
but all of the other normal sounds are missing.
mixer also has the volume controls as if there should be sound.
my virtual machine also can’t attach to the sound and gives an error about everytime a start a vm.

I had same problem changed to Xine backend and then it worked.


I have no idea how to change my backend to xine.
If you could explain would appreciate it.


system settings > sound > backend tab

I really have no idea what you are talking about i can’t find a backend tab. This really sucks.
All i can do is click edit and i don’t get any options

i went->applications_> system->adminitrator settings hardware sound.
I don’t see any backend tabs.>:(

Menu -> Configure Desktop -> Sound -> Backend.
if you have installed xine backend you should be able to select it.


I’m having those same symptoms, I’ve installed a fresh installation of opensuse 11.1 with kde 3 and 4, and besides kde-inerent sounds play right, amarok and kaffeine for example can’t play anything (well, they can but no sound comes out). However it’s odd smplayer can play sound fine.

Upgrading or installing OpenSuse11.1 on a Compaq 8510p with Mobility Radeon HD2600 leaves me with a white screen after boot. Desktop is Gnome.

Yes after adding the rpm that works.
The main sound works again however it is very low.
But the sounds for when the windows minimize are still missing. Also vmware can’t play sound anymore.
Another side point my desktop wallpaper won’t stick.
Must upgrading always break stuff?:frowning: