After S2RAM: Laptop speakers, powermanagement not working

After I wake up my laptop from suspend to ram, my laptop speakers don’t work. The headphone, however, does. When I do a “rcalsasound restart” the laptop speakers work again. This issue resembles very much, although this issue could not be solved with “rcalsasound restart”, so I think the unerlying cause could be completely different.

But what’s worse than the sound not coming back completely is that my CPU frequency gets stuck at 800MHz, which is the powermanagement state for my system, even when its power cord is plugged in and it should be able to go to 1.7GHz. I’ve tested this with starting up openoffice and monitoring the CPU frequency, but it consistently stays at 800MHz making my system feel sluggish.

My laptop is an HP nx8220 system (Pentium M mobile, ATI Mobility Radeon X600, Intel 8x0 sound).

Has anyone had similar issues with S2RAM or could anyone lead me to a solution for this?

In case you have not tried, you might try to surf on your model laptop, to see what others have tried. For example an older openSUSE user:
SUSE Linux on a HP NX8220 Notebook

Powersave / PowerManagement

Install packages powersave, yast2-power-management, yast2-powertweak e.g. via YaST (Software Management)

The PowerManagement should work, if the acpi=on boot option gets enabled (see above) and the boot option vga=0x317 is changed to vga=0.
Note: The later results in a non-graphical boot screen.

The PowerManagement can be configured via YaST and via KDE tools.
“Suspend to RAM” and “Suspend to Disk” are working flawless out-of-the-box.
You may have tried that already, and it may not be applicable to your openSUSE, but it was not possible for me reading your post to determine if you had tried that.

I also noted the HP White Paper on laptop’s with Linux, while it does not mention Power Management, does recommend to install with acpi disabled and after the install is complete, change from acpi=off to acpi=on.

I note here a Ubuntu user had the identical problem:
CompaqNx8220 - - Linux Wiki und Freie Software

There is also a big article here (in German) on this laptop and Power Management:
Compaq HP nx8220 Power Management - Gentoo Linux Wiki

I don’t speak German, but often one if one is not a German speaker, one can survive if one puts the URL into babel fish, and try to make sense of the computer translation that way.

Hi Oldcpu, thanks for the links. With regards to the first link, the package yast2-power-management, yast2-powertweak are no longer available for openSuse 11.0 (my version). The VGA=0 option I’m already using otherwise my ATI x600 card prevents the system from going into standby to begin with.

The second link I’ll keep as a last resort, I don’t really want to re-install the system at this point, since other than suspend it works flawlessly.

The last link won’t load at this time, I’ll try later on.

This guy start with patching his 2.6.16 kernel, so he must be on a really old version of openSuse. I don’t know which of his steps would apply to version 11.0. What’s interesting though is that he has a file “/etc/hibernate/ram.conf” in which he adds the line


RestartServices alsasound

Now that is exactly what I have to do manually. This file however no longer seems to exist. Do you know where I can do this in openSuse 11.0?

Again, thanks for your help.

The sound problem is solved. I followed the solution in this thread:

How To Restart Sound After Hibernation / Suspend To Disk? - openSUSE Forums

I created a file called 81sound with the script from that thread and put it /usr/lib/pm-utils/sleep.d. Made it executable and it works.

Great! Thanks for sharing your solution. Is that the right URL? It reads to me like a support thread where my efforts to help were a dismal failure.

Perhaps if you get the chance you could make a note of your technique here:
HCL/Laptops/HP - openSUSE
(in the laptop wiki).

Hi, I’ll update the table as soon as I’ve got everything working. That’s not 100% the case yet: After the wake-up from S2RAM the sound works properly now, but kmix and amarok have to be restarted manually. Also, the power-related problem I have I managed to trace back to kpowersave. If I restart that manually also then everything works fine.

So, since all my remaining problems have to do with KDE, is there a way to let KDE know how to handle a wake-up from S2RAM?