After OpenSuse 13.2 install... No option to boot into Windows 8

Sigh…not sure how this happened but after installing OpenSuse on my 2nd Desktop PC (Legacy Bios) there is no option to boot into Windows 8

daka@linux-rqzp:~> sudo fdisk -l

Disk /dev/sda: 596.2 GiB, 640135028736 bytes, 1250263728 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x83e6d949

Device     Boot     Start        End    Sectors   Size Id Type
/dev/sda1  *         2048     718847     716800   350M  7 HPFS/NTFS/exFAT
/dev/sda2          718848  205373439  204654592  97.6G  7 HPFS/NTFS/exFAT
/dev/sda3       205373440 1250258943 1044885504 498.2G  7 HPFS/NTFS/exFAT

Disk /dev/sdb: 931.5 GiB, 1000204886016 bytes, 1953525168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 54CD4E65-0197-4F08-B5D8-9766E6A17B27

Device        Start        End    Sectors   Size Type
/dev/sdb1      2048     321535     319488   156M EFI System
/dev/sdb2    321536    4530175    4208640     2G Microsoft basic data
/dev/sdb3   4530176   88422399   83892224    40G Microsoft basic data
/dev/sdb4  88422400 1953523711 1865101312 889.4G Microsoft basic data

Would certainly appreciate a helping hand with resolving this. I have 2 hard drives and my second hard drive is 100% devoted to OpenSuse (thats what I chose during the install)

Ok first off Windows 8? is fast boot OFF in Windows. It can leave its partitions in a dirty state and may not be readable

If fast boot is off and Windows properly shut down run Yast - boot loader and check the box “Prob foreign OS”

That should pick it up if the partitions are readable.

If not there is some manual ways

@gogalthorp:

Thank you for your reply. I did as you say and turned off fastboot inside WIndows 8. Then I shutdown. After that I booted into OpenSuse and went to boot settings in Yast and checked the “probe foreign os” But I still did not see an option for Windws 8 in that menu. And when I rebooted my PC I still do not have an option in grub for Windows 8.

THe only way I can get into Windows 8 is to go to the Bios and change the boot order sequence to boot from sata hdd 1 (and then it boots into windows)

Else it says UEFI: OpenSuse . And that was the default before. So basically that has been my workaround for the time being, as soon as the PC boots up I can hit the “esc” key and enter the Bios “Boot menu” where I can change which of the 2 I want to use. Its strange to see “UEFI” because on the internet it says my motherboard does not have UEFI, only Legacy Bios.

The good news is that on my laptop (a newer machine) I have the Dual boot working perfectly. The laptop definately uses UEFI bios.

i am making a guess although i am not an expert. as far as i can see, you have two hdds, dev/sda with opensuse and dev/sdb with windows.
back in my fedora days, before i update grub fron fedora, i needed to mount all partition to get all othe OS on the grub list (i have had ubuntu and windows 7 besides fedora).
maybe if you mount the sdb HDD from opensuse you will have the chance.
still, the easiest solution would be to make a rescatux disk.

Mounting may help but it should not be needed the os prober should scan all drives for bootable OS.

in a console window become root
su -

then
**grub2-mkconfig -o /boot/grub2/grub.cfg

grub2-install /dev/sdb**
Note be sure the /dev/sdb is the Linux drive

That should work.

If it does not show us

gdisk /dev/sda
gdisk /dev/sdb

Is there any thing funky on how the Windows partitions are formatted? ie Dynamic disk??

i am making a guess although i am not an expert. as far as i can see, you have two hdds, dev/sda with opensuse and dev/sdb with windows.
back in my fedora days, before i update grub fron fedora, i needed to mount all partition to get all othe OS on the grub list (i have had ubuntu and windows 7 besides fedora).
maybe if you mount the sdb HDD from opensuse you will have the chance.

I go along with rich1974. I had a similar situation with openSUSE and Vista. I mounted Vista from openSUSE and updated the grub. Worked for me. :slight_smile:

…and then updated as gogalthorp suggested.

Dave

Thanks guys,

First I mounted the Windows partitions by clicking on them using dolphin (and opening the subfolders).

Then I went to Yast boot settings and made sure “probe foreign OS” was ticked and clicked Next > Next > Done

Unfortunatley Windows was not detected with that method. Next I did this:

daka@linux-rqzp:~> su -
Password: 
linux-rqzp:~ # grub2-mkconfig -o /boot/grub2/grub.cfg
Generating grub configuration file ...
Found theme: /boot/grub2/themes/openSUSE/theme.txt
Found linux image: /boot/vmlinuz-3.16.7-7-desktop
Found initrd image: /boot/initrd-3.16.7-7-desktop
Found linux image: /boot/vmlinuz-3.16.6-2-desktop
Found initrd image: /boot/initrd-3.16.6-2-desktop
  WARNING: lvmetad is running but disabled. Restart lvmetad before enabling it!
  /dev/sdc: open failed: No medium found
  /dev/sdd: open failed: No medium found
  /dev/sde: open failed: No medium found
  /dev/sdf: open failed: No medium found
  No volume groups found
Found openSUSE 13.2 (x86_64) on /dev/sdb3
done
linux-rqzp:~ # grub2-install /dev/sdb
Installing for x86_64-efi platform.
Installation finished. No error reported.
linux-rqzp:~ # 

Yes, sdb is the hdd that is devoted to Linux

– Ok, rebooting now to test it out =)

Edit: There is nothing funky about the formatting, just default NTFS in the default layout. Nothing special

Bad News: It did not resolve the problem.

daka@linux-rqzp:~> gdisk /dev/sda
Absolute path to 'gdisk' is '/usr/sbin/gdisk', so running it may require superuser privileges (eg. root).
daka@linux-rqzp:~> sudo gdisk /dev/sda
root's password:
GPT fdisk (gdisk) version 0.8.10


Partition table scan:
  MBR: MBR only
  BSD: not present
  APM: not present
  GPT: not present




***************************************************************
Found invalid GPT and valid MBR; converting MBR to GPT format
in memory. THIS OPERATION IS POTENTIALLY DESTRUCTIVE! Exit by
typing 'q' if you don't want to convert your MBR partitions
to GPT format!
***************************************************************




Command (? for help): q
daka@linux-rqzp:~> 


daka@linux-rqzp:~> sudo gdisk /dev/sdb
GPT fdisk (gdisk) version 0.8.10


Partition table scan:
  MBR: protective
  BSD: not present
  APM: not present
  GPT: present


Found valid GPT with protective MBR; using GPT.


Command (? for help): 

Sorry I forgot to add the -l ( lower case L)

format should be

gdisk -l /dev/sdX

where X is the drive you want to list

Looking at the output it looks like /dev/sda is MBR format not EFI/GPT

mixing modes is always tricky.

Im not sure why the Suse got installed with UEFI settings. I dont remember being asked to specify.

Also the BIOS will not allow me to make the Legacy sda1 the first in the boot order unless I go into the bios every single time and make the change. This would mean everytime I want to use WIndows I will have to access the BIOS configuration.

Hopefully there is a way to remedy this without having to do a full reinstall. Cant I just edit menu.lst like in the good old days? =)

If the device you intalled with is booted in EFI mode the install will default to EFI. It won’t ask. You need to be aware of the signs ie it will install grub2-efi not grub2 Also a /boot/efi partition will be created if it does not exist. Some BIOS will default boot to legacy (mbr/msdos) mode some will default boot to EFI. Always select the boot mode from the BIOS boot menu from the boot screen. Note that which key to press at boot is machine dependent so it should be shown on the boot screen or at least in the manual. You did get a manual didn’t you LOL :stuck_out_tongue:

I don’t know for certain that the mixed modes are your problem but “crossing the streams is very dangerous” “Never mix never worry”.

As far as I know, you should be able to hit F12 during boot (while the logo is still showing), and select what system for this particular boot.

Apart from that, your problem appears to be because opensuse is an EFI system and Windows is a legacy bootable system. They don’t mix. The BIOS has to provide different services for each style of booting, and cannot be switched when halfway through.

It is possible to install grub2 for BIOS; you will need to decide where it should be installed - on MBR of /dev/sda or on MBR of /dev/sdb. On /dev/sda no additional steps are needed; on /dev/sdb you will need to create additional small partition. Then you will need to set your BIOS to use legacy boot.

Yes, I would like to try that on sda1

Which would be the steps i need to take?

Also: Do I need to delete the EFI partition or will this happen automatically?

If sda is your disk with Windows it is unfortunately not possible - you can install only in MBR of sda.

Which would be the steps i need to take?

  1. Check that you have grub2-i386-pc package (should be default); install if missing
  2. Install grub2 for legacy BIOS in MBR of /dev/sda: grub2-install --target i386-pc /dev/sda
  3. Check that GRUB_USE_LINUXEFI is not set to true in /etc/default/grub. If it is, change it (e.g. GRUB_USE_LINUXEFI=false) and rerun grub2-mkconfig
  4. Reboot and select legacy BOOT in your boot menu
  5. If everything is OK, go in yast bootloader and change bootloader frin grub2-efi to grub2

Do I need to delete the EFI partition or will this happen automatically?

ESP is not deleted and it is not used anymore. It is up to you to keep or delete it.

Just to clarify: I only have 2 hard drives, drive sdc appears to be a flash drive I had plugged in

daka@linux-rqzp:~> sudo zypper in grub2-i386-pc package
root's password:
Loading repository data...
Reading installed packages...
'package' not found in package names. Trying capabilities.
No provider of 'package' found.
'grub2-i386-pc' is already installed.
No update candidate for 'grub2-i386-pc-2.02~beta2-20.5.1.x86_64'. The highest available version is already installed.
Resolving package dependencies...


Nothing to do.
daka@linux-rqzp:~> sudo grub2-install --target i386-pc /dev/sda
Installing for i386-pc platform.
grub2-install: warning: Sector 32 is already in use by the program `FlexNet'; avoiding it.  This software may cause boot or other problems in future.  Please ask its authors not to store data in the boot track.
grub2-install: warning: Sector 33 is already in use by the program `FlexNet'; avoiding it.  This software may cause boot or other problems in future.  Please ask its authors not to store data in the boot track.
Installation finished. No error reported.
daka@linux-rqzp:~> 

GRUB_USE_LINUXEFI was set to TRUE.

Changed line from TRUE to FALSE: GRUB_USE_LINUXEFI=false

daka@linux-rqzp:~> sudo grub2-mkconfig
root's password:
Generating grub configuration file ...
#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub2-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#


### BEGIN /etc/grub.d/00_header ###
set btrfs_relative_path="y"
export btrfs_relative_path
if  -f ${config_directory}/grubenv ]; then
  load_env -f ${config_directory}/grubenv
elif  -s $prefix/grubenv ]; then
  load_env
fi
if  "${next_entry}" ] ; then
   set default="${next_entry}"
   set next_entry=
   save_env next_entry
   set boot_once=true
else
   set default="${saved_entry}"
fi


if  x"${feature_menuentry_id}" = xy ]; then
  menuentry_id_option="--id"
else
  menuentry_id_option=""
fi


export menuentry_id_option


if  "${prev_saved_entry}" ]; then
  set saved_entry="${prev_saved_entry}"
  save_env saved_entry
  set prev_saved_entry=
  save_env prev_saved_entry
  set boot_once=true
fi


function savedefault {
  if  -z "${boot_once}" ]; then
    saved_entry="${chosen}"
    save_env saved_entry
  fi
}


function load_video {
  if  x$feature_all_video_module = xy ]; then
    insmod all_video
  else
    insmod efi_gop
    insmod efi_uga
    insmod ieee1275_fb
    insmod vbe
    insmod vga
    insmod video_bochs
    insmod video_cirrus
  fi
}


if  x$feature_default_font_path = xy ] ; then
   font=unicode
else
insmod part_gpt 
insmod btrfs
set root='hd1,gpt3'
if  x$feature_platform_search_hint = xy ]; then
  search --no-floppy --fs-uuid --set=root --hint-bios=hd1,gpt3 --hint-efi=hd1,gpt3 --hint-baremetal=ahci1,gpt3  1f53d980-ba59-4a37-b233-9a80b916fd5a
else
  search --no-floppy --fs-uuid --set=root 1f53d980-ba59-4a37-b233-9a80b916fd5a
fi
    font="/usr/share/grub2/unicode.pf2"
fi


if loadfont $font ; then
  set gfxmode=auto
  load_video
  insmod gfxterm
  set locale_dir=$prefix/locale
  set lang=en_US
  insmod gettext
fi
terminal_output gfxterm
Found theme: /boot/grub2/themes/openSUSE/theme.txt
insmod part_gpt 
insmod btrfs
set root='hd1,gpt3'
if  x$feature_platform_search_hint = xy ]; then
  search --no-floppy --fs-uuid --set=root --hint-bios=hd1,gpt3 --hint-efi=hd1,gpt3 --hint-baremetal=ahci1,gpt3  1f53d980-ba59-4a37-b233-9a80b916fd5a
else
  search --no-floppy --fs-uuid --set=root 1f53d980-ba59-4a37-b233-9a80b916fd5a
fi
insmod gfxmenu
loadfont ($root)/boot/grub2/themes/openSUSE/ascii.pf2
loadfont ($root)/boot/grub2/themes/openSUSE/DejaVuSans10.pf2
loadfont ($root)/boot/grub2/themes/openSUSE/DejaVuSans12.pf2
loadfont ($root)/boot/grub2/themes/openSUSE/DejaVuSans-Bold14.pf2
insmod png
set theme=($root)/boot/grub2/themes/openSUSE/theme.txt
export theme
if  x${boot_once} = xtrue ]; then
  set timeout=0
elif  x$feature_timeout_style = xy ] ; then
  set timeout_style=menu
  set timeout=8
# Fallback normal timeout code in case the timeout_style feature is
# unavailable.
else
  set timeout=8
fi
if  -n "$extra_cmdline" ]; then
  submenu "Bootable snapshot #$snapshot_num" {
    menuentry "If OK, run 'snapper rollback $snapshot_num' and reboot." { true; }
  }
fi
### END /etc/grub.d/00_header ###


### BEGIN /etc/grub.d/10_linux ###
Found linux image: /boot/vmlinuz-3.16.7-7-desktop
Found initrd image: /boot/initrd-3.16.7-7-desktop
menuentry 'openSUSE' --class opensuse --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-1f53d980-ba59-4a37-b233-9a80b916fd5a' {
        load_video
        set gfxpayload=keep
        insmod gzio
        insmod part_gpt 
        insmod btrfs
        set root='hd1,gpt3'
        if  x$feature_platform_search_hint = xy ]; then
          search --no-floppy --fs-uuid --set=root --hint-bios=hd1,gpt3 --hint-efi=hd1,gpt3 --hint-baremetal=ahci1,gpt3  1f53d980-ba59-4a37-b233-9a80b916fd5a
        else
          search --no-floppy --fs-uuid --set=root 1f53d980-ba59-4a37-b233-9a80b916fd5a
        fi
        echo    'Loading Linux 3.16.7-7-desktop ...'
        linux   /boot/vmlinuz-3.16.7-7-desktop root=UUID=1f53d980-ba59-4a37-b233-9a80b916fd5a  ${extra_cmdline}  resume=/dev/sdb2 splash=verbose quiet showopts
        echo    'Loading initial ramdisk ...'
        initrd  /boot/initrd-3.16.7-7-desktop
}
submenu 'Advanced options for openSUSE' $menuentry_id_option 'gnulinux-advanced-1f53d980-ba59-4a37-b233-9a80b916fd5a' {
        menuentry 'openSUSE, with Linux 3.16.7-7-desktop' --class opensuse --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-3.16.7-7-desktop-advanced-1f53d980-ba59-4a37-b233-9a80b916fd5a' {
                load_video
                set gfxpayload=keep
                insmod gzio
                insmod part_gpt 
                insmod btrfs
                set root='hd1,gpt3'
                if  x$feature_platform_search_hint = xy ]; then
                  search --no-floppy --fs-uuid --set=root --hint-bios=hd1,gpt3 --hint-efi=hd1,gpt3 --hint-baremetal=ahci1,gpt3  1f53d980-ba59-4a37-b233-9a80b916fd5a
                else
                  search --no-floppy --fs-uuid --set=root 1f53d980-ba59-4a37-b233-9a80b916fd5a
                fi
                echo    'Loading Linux 3.16.7-7-desktop ...'
                linux   /boot/vmlinuz-3.16.7-7-desktop root=UUID=1f53d980-ba59-4a37-b233-9a80b916fd5a  ${extra_cmdline}  resume=/dev/sdb2 splash=verbose quiet showopts
                echo    'Loading initial ramdisk ...'
                initrd  /boot/initrd-3.16.7-7-desktop
        }
        menuentry 'openSUSE, with Linux 3.16.7-7-desktop (recovery mode)' --class opensuse --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-3.16.7-7-desktop-recovery-1f53d980-ba59-4a37-b233-9a80b916fd5a' {
                load_video
                set gfxpayload=keep
                insmod gzio
                insmod part_gpt 
                insmod btrfs
                set root='hd1,gpt3'
                if  x$feature_platform_search_hint = xy ]; then
                  search --no-floppy --fs-uuid --set=root --hint-bios=hd1,gpt3 --hint-efi=hd1,gpt3 --hint-baremetal=ahci1,gpt3  1f53d980-ba59-4a37-b233-9a80b916fd5a
                else
                  search --no-floppy --fs-uuid --set=root 1f53d980-ba59-4a37-b233-9a80b916fd5a
                fi
                echo    'Loading Linux 3.16.7-7-desktop ...'
                linux   /boot/vmlinuz-3.16.7-7-desktop root=UUID=1f53d980-ba59-4a37-b233-9a80b916fd5a  ${extra_cmdline} showopts apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe
                echo    'Loading initial ramdisk ...'
                initrd  /boot/initrd-3.16.7-7-desktop
        }
Found linux image: /boot/vmlinuz-3.16.6-2-desktop
Found initrd image: /boot/initrd-3.16.6-2-desktop
        menuentry 'openSUSE, with Linux 3.16.6-2-desktop' --class opensuse --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-3.16.6-2-desktop-advanced-1f53d980-ba59-4a37-b233-9a80b916fd5a' {
                load_video
                set gfxpayload=keep
                insmod gzio
                insmod part_gpt 
                insmod btrfs
                set root='hd1,gpt3'
                if  x$feature_platform_search_hint = xy ]; then
                  search --no-floppy --fs-uuid --set=root --hint-bios=hd1,gpt3 --hint-efi=hd1,gpt3 --hint-baremetal=ahci1,gpt3  1f53d980-ba59-4a37-b233-9a80b916fd5a
                else
                  search --no-floppy --fs-uuid --set=root 1f53d980-ba59-4a37-b233-9a80b916fd5a
                fi
                echo    'Loading Linux 3.16.6-2-desktop ...'
                linux   /boot/vmlinuz-3.16.6-2-desktop root=UUID=1f53d980-ba59-4a37-b233-9a80b916fd5a  ${extra_cmdline}  resume=/dev/sdb2 splash=verbose quiet showopts
                echo    'Loading initial ramdisk ...'
                initrd  /boot/initrd-3.16.6-2-desktop
        }
        menuentry 'openSUSE, with Linux 3.16.6-2-desktop (recovery mode)' --class opensuse --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-3.16.6-2-desktop-recovery-1f53d980-ba59-4a37-b233-9a80b916fd5a' {
                load_video
                set gfxpayload=keep
                insmod gzio
                insmod part_gpt 
                insmod btrfs
                set root='hd1,gpt3'
                if  x$feature_platform_search_hint = xy ]; then
                  search --no-floppy --fs-uuid --set=root --hint-bios=hd1,gpt3 --hint-efi=hd1,gpt3 --hint-baremetal=ahci1,gpt3  1f53d980-ba59-4a37-b233-9a80b916fd5a
                else
                  search --no-floppy --fs-uuid --set=root 1f53d980-ba59-4a37-b233-9a80b916fd5a
                fi
                echo    'Loading Linux 3.16.6-2-desktop ...'
                linux   /boot/vmlinuz-3.16.6-2-desktop root=UUID=1f53d980-ba59-4a37-b233-9a80b916fd5a  ${extra_cmdline} showopts apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe
                echo    'Loading initial ramdisk ...'
                initrd  /boot/initrd-3.16.6-2-desktop
        }
}


### END /etc/grub.d/10_linux ###


### BEGIN /etc/grub.d/20_linux_xen ###
### END /etc/grub.d/20_linux_xen ###


### BEGIN /etc/grub.d/20_memtest86+ ###
### END /etc/grub.d/20_memtest86+ ###


### BEGIN /etc/grub.d/30_os-prober ###
  WARNING: lvmetad is running but disabled. Restart lvmetad before enabling it!
  /dev/sdc: open failed: No medium found
  /dev/sdd: open failed: No medium found
  /dev/sde: open failed: No medium found
  /dev/sdf: open failed: No medium found
  No volume groups found
Found openSUSE 13.2 (x86_64) on /dev/sdb3


### END /etc/grub.d/30_os-prober ###


### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###


### BEGIN /etc/grub.d/41_custom ###
if  -f  ${config_directory}/custom.cfg ]; then
  source ${config_directory}/custom.cfg
elif  -z "${config_directory}" -a -f  $prefix/custom.cfg ]; then
  source $prefix/custom.cfg;
fi
### END /etc/grub.d/41_custom ###


### BEGIN /etc/grub.d/80_suse_btrfs_snapshot ###
if  -f "/.snapshots/grub-snapshot.cfg" ]; then
  source "/.snapshots/grub-snapshot.cfg"
fi
### END /etc/grub.d/80_suse_btrfs_snapshot ###


### BEGIN /etc/grub.d/90_persistent ###
### END /etc/grub.d/90_persistent ###
done
daka@linux-rqzp:~> 

Then I rebooted and went into BIOS settings. I disabled UEFI boot devices section completely and set it to boot “Legacy boot” with SATA1

Upon booting in it brought up Grub but No Windows 8 was in the menu for selection.

I went into Yast boot Loader settings and changed it to GRUB2-EFI to GRUB2 (Boot from MBR is ticked)

I pressed the button on the bottom that says "Boot Loader Installation details " It showed the following:

Disk Order:

/dev/sdb
/dev/sda
/dev/sdc

**This did not seem right to me so I changed the order **to:

/dev/sda
/dev/sdb
/dev/sdc

(I hope that was the correct thing to do)

Now on the third tab that says Bootloader options I see a tick in "Probe Foreign OS)

On default Boot Section I pressed the drop down menu and notice that Windows 8 is still not available as a choice.

I pressed OK and after several seconds looks like everything was processed except I notice the screen just disappeared with no confirmation dialog such as “Your Boot settings have been completed successfully” or anything like that so I am not sure if that is normal behavior.

I rebooted about 3 times, I have tried mounting the windows partitions by clicking on them in Dolphin and then going into Yast Boot settings again but I still dont see Windows 8 as a choice.

In conclusion: Windows 8 is not available to me as a choice in Grub at boot-time

When I went into the BIOS again I noticed that EFI has been re-enabled (on its own). SO I set it back to Legacy and tried to boot again.

THats when I noticed what it happening, an error that scrolls by so fast I can barely read it about Grub “SYstem BootLoader not found” and it appears that it is then reverting back to EFI (The partition is still there, I have not deleted it yet)

So please look over the terminal output above and see if maybe I missed a step or something. I am disappointed because now at this point I have no way to access the Windows partition AT ALL so I am in rough shape because now I cannot even go into the BIOS to access it, I am effectively locked-out of Windows completely =(

The only thing I know to do now would be to insert the Windows 8 CD and run **bootrec /fixmbr

**Of course if I do that we will be back to square one as far as Grub but hopefully you can advise me some other solution.

I deleted the EFI partition and after I rebooted I noticed that the BIOS option remains as Legacy (so at least that problem has been cleared up).

So now all I need is to find a way for OpenSuse to “see” that Windows 8 co-exists and for grub to have an entry for Windows 8 as a selection.

If you have both OS in legacy mode try the above suggested actions again.