After openSuse 11 Installation: "No Operating System found"

Hello there,

I just installed openSuse 11 from DVD (3 times to be exactly to be sure that it is not my fault).

After the installation Linux boots and everything is fine. I can update packages, install software and so on.
But if I restart the system my BIOS shows me after rebooting “No Operation System found”.

So I guess the bootloeader doesn’tt work clearly.
With the DVD I tried to repair the bootloader - no result. Same error.
Then I tried to set the failsafe-boot as default - same result.

After the three installations I tried another one after I cleared my HDD with a Linux LiveCD (dd if=/dev/zero of=/dev/hda)
So I installed openSuse 11 again.
Well… maybe you guess why I am writing: “No operating system found”.

Here are some information about my system:
HP Compaq Notebook nx6110 (German)
Intel 1,86 GH

openSuse 11 Installation Details:
German Keyboard Layout, GNOME … and the standard HDD Partitioning for my HDD.

Do you have any Idea what I can do?

Well, I can install openSuse 11 again and wait so long until I have to reboot, but this is no solution :smiley:

I just installed openSuse 11 again - and I did not update the system - and now it works.
This is strange, isn’t it?

That is strange… If it where grub going amist I would expect I different error.

If it happens again check the partition layout by using the DVD and booting into rescue mode… once there check to see which partition is marked as active boot with ’ fdisk -l '.

GRUB is not even loading, right. And that my BIOS tells me that there is no OS is strange to, because I took a look with a Linux Live CD at them and saw nothing which could cause problems.
Even the boot device is correct.

I also tried the he DVD repair-tool.
No Errors. Nothing to do.

I cleared the disk with the dd command - so there is nothing to delte and all partitions had to be configured by the setup.

What I do next:

  • Install Windows XP
  • Install openSuSe 11 after this installation
  • Update the system again

Curious to hear your findings with these next steps.

as a note, I was referring to the active boot partition as set on the disk itself (BIOS setting aside)

Good luck! :wink:

Yes. I am courious - and so are my methods.
Should I apologize not for mentioning it before :smiley:

Status: Windows XP installed.
Nuw clearing the system and installing a “real” Operating System…
Until now Windows reboots fine…

I’m not sure if it is related, but I had a hardware failure on my previous test PC’s hard drive (in the area of the MBR), which made booting to openSUSE-11.0 very difficult (would only boot 10% to 25% of the time). In fact, grub would also fail over 75% of the time. Yet when grub did work, openSUSE-10.3 in grub worked fine, although 11.0 constantly failed most the time. Changing out the hard drive, and re-installing on a different hard drive, solved the problem.

My guess is in my case, I had a bad bit in the MBR, which impacted the openSUSE-11.0 boot, but not the openSUSE-10.3 boot.

Are you confident that this is not a hard drive problem?

Windows XP worked fine.
So I installed openSuSe … and I updated the system… added new packages… and well… It worked.

Don’t ask me why…

But I am happy.

Thanks for your help :slight_smile:

edit: @oldcpu
ahh… that was your hardware problem you spoke of earlier.
Nasty one to spot!

Anyway to diagnose/check the MBR for this?

Could be there was no boot code in the MBR… openSUSE defaults to placing your grub config in the boot partition (to preserve other OS/bootloader configurations), maybe it needed to be installed to the MBR itself in this case?

Hardware error: negative.
With Suse 10.3 worked everything fine… and Windows too…

I think I got the solution for my problem.
I installed Suse 11 in german. After the installation I updated my system after adding some new packages (firefox, system updates and so on). Then I rebooted and the OS error accured.
The whole boot-partition was ok which I checked with a Linux Live CD.

Now I will explain you what I did now:
I installed XP and then openSuse 11 (Just for fun - who knows ^^) - instead of updating the system immediately I rebooted first, Then I installed all updates - and finally I installed languagepack for localization - then I rebooted for the third time.
And voilá:: Suse is running.

The suspect error message came after the installation and updating the system - the german system.
Maybe there is a bug or something which change the bootloader or some other depending settings like the boot partition after updating.

Not that I wouldn’t use the english version - but localized is a bit better :wink:

Might be good to open a bug against this! If the English version is working , so should others!

Good digging though! :wink: