after migrating to another webserver, users cannot login

I want to migrate all home directories and users from one webserver to another. The old server runs OpenSuSE 11.2 and the new one OpenSuSE 11.4. I appended only the userpart of the passwd file from the old server to the new one. I did the same with the shadow file and the group file. I checked the user rights for all three of them and they were ok (shadow 600). I have done such a migration before and at that time it worked fine. Now for the weird part:

At first it seemed everything was ok. Websites and webshops were visible and working correctly. At first ftp seemed to work fine. Login worked but when uploading files, the error messages appeared: permission denied. Further testing gave following results:

-Root and users can login on console with their old passwords.
-Root can create new users, but they can not login: some error message comes, but is unreadable since it stays too short on display. After that it prints “hint:” on a new line and on another new line it gives a new login prompt.
-Root and users can change user’s password, but then they can not login anymore. The same unreadable error message appears.
-Users can login with ftp, even after changing passwords(!) but can not change or add files
-/var/log/messages only shows: “authentication failure” twice.

Actions so far:
Emptied /tmp
copied the users again from passwd and shadow
checked UID’s and GID’s again
googled a lot

Anyone here who has an idea what is going on? I am out of ideas and searching the internet gave me no solutions either. Any help is appreciated. Thanks.


What’s happening when you use the original passwd, shadow and group?

Makes no difference. I do not see any logic in this behavior, do you?

Meaning that the original, clean install of 11.4 showed the same problem? That’s not good. Sorry, out of my knowledge…