After massive update. Gnome will not log in

Hi,

After a prompt for 1875 updates which I agreed to I was asked to restart my system. Upon shut-down my system froze, I thought that all the updates would take a while so I left my laptop be for 1hr, no change so I forced it down.

Upon restart I cannot log into Gnome, I get a grey screen with failure cannot load and I have to log out. I can however log into KDE which is also suffering from problems. Above the bottom task bar there is a bar that is very blurry, like a failed plasma or something. Also in FF all the buttons have the icon missing default of a page with a red X.

I tried to check the /var/log files but they are empty so I am unsure what went wrong to diagnose it.

I am on 12.3 KDE (although I want my Gnome back)

Dave

I’m not sure that you are even on 12.3 at this stage.

I think that I once saw around 500 updates. But that was running Tumbleweed.

My best guess is a failing disk or corrupt file system, resulting in a corrupt RPM database.

If it were me, I would run checks on the disk, perhaps while running from live media. And if the disk shows as good, I would reinstall. There’s something amiss with your system.

I think he shut down in the middle of the updates. In which case his system is hosed. The problem is that the installer is setting a warning that a reboot is needed because of a kernel upgrade but you are supposed to wait until after the updates are done then reboot not reboot immediately. This may not be clear to some people since there was at least one other person that did this recently.

That does seem like a lot of updates but we don’t know if this was a new install of all desk tops or maybe the OP activated all the repos in the world.

In any case I’d say the system is hosed and should just be reinstalled. It may be possible to get it back operational but it would be a massive effort.

Hi ok,

I did a complete reinstall. So a fresh install only things I have set up is the updates for a fresh restart via the online update in Yast, VLC, flash and multimedia and some gnome themes. I did not go near anything graphical.

After 1hr of doing nothing apart from reading online the same issue arose.
I flicked the mouse to the top left where in the system froze. I cltr+alt+bkspc to restart gnome, to get the error screen where “a fatal error has occurred and gnome cannot start, please log out”. After restarts I still get the same error. Nothing was installing in parallel or anything the system just froze and gnome is fecked.

I cannot log in and I am post thing via IceWM.

I do not mess around with repos and only add stuff from the opensuse online repo. I am very confused by this, I am looking at /var/log/Xorg.1.log but nothing is sticking out at me.

If you had a kernel update maybe you need to reinstall any video drivers??? Sorry I don’t know much about gnome I run KDE

How would I check ?? I find it strange that after the install and update it too nearly 2hrs to **** up. I am running off a brand new SanDisk SSD, I will run a disk check as a precaution.

After my fresh install I installed 204 patches from the online update:

2 pertain to “video”
openSUSE-2013-560 - xf86-video-modesetting: Update to 0.8.0 and several fixes
openSUSE-2013-496 - xf86-video-mga-update: Restrict kernel driver matching to g200 server chips

10 pertain to “gnome” but nothing interesting in there.

I find this quite annoying, I can switch to KDE or XFCE but I want to know what is fundamentally wrong so I can either (a) fix it or (b) enter a bug file correctly.

Dave

This is a bit drastic, but perhaps worth trying.

While logged into icewm, start a terminal session, and do:


cd  ### make sure you are in your home directory
rm -rf .gnom* .gtk* .gconf* 

That will clear our any personal settings from your previous gnome sessions. Then login to gnome and see if you can now get in.

On 2013-08-18 23:36, gogalthorp wrote:
>
> If you had a kernel update maybe you need to reinstall any video
> drivers??? Sorry I don’t know much about gnome I run KDE

All desktops would be affected, not only gnome.


Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

Well KDE will run more readily without a propritary driver ie the OS drivers. Gnome seems to be more picky. But if it ran for a while it is not a driver problem

Update:

After 2 restarts I can log into gnome again. After 2hrs same issue arose where it froze and crashed again, after the “rm” action earlier I could restart and we are going ok now for about 1hr.
I have no * .xsession-errors*to help diagnose what is happening which is really annoying, is there any way to set it up ?