After Leap update system won't boot

I have a system HP 6000 that I installed Leap on back in late December. I ran a zypper update on it and had 80 some packages. I only have the default repos plus Google Chrome. After I initially installed Leap I ran zypper up and rebooted and all was well. Today I ran zypper up, press y to update. Once complete I rebooted but the PC powers on but I get no display but my monitor light is green. Something got fouled up. I have another identical system that I was going to update but after this decided against it until I could figure out this problem.

Any thoughts or helpful suggestions to try? I am trying to prevent a re-image but I may have to go down that path and not knowing what will happen the next time.

Video/driver how installed???

I originally installed with USB boot stick using XFCE. Is there a list somewhere that shows a updated package list? I could look and see if there was an updated video driver package but I never had this issue when running 13.2 on the same box. Strange and troublesome at the same time.

I used Clonezilla to create this image which I deployed to both PCs. Here is the packages which were updated on the one not working, from the one that is still working because I didn’t update yet.

zypper up
Loading repository data...
Reading installed packages...


The following 140 packages are going to be upgraded:
  Mesa Mesa-libEGL1 Mesa-libGL1 Mesa-libglapi0 MozillaFirefox MozillaThunderbird autoyast2-installation bind-libs bind-utils crda cups-filters cups-filters-cups-browsed
  cups-filters-foomatic-rip cups-filters-ghostscript deltarpm device-mapper gnome-online-accounts gnome-online-accounts-lang google-chrome-stable grub2 grub2-i386-pc grub2-snapper-plugin
  grub2-x86_64-efi gtk2-branding-openSUSE gtk2-data gtk2-engine-hcengine gtk2-immodule-amharic gtk2-immodule-inuktitut gtk2-immodule-thai gtk2-immodule-vietnamese gtk2-lang gtk2-tools iagno
  iagno-lang krb5 krb5-32bit libQt5Core5 libQt5DBus5 libQt5Gui5 libQt5Network5 libQt5Widgets5 libQt5X11Extras5 libXfont1 libdcerpc-binding0 libdcerpc-binding0-32bit libdcerpc0 libdcerpc0-32bit
  libfreebl3 libgbm1 libgensec0 libgensec0-32bit libgoa-1_0-0 libgoa-backend-1_0-1 libgtk-2_0-0 libldb1 libldb1-32bit libndr-krb5pac0 libndr-krb5pac0-32bit libndr-nbt0 libndr-nbt0-32bit
  libndr-standard0 libndr-standard0-32bit libndr0 libndr0-32bit libnetapi0 libnetapi0-32bit libnuma1 libopenssl1_0_0 libopenssl1_0_0-32bit libpng12-0 libpng15-15 libpng16-16
  libqt5-qtbase-platformtheme-gtk2 libqt5-qtimageformats libregistry0 libsamba-credentials0 libsamba-credentials0-32bit libsamba-hostconfig0 libsamba-hostconfig0-32bit libsamba-passdb0
  libsamba-passdb0-32bit libsamba-util0 libsamba-util0-32bit libsamdb0 libsamdb0-32bit libselinux1 libselinux1-32bit libsgutils2-2 libsmbclient-raw0 libsmbclient-raw0-32bit libsmbclient0
  libsmbconf0 libsmbconf0-32bit libsmbldap0 libsmbldap0-32bit libsoftokn3 libtalloc2 libtalloc2-32bit libtdb1 libtdb1-32bit libtevent-util0 libtevent-util0-32bit libtevent0 libtevent0-32bit
  libvdpau_nouveau libwbclient0 libwbclient0-32bit libxml2-2 libxml2-tools lvm2 mozilla-nss mozilla-nss-certs mozilla-nss-tools nfs-client ntp numactl openssh openssh-helpers openssl os-prober
  pytalloc pytalloc-32bit samba samba-32bit samba-client samba-client-32bit samba-libs samba-libs-32bit samba-winbind samba-winbind-32bit sg3_utils shim star systemd-presets-branding-openSUSE
  tigervnc xorg-x11-Xvnc xorg-x11-server xorg-x11-server-extra yast2-installation yast2-network


140 packages to upgrade.
Overall download size: 185.6 MiB. Already cached: 0 B. After the operation, additional 3.7 MiB will be used.
Continue? [y/n/? shows all options] (y):

I’ve rebooted these PCs and they came up alright but after applying the above updates on the one it is not showing anything.

Is that a “Hewlett Packard Compaq 6000 Pro (AX353AW#ABD)”?

If so, google told me it would use Intel GMA 4500 Dynamic Video Memory Technology 5.0. But on the other hand you received an update for “libvdpau_nouveau” so you might have an NVIDIA graphic device.

Please provide the result of

hwinfo --gfxcard

Best regards

susejunky

hwinfo --gfxcard
10: PCI 02.0: 0300 VGA compatible controller (VGA)
  [Created at pci.366]
  Unique ID: _Znp.aCnxMzTjBG4
  SysFS ID: /devices/pci0000:00/0000:00:02.0
  SysFS BusID: 0000:00:02.0
  Hardware Class: graphics card
  Model: "Intel 4 Series Chipset Integrated Graphics Controller"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x2e12 "4 Series Chipset Integrated Graphics Controller"
  SubVendor: pci 0x103c "Hewlett-Packard Company"
  SubDevice: pci 0x3048
  Revision: 0x03
  Driver: "i915"
  Driver Modules: "drm"
  Memory Range: 0xf0000000-0xf03fffff (rw,non-prefetchable)
  Memory Range: 0xe0000000-0xefffffff (ro,non-prefetchable)
  I/O Ports: 0x1230-0x1237 (rw)
  IRQ: 31 (6 events)
  I/O Ports: 0x3c0-0x3df (rw)
  Module Alias: "pci:v00008086d00002E12sv0000103Csd00003048bc03sc00i00"
  Driver Info #0:
    Driver Status: i915 is active
    Driver Activation Cmd: "modprobe i915"
  Config Status: cfg=new, avail=yes, need=no, active=unknown


11: PCI 02.1: 0380 Display controller
  [Created at pci.366]
  Unique ID: ruGf.5f8aGpmNTt9
  SysFS ID: /devices/pci0000:00/0000:00:02.1
  SysFS BusID: 0000:00:02.1
  Hardware Class: graphics card
  Model: "Intel 4 Series Chipset Integrated Graphics Controller"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x2e13 "4 Series Chipset Integrated Graphics Controller"
  SubVendor: pci 0x103c "Hewlett-Packard Company"
  SubDevice: pci 0x3048
  Revision: 0x03
  Memory Range: 0xf0400000-0xf04fffff (rw,non-prefetchable,disabled)
  Module Alias: "pci:v00008086d00002E13sv0000103Csd00003048bc03sc80i00"
  Config Status: cfg=new, avail=yes, need=no, active=unknown


Primary display adapter: #10



I decided to do some experimenting on a VM so I could test a few things out. I dropped the image down but it wouldn’t boot.

I looked at the other two physical PCs I have and even though I have the /etc/fstab file set to use the LABELS:

/dev/sda1            swap                 swap       defaults              0 0
/dev/sda3            /                    ext4       acl,user_xattr        1 1
/dev/sda2            /boot                ext4       acl,user_xattr        1 2

It looks like maybe grub2 is still set to use the UUID:

blkid
/dev/sda1: UUID="692e4fba-6d82-4981-91ef-c4fe858bf711" TYPE="swap" PARTUUID="000b42c7-01"
/dev/sda2: UUID="218aceba-9683-4daa-a561-2d1e8a4479ea" TYPE="ext4" PTTYPE="dos" PARTUUID="000b42c7-02"
/dev/sda3: UUID="af3c2f90-f3b1-4493-acdc-8bc690473294" TYPE="ext4" PARTUUID="000b42c7-03"

The VM when attempting to boot after I dropped the clonezilla image down gave me this error:

Starting Dracut Emergency Shell...
Warning: /dev/disk/by-uuid/af3c2f90-f3b1-4493-acdc-8bc690473294 does not exist
Warning: Boot has failed. To debug this issue add "rd.shell rd.debug" to the kernel command line.

How and where can I change this so it is using the LABEL and not the UUID?

10: PCI 02.0: 0300 VGA compatible controller (VGA)” looks OK to me. I do not understand what “11: PCI 02.1: 0380 Display controller” is about.

The update you received included an update for GRUB2 (grub2, grub2-i386-pc, grub2-snapper-plugin, grub2-x86_64-efi, shim) so it might be worth trying to re-install your bootloader by

  1. starting up your machine with a LIVE-media (e.g. the openSUSE 42.1 install DVD in rescue mode)
  2. chroot to the installed system
  3. re-install GRUB2.

I do not use VMs so a can’t assist you with that.

Best regards

susejunky

Unfortunately that didn’t work either. Is there someplace that I can change the UUID to use the LABEL /dev/sda1, /dev/sda2, and /dev/sda3 across the entire system? My /etc/fstab is set that way but it looks like the UUID is being called from other places and I would like to change all UUID references for the udev devices.

http://i64.tinypic.com/2s9u29x.png

This somehow looks familiar to me.

I once had a similar problem with YaST2 and GRUB2 on a BIOS based machine with a disk that used a MBR partition layout. When i recall all this correctly then there was a file in “/boot/grub2” which was called something like “grubinstalldevice” which held the UUID of the disk to which GRUB2 had been originally installed. After i corrected the UUID in that file YaST2 worked again. As soon as i have access to that machine again i will check for the correct name of that file. Nevertheless when i had to fix my GRUB2 setups in a chroot environment i never used YaST2 but always did it by

# grub2-install /dev/sdxx
# grub2-mkconfig -o /boot/grub2/grub.cfg

If you want GRUB2 not to use UUID when passing the root-device to the kernel you can set

GRUB_DISABLE_LINUX_UUID=true

in the file “/etc/default/grub”.

By the way: Do you have a BIOS or an UEFI based machine? Does your disk have a MBR or a GPT partition layout?

With UEFI/GPT things might be slightly different.

Best regards

susejunky

/etc/default/grub_installdevice

Thank you very much, arvidjaar!

I did recall all this only very vaguely. Now i am back home and checked my other machine.

Just for information: This is the contents of my “etc/default/grub_installdevice”

/dev/disk/by-id/scsi-0ATA_Samsung_SSD_840_S1ANNSAF312101Y
activate
generic_mbr

Best regards

susejunky

Please be aware:
OS device names (like /dev/sdxx) are not always stable. The kernel may probe drives in a different order from boot to boot. To tell GRUB2 not to use UUIDs might cause problems.

Best regards

susejunky

It appears clonezilla doesn’t do a good job of changing these values as one machine, the master, is working fine but the ones I imaged with after updates are giving me this fit. I am going to try and change the /etc/default/grub_installdevice to /dev/sda2 which is my /boot partition.

Maybe I missed a setting when I created the image with clonezilla.

Check the UUID it may have changed for new parititions

Is that with the blkid command?

http://img4.imagetitan.com/img4/small/13/13_capture181.png](http://img4.imagetitan.com/img.php?image=13_capture181.png)

Where and how do I update the UUID across the system?

UUID is a random number generated each time a partition is created and serves as a unique identifier for the partition. It is used in /etc/fstab and Grub and if the numbers in those files do not match the numbers on the drive things will not boot. Compare the values in /etc/fstab and those reported by blkid from the live boot. If different that is the problem.

Ok, yeah they are different. The /etc/fstab has

/dev/sda1/   swap
/dev/sda2/   /
/dev/sda3   /boot

So I should be able to edit the /etc/fstab to match those UUID’s in teh blkid command output? That should solve my problems? Or does this information need to go else where as well?

Well you can use /dev/sdX# also but that may not be stable since it depends on the order things are seen in the BIOS. But if you only have a single drive I suppose it doesnot matter that much but the default usage is UUID so I wonder how you got the dev syntax. Was this an upgrade from an ollder version If so which. UUID has for some time been the default way.