After Leap 15 update, bug in kernel-firmware was freezing bootup process

Performed a Leap 15 update on 1/15/2019. Notice that the system went into a kernel panic, freezing the boot-up process.

The last two lines in the kernel panic were:

Kernel Offset: disabled
— end Kernel panic - not syncing: DMA: Random memory could be DMA accessed

It seems like it was happening just after the AppArmor activation.

I had a recent image backup. Restored the image and tried a few times the same update sequence, piece by piece, until I found the file causing the whole problem:

kernel-firmware 20180525-lp150.2.3.1 while updating to version 20181026-lp150.2.6.1

So the kernel-firmware 20181026-lp150.2.6.1 threw the system in kernel panic. I updated the kernel up to 4.12.14-lp150.12.28-default, but this did not help. Also tried booting, without activating the AppArmor service on the bootup process, but at this point, the system would not boot up at all, after the grub2 screen.

As a last resort, after the resetting the image so many times, I updated all other files, while leaving the new kernel-firmware in taboo status, so it would not upgrade. No problems booting up the system after this point.

This was my first kernel panic ever!

Please be aware.


There are actually several other threads on this problem. There is also an open bug report. And I’m pretty sure there is work going on to resolve the problem.

Most of the reports seem to point to an issue with an atheros WiFi card, or some other WiFi card using the atheros chip set.

Interesting. That I do have. A Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter.

I will keep my ears open.

Thanks for the info.