After large update including Kernel Leap42.2 getting multiple mouse pointers left behind

Updated 42.2 (which included a kernel update and updates to Plasma I noticed) and now my mouse pointer paints several copies of itself when close to a action area. These can be the arrow or the pointing hand or even the I symbol for text entry. Have no idea how to get it to stop. Anyone have any ideas? I checked the mouse settings and I do not see anything there. Thanks for any help.

could you tell us your repo list

zypper lr -d

42.2 updates should be security and bugfix updates only no large updates as far as I know 42.2 should be nearing it’s end of life

I have not updated for a few months.

Repository priorities are without effect. All enabled repositories share the same priority.

| Alias | Name | Enabled | GPG Check | Refresh | Priority | Type | URI | Service

1 | Downloads | Downloads | Yes | ( p) Yes | Yes | 99 | plaindir | dir:///home/mathew/Downloads |
2 | RPM_files | RPM files | Yes | ( p) Yes | Yes | 99 | plaindir | dir:///home/mathew/RPM%20files |
3 | google-earth | google-earth | Yes | ( p) Yes | No | 99 | rpm-md | |
4 | | libdvdcss repository | No | ---- | ---- | 99 | rpm-md | |
5 | | Packman Repository | Yes | (r ) Yes | Yes | 99 | rpm-md | |
6 | openSUSE_42.2-0 | openSUSE 42.2-0 | No | ---- | ---- | 99 | yast2 | hd:///?device=/dev/disk/by-id/wwn-0x2000acde48234567-part2&filesystem=auto |
7 | repo-debug | openSUSE-Leap-42.2-Debug | Yes | (r ) Yes | Yes | 99 | yast2 | |
8 | repo-debug-update | openSUSE-Leap-42.2-Update-Debug | Yes | (r ) Yes | Yes | 99 | rpm-md | |
9 | repo-debug-update-non-oss | openSUSE-Leap-42.2-Update-Debug-Non-Oss | Yes | (r ) Yes | Yes | 99 | rpm-md | |
10 | repo-non-oss | openSUSE-Leap-42.2-Non-Oss | Yes | (r ) Yes | Yes | 99 | yast2 | |
11 | repo-oss | openSUSE-Leap-42.2-Oss | Yes | (r ) Yes | Yes | 99 | yast2 | |
12 | repo-source | openSUSE-Leap-42.2-Source | Yes | (r ) Yes | Yes | 99 | yast2 | |
13 | repo-source-non-oss | openSUSE-Leap-42.2-Source-Non-Oss | Yes | (r ) Yes | Yes | 99 | yast2 | |
14 | repo-update | openSUSE-Leap-42.2-Update | Yes | (r ) Yes | Yes | 99 | rpm-md | |
15 | repo-update-non-oss | openSUSE-Leap-42.2-Update-Non-Oss | Yes | (r ) Yes | Yes | 99 | rpm-md |

The multi pasted mouse pointer images go away after a little time but it is annoying.

Never mind. A thought occurred to me to do a complete power off and restart and the mouse pointer issue is resolved. Somehow the simple reboot (plus a couple of other reboots during the process) after install left a problem.

All fixed now.

After a large update you probably had mixed versions of software and a restart is needed to start using only the new stuff

You can always check what need a restart/boot with as root zypper ps command

I guess it is not all fixed. For some reason I get the pointer problem still occasionally when and after using the FF browser requiring a power off restart to have it go away. I hate that kind of problem. Something interfering with something else. But not all the time.

Incidentally Forum, you should have a persistent signin option. Having to logon each time you want to use the Forum is not the best.

what graphic card and driver do you use, if using propitiatory drivers they need to be updated when the kernel gets updated
this sounds like hardware acceleration issue, the compositor gets disabled if kwin5 crashes or is missing appropriate drivers
in plasma 5 settings in the top right corner in the filter type “compositor” then open the compositor settings and see if it’s using software rendering or opengl if it’s software select one of the hardware accelerated modes (it depends on your video driver)

the forum uses cookies to keep you logged in a persistent sign-in option might not sit well with a lot of users
how get signed out depends on your browser settings I usually kill off cookies when I close my browser so I re-login after a browser restart there are ways to keep some cookies alive

The graphic chip is Intel. Built in. I am reloading the intel driver to see if that helps. BTW the compositor selected is OGL 3.1 with selection for OGL 2.0 and Xrendering.

Reloading the video driver did not solve the problem. Might just be something I will have put up with. Other than the multiple pointer images functionality of the system seems ok.

I don’t have an intel gfx so I haven’t had this issue but there is a known issue with intel sna acceleration (which is used by default) and plasma 5 the fix is to use uxa acceleration,
this has to be done manually create the file /etc/X11/xorg.conf.d/20-intel.conf

kdesu kate /etc/X11/xorg.conf.d/20-intel.conf

and paste this in it

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod"  "uxa"

Good thinking and research I_A. My thanks for being willing to attempt fixing my issue. It certainly sounds like the Plasma 5/Intel bug is a likely candidate to be the problem. Incidentally, after trying your code (kdesu kate /etc/X11/xorg.conf.d/20-intel.conf) to create the file I kept getting back a unable to complete the command. Being a bit rusty on this command line stuff I tried Dolphin in SU mode to navigate to .etc/X11/xorg.conf.d and than right clicked- create text file. After the file was created I opened it (noticing it opened in KWrite, seems kate text editor is not installed as part of a standard install these days. Which explains why the kdesu kate did not work.) and pasted in the contents as you indicated. Saved, exited and power off restart.

Hopefully this fixes it now. I do appreciate the extra mile you have gone to.

Well after several hours the mouse pointer problem has not reappeared. I also think some other minor glitches, freeze ups and responsiveness with the desktop have also been resolved.

Thanks again for the fix. :slight_smile: