After KDE4 update kickstart menu button back to default K?!?

Basically after performing a large update yesterday (using nothing but the pre defined repositories) by selecting Packages -> All Packages -> Update if newer version is available from the Yast2 menu the KDE4 kickoff menu button is back to the standard KDE menu (with the blue K), and I happened to rather like the green lizzard there. Also it’s not possible to move icons around on the taskbar anymore, very unhandy.

Any idea how to get it back other than a clean install?

Have a go at bottom panel/taskbar: R-click → panel options → add widgets → application launcher menu (add it). It might add the Lizard back (or not, just a thought).

Actually it didn’t. What did work however, it to completely remove all all kde4 packages, remove the KDE factory repository (or put it at a very low priority) and then reinstall the base KDE4 installation … you’ll notice there are a few SUSE branded packages installed as well that are responsible for the SUSE theming.

However now I have some weird gnome like package installer for dummies which I really don’t like so I guess I’ll just reinstall from the DVD and update very sparingly, making a note of what gets upgraded in order to downgrade when needed.

I’m still waiting for my DVD but I do have a dodgy one in the meantime to play with. While I wait I’m going to reinstall with KDE3.5 and then install KDE 4.1 latest factory repositories version rather than the KDE4 on the standard media. I read that it’s significantly better than the one on the DVD.

Installing KDE 4.1 fresh from the factory might work. What I had done is installed 4.0.4 from the normal repositories, installed quite a few additional kde4 packages and then upgraded to 4.1. Because not all packages could be upgraded a lot of things were broken (even had to remove ~/kde4). It seemed 4.1 did have some improvement, but also some features were lost, like the ability to customize the order of things on your taskbar and some (not all) of the SUSE customizations.

Good luck anyways.

I had that revert to K thing happen with RC1. I’ve since installed the released version from the Live CD (KDE) and I still have the lizard, but I’ve got something else weird happening.

I went into the Menu Editor as I am want to do to tidy things up and make categories to my liking. So I went through and tried to make some RARE subfolders where I could tuck things that I know I won’t use hardly ever but some things refused to budge from their location. On Kubuntu 8.04 I was able to add subfolders under each predefined category and shuffle things that way. Anyway, I gave up and just deleted items I knew I wouldn’t need. Now, after rebooting, I get recursing …whoa. Just tried to reproduce the error and it stopped. Anyway, I would navigate to /System/Desktop Applet or /System/File Manager and under there would be the whole menu tree again instead of what should be there. I just switched from KickOff to Classic and back and it appears to have stopped. BUT, what has stuck is under /Utilities, I only see the Desktop submenu item even though in Menu Editor there are obviously other things like Calculator, /Printing/Manage Printing and so on.

I’ve done several updates and have added numerous apps. Any way to fix/refresh/revert the menu tree while still having access to all the things that are installed?

I think if you want to use the chameleon image, you have to use the kde4-workspace-branding-opensuse.
In my case I want to use the original k-menu image so I installed the kde4-workspace-branding-upstream.

To see the available choices in yast2, use the search and type branding and you will find out what you are missing.

Hope this helps,

Hi, I have the same problem, loosing the green gekko after update, (newly installed 11.0/KDE4), but also some icons look different and changed into the same looking icon with the ‘computerlook’ or the ‘desktoplook’. Esp. the icons in the starter menu for closing and restarting etc. all look the same. I tried your solution (see quote), but this doesn’t do the trick.

Now I don’t know how to get all the desktop icons back!
Some more ideas? thanx

i found the solution for my problem; just install the extra icon packages in yast2 for kde4!