After KDE Konqueror install/update, no display, mouse pointer is OK

Dear friends,
I love my Leap 42.3 KDE Plasma 5 operating system: thank you very much.

About a month ago, I tried to get Konqueror running and found an install command (don’t remember where). During the connection, it showed that it was approximately 400MB download and while watching I saw that it was not only downloading Konqueror, but also KDE:Qt4 and KDE:Frameworks, etc.

When finished, I re-booted to a gray screen (not black) and a movable mouse pointer. I have read so many articles that showed similar instances, but not mine: nothing worked.
I’ve learned a lot about accessing YAST from command line: working from iceWM and XFCE and have tried all sorts of things but nothing works.
I’ve tried rolling back with SNAPPER, to no avail.

I am now running with no problems on my msata drive with Leap 42.3 installed KDE Plasma 5 desktop. I deduce that hardware is not a problem.
I have a ThinkPad T530 with a 256GB SSD drive. GRUB is working just fine when selecting Windows 10 or Leap 42.3.
Boot-up is fine until it gets to the KDE Plasma 5 desktop.

I considered using dd command to transfer from the msata partition to the broken partition, but I would like to learn what happened and how to fix it.
How do I get my KDE Plasma 5 desktop working again?
Thank you,

I do nnot understand why you downloqded Konqueror from somewhere (and it would have been helpful if you could have told us from where), because it has been part of KDE since forever, and if for some reason it was not installed it could have been selected and installed from YaST Software Manager.

It appears that you have probably installed an alien repository and then installed a different version of Konqueror and all of its dependencies, leaving your Plasma borked. The answer is to remove the alien repository and then use the zypper command to reinstall the openSUSE KDE pattern of packages.

Restart the machine and select the broken Leap-42.3. When you get to the non-existent graphical login screen press <ctrlaqlt+F!> keys. This should take you to a monochrome Linux console with a Login prompt. Login as a user. There is generally no visual feedback for the password entry so do not double-key.
Display the list of active repositories, look for the alien and disable it like this (you will have to scroll down):

sysman@ns3:~> zypper lr -Ed        
Repository priorities are without effect. All enabled repositories share the same priority.

#  | Alias               | Name                | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                                                            | Service
 7 | 42.3-Packman        | 42.3-Packman        | Yes     | (r ) Yes  | Yes     |   99     | rpm-md |                                             |        
 8 | 42.3-Repo-oss       | 42.3-Repo-oss       | Yes     | (r ) Yes  | Yes     |   99     | yast2  |                                                  |        
 9 | 42.3-Update-non-oss | 42.3-Update-non-oss | Yes     | (r ) Yes  | Yes     |   99     | rpm-md |                                                          |        
10 | 42.3-Update-oss     | 42.3-Update-oss     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md |                                                              |        
15 | lang-ruby-extens   | lang-ruby-exttens   | Yes     | (r ) Yes  | No      |   99     | rpm-md |               |        
sysman@ns3:~> sudo zypper  mr -d 15
Repository 'lang-ruby-exttens' has been successfully disabled.

Your macihine has Intel CPU, WiFi, Ethernet and graphics, so you will ony need repositories that look spmething like the first four (#7,8,9,1p) above.
Repeate the

:~> zypper lr -Ed

tocheck. When you are happy execute the following to restore (hopefully a working system. NB I am assuming that you have a wired cable connection, and do not have to have a graphical login to achieve a network connection.

 ~>  sudo zipper dup 

If that seems to work, Reboot

 ~>  sudo systemctl reboot 

And hope for the best.

@eng-it : FWIW: I guess ‘zipper’ won’t do much :D.

I’m not sure what you did there. It seems as if you installed the old konqueror from KDE4.

I have konqueror installed here with 42.3. I installed from the openSUSE repos. It is a Plasma 5 version of konqueror. It is currently open on my desktop, and working fine. Well, okay, “fine” might be too strong, but working pretty well.

Well spotted Knurpht – I am blaming the 1st April gremlins.

 ~>  sudo z**y**pper dup 

Thank you all for your help and time.
Answer to the first question regarding download sources:
I am very finicky about where I get my downloads, so I’m guessing I got it from KDE.
Didn’t know I could get it a better way (ie repository). Learn something every day.

On the other suggestions, I will be doing those steps as soon as I can and will let you all know.
Many thanks,

Which means that, it hasn’t been built against the openSUSE environment and, it hasn’t been passed by the openSUSE openQA process …

Dear friends,
I deleted a whole bunch of repositories. Some were duplicates, some were source, some were KDE:Framework, Qt5 and 2 were Chrome dL (think that’s what it was). One was for the openSUSE 42.3 DVD in the computer DVD drive.
Reduced them down to the regular ones as suggested by eng-int (rayH).
Finished with zypper dup and systemctl reboot.

Well, made a little bit of progress: I’ve got the Plymouth splash screen and can access a few things, but Plasma 5 does not appear to be working yet.
Meaning that the alternative full screen app launcher that I like, still does not work. I still have to access YAST from command line.

The last comment from dcurtisfra]( saying I used a app that was not built against openSUSE, then he is probably right.

Anymore suggestions?

I will add more as I can.
Thank you all,

At least post your present repo list so we can see what is in there.

zypper lr -d

Sorry for the delay: had to fix a Windows 10 problem. Success!

Not able to cut and paste zypper lr -d Here it is the hard way:
openUSE-lEAP-42.3-0 (this is the Leap 42.3 DVD)
Packman Repository

I created another user and that worked just fine.
Suggestions, please?


If it works fine for another user, then it is something in your user settings.

I am seeing those as:
and various files in

The older konqueror from KDE4 used to keep its configuration in
and various files in
(Those are from memory – I don’t have those on my current 42.3 system).

You might try removing all of those files. Well, don’t actually remove them, but rename them or move them to different directories somewhere. Then logout and login. And see if konqueror now works. If it does, it will have lost all of its configuration, but you might be able to restore some of that from the renamed files.

I’d consider removing ~/.local/share/kscreen whilst being logged out. That should force recreation of the display settings.

Thank you Knurpht,

While logged in to my new user (david), and looking in the old user (dave), could not find the files you were referring to: “$HOME/.config/konquerorrc”
and various files in “$HOME/.local/share/konqueror”. No problem getting to said directories, but files were not there.

Thank you Knurpht,
While logged in to new user, david, found and renamed dave/.local/share/kscreen: no success. Still have blank screen with mouse pointer.

Suggestions, please.

Can I reinstall KDE Plasma 5 for old user, dave, without messing up the new user, david?


Login as “dave” at the command line or with Icewm.

 rm -rf .config .local .kde4

And then logout, and now login to KDE. Your KDE configuration should get a completely fresh start.

When I do that, instead of removing those directories, I move them elsewhere:

mkdir OLD
mv .config .local .kde4 OLD/.

That way I can recover some data from the old files if needed. And I can later remove OLD and its content.

That did the trick. Thank you so very much! I appreciate all of your help.
Also, thank you for the additional info on saving to OLD folder: I understand. I didn’t have that much custom stuff… Only took me a few minutes to recover.
I will continue learning, of course. I installed Konqueror using zypper, but had library problems which I quickly fixed by reinstalling using Software Manager in YAST.
David Weekley

I’m glad you have things back working again.

Dear friends,
I have one more thing to add regarding the rm -rf .config .local .kde command:
I learned the hard way that I should have used the second suggestion (mkdir OLD mv .config .local .kde4 OLD/) . I had to re-download all of my emails (I use Thunderbird email client)
plus some other things.
Thanks again.
I have not yet learned how to close this thread.
Have a great day,

IOTW, you leave all your e-Mails on the ISP’s server or, whoever it is who handles your e-Mail traffic.

  • It’s not a bad way of ensuring that e-Mails can not be “lost”, given that there’s enough capacity there …

Personally, I prefer to archive my e-Mails locally and, at least for the case of the Desktop machine, not leave them on the ISP’s server – personal preference …

Given your KDE GUI, why prefer the Mozilla e-Mail client over the KDE PIM (Kontact)?

Comparing “Thunderbird on Windowz” to “Kontact on Linux”, my personal view is, the current KDE product does a much better job of integrating e-Mail, contact addresses, tasks and appointments, journal, notes, RSS feeds and KWallet integration and, the KDE e-Mail client is, IMHO, more comfortable, as well as and also …

Yes, yes, we all suffered when KDE moved from Qt4 to Qt5 (Web) but, the KDE folks have ironed out almost all of the things which were causing irritation (a repair for the printing issue has recently been submitted) – let’s admit that, there wasn’t really anything which was causing “pain” – the product remained “useable” despite the issues we suffered …

My current personal vote is: “Use KDE Kontact, for all PIM activities.”

AFAIK, there’s no concept of “closing a thread” in the openSUSE Forums – it ain’t a Change Request (Bug Reporting; Error Reporting) database.

Hello dcurtisfra,
I see you are online: howdy!

I am now trying Kontacts. It failed to import from Thunderbird, so I need to do some homework.
I have been using Thunderbird for years and like the calendar capabilities. I see that Kontacts has that as well and maybe more from what I see on the left pane.

I use IMAP. I think it allows download and keeps the mail on the server. I see it downloading my emails.

Thanks again for your help.

Yes indeed! In fact, the e-Mails you send are also kept on the server …

  • Which is exactly what commercial enterprises, such as your employer, need …

If you’re working for an employer, your involvement in your employer’s e-Mail traffic is your employer’s e-Mail traffic and, commercial legislation normally requires that businesses keep copies of all documents related to that business.

[HR][/HR]Which raises the question, does this apply to a private person?

My personal view is, it doesn’t. Which is why I prefer to use POP(3) rather than IMAP, despite my Internet Service Provider (ISP) offering both e-Mail protocols. And, for the case of my Desktop machine, I do not leave received e-Mail on the ISP’s servers – only for the case of my Laptop but, in that case I’m “not at home” …

Exactly what my ISP does with my sent e-Mails, to be perfectly honest, I don’t know …*On the other hand, when I post a physical letter, as soon as I give that letter to the local postal authority, it’s no longer “mine” …
IMHO, e-Mail is exactly the same – when I “send” the e-Mail, it’s no longer “mine” …