After installing openSUSE I cant boot Ubuntu

Hi,
I bought a Linux magazine as a Christmas present attached to it was a 8GB distro-loaded disc sporting Ubuntu 9.10 (which is already on my system,) Mandriver, and open-SUSE 11.2 which I decided to install.
Problem is, I can’t get into Ubuntu anymore, where all my mail music ect is.

Ubuntu is listed with vista in window 2 of open-suse grub. When I try to boot Ubuntu I get an earlier kernel splash which is somewhat magnified and busybox v1.1.3. Vista boots OK.

Would un installing openSUSE put things back as they were? I can learn about open-SUSE using the DVD

Not necessarily.

Please run

fdisk -l

to display your drives and partitions. Fdisk has to be run as root, so use su or sudo. Be careful with the fdisk command. Make sure it has the -l to it, and only run that command.

Sorry for the delay Jonathon.

linux-ry1h:/home/graham # fdisk -l

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x78000000

Device Boot Start End Blocks Id System
/dev/sda1 1 8 64228+ de Dell Utility
/dev/sda2 9 1314 10485760 7 HPFS/NTFS
/dev/sda3 1314 19597 146856445+ 7 HPFS/NTFS
/dev/sda4 * 19598 38913 155155770 5 Extended
/dev/sda5 19598 21425 14683378+ 83 Linux
/dev/sda6 38161 38913 6048441 82 Linux swap / Solaris
/dev/sda7 21426 37475 128921593+ 83 Linux
/dev/sda8 37476 38160 5502231 82 Linux swap / Solaris

Partition table entries are not in disk order
linux-ry1h:/home/graham #

I wouldn’t uninstall at all… sounds like a problem with your GRUB.

Was that Linux Format by any chance? You can also post on their forum…

Yes LFM, I did not know that they had a forum.

Grub (openSUSE) and Grub2 (Ubuntu 9.10) don’t always play nice together.

Here is a guide to get your Ubuntu Grub back.

Start with

Do not use Ubuntu 9.10 live CD to restore the boot loader from a previous version.
And end with
Reboot, making sure to boot to your hard drive and not to the live CD. Grub should be installed and both Ubuntu and Windows should have been automatically detected.
Then boot into Ubuntu and run the command

sudo update-grub2

That should restore everything.

I started with hardy heron 8.04.01 and upgraded to 9.10 via upgrades, so I don’t know what version grub I have now .

You don’t have Grub2 then.

You should be able to just add the Ubuntu Grub entry to the openSUSE Grub to get into Ubuntu.

Like I said earlier.
Ubuntu is listed with vista in window 2 of open-suse grub. BUT When I try to booting Ubuntu I get an earlier kernel (not9.10) splash which is somewhat magnified a really fat scrolling bar whilst loading, then:

busybox v1.1.3. initramfs

That’s why you should find the correct entry and add it to the openSUSE Grub.

please tell me How.

In a terminal, as root:

cat /boot/grub/menu.lst

Then using Dolphin, browse to /boot/grub/menu.lst in the Ubuntu root partition. You’ll need to enter your Ubuntu password to access that partition.

Copy the contents of both the terminal output and the Ubuntu ***/boot/grub/menu.lst file ***and paste into a reply.

Thanks,

graham@linux-ry1h:~> su
Password:
linux-ry1h:/home/graham # cat /boot/grub/menu.lst

Modified by YaST2. Last modification on Mon Jan 4 20:14:23 GMT 2010

THIS FILE WILL BE PARTIALLY OVERWRITTEN by perl-Bootloader

Configure custom boot parameters for updated kernels in /etc/sysconfig/bootloader

default 0
timeout 8
##YaST - generic_mbr
gfxmenu (hd0,4)/boot/message
##YaST - activate

###Don’t change this comment - YaST2 identifier: Original name: linux###
title openSUSE 11.2 - 2.6.31.8-0.1
root (hd0,4)
kernel /boot/vmlinuz-2.6.31.8-0.1-default root=/dev/disk/by-id/ata-WDC_WD3200AAKS-75B3A0_WD-WMAT12413982-part5 resume=/dev/disk/by-id/ata-WDC_WD3200AAKS-75B3A0_WD-WMAT12413982-part6 splash=silent quiet showopts
initrd /boot/initrd-2.6.31.8-0.1-default

###Don’t change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe – openSUSE 11.2 - 2.6.31.8-0.1
root (hd0,4)
kernel /boot/vmlinuz-2.6.31.8-0.1-default root=/dev/disk/by-id/ata-WDC_WD3200AAKS-75B3A0_WD-WMAT12413982-part5 showopts apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 x11failsafe
initrd /boot/initrd-2.6.31.8-0.1-default

###Don’t change this comment - YaST2 identifier: Original name: windows 1###
title windows 1
rootnoverify (hd0,1)
chainloader +1

###Don’t change this comment - YaST2 identifier: Original name: windows 2###
title windows 2
rootnoverify (hd0,2)
chainloader +1
linux-ry1h:/home/graham #

access is denied for: /boot/grub/menu.lst file and I can’t find where to enter password.

I think tjis is it,I found it at:

Root>windows>D>ubuntu>install>boot>grub

#This file is modified at runtime by bootmenu.nsh

debug off
hiddenmenu
timeout 5
default 0

title Start installer in normal mode
find --set-root --ignore-floppies /ubuntu/install/boot/vmlinuz
kernel /ubuntu/install/boot/vmlinuz debian-installer/custom-installation=/ubuntu/install/custom-installation noprompt quiet splash boot=casper ro debian-installer/locale=en_GB.UTF-8 console-setup/layoutcode=gb console-setup/variantcode= –
initrd /ubuntu/install/boot/initrd.gz
boot

title Start installer in safe graphic mode (only if you have display problems)
find --set-root --ignore-floppies /ubuntu/install/boot/vmlinuz
kernel /ubuntu/install/boot/vmlinuz debian-installer/custom-installation=/ubuntu/install/custom-installation noprompt debug debug-ubiquity xforcevesa boot=casper ro debian-installer/locale=en_GB.UTF-8 console-setup/layoutcode=gb console-setup/variantcode= –
initrd /ubuntu/install/boot/initrd.gz
boot

title Start installer with ACPI workarounds (only if you have ACPI problems)
find --set-root --ignore-floppies /ubuntu/install/boot/vmlinuz
kernel /ubuntu/install/boot/vmlinuz debian-installer/custom-installation=/ubuntu/install/custom-installation noprompt debug debug-ubiquity boot=casper ro debian-installer/locale=en_GB.UTF-8 console-setup/layoutcode=gb console-setup/variantcode= – acpi=off noapic nolapic
initrd /ubuntu/install/boot/initrd.gz
boot

title Start installer in verbose mode
find --set-root --ignore-floppies /ubuntu/install/boot/vmlinuz
kernel /ubuntu/install/boot/vmlinuz debian-installer/custom-installation=/ubuntu/install/custom-installation noprompt debug debug-ubiquity boot=casper ro debian-installer/locale=en_GB.UTF-8 console-setup/layoutcode=gb console-setup/variantcode= –
initrd /ubuntu/install/boot/initrd.gz
boot

title Read-Only Demo (Live CD Desktop)
find --set-root --ignore-floppies /ubuntu/install/boot/vmlinuz
kernel /ubuntu/install/boot/vmlinuz quiet splash boot=casper ro debian-installer/locale=en_GB.UTF-8 console-setup/layoutcode=gb console-setup/variantcode= –
initrd /ubuntu/install/boot/initrd.gz
boot

Did you install Ubuntu with WUBI?

If you did then this is all for naught.

If you installed from the Live CD then:

Try alt + F2, then kdesu dolphin.

Then try to browse for the file.

If that doesn’t work you may have to log into openSUSE as root to do it.

What partition do you have Ubuntu on? I had the same problem wiht openSUSE, ubuntu and windows 2000.

openSUSE setup wants to write a generic bootcode in mbr and activate its boot partition, which is not the same as installing Grub there but has the same effect: you just end up booting openSUSE Grub.

However, if you go in the boot options during install and uncheck everything there, you will still boot in Ubuntu Karmic Grub2. Just disabling ‘boot from mbr’ is not enough.

My Ubuntu was installed in vista about three years ago (hardy heron) and gradually my computing migrated to Ubuntu so thats where most of my work is now done.
I just decided to give myself a treat and got a Linux publication loaded with other operating systems and decided to install Open suse, then after that Mandriver. It would be nice to choose booting for all from the vista/Ubuntu Grub loader but its not important.

It would be nice to get to Ubuntu again, judging by the replies I might not have to lose all my data sitting there out of reach.

Later, (got to go) I will carefully follow the advice given, (I love Linux)

thanks

Is your ubuntu on windows or a stand alone partition. if so, what partition is it on. Are you using openSUSE grub or ubuntu grub. either way you need to use a symlink. I should be able to give you the code, but you need to tell me what partition it is on.