After installing on a LVM no boot device can be found after startup


I tried to reinstall my openSUSE installation today. I had installed Tumbleweed before but wanted to use Leap now.

So my hard drives look like this

Intel SSD

  • fat32 → /boot/efi
  • ext4 → /boot
  • swap → swap (encrypted)
  • lvm → vg System → / (root) (encrypted)


  • lvm → vg xs → /home (encrypted)

I’m not sure if it has something to do with the btrfs filesystem as I mentioned in this thread:

But now I used ext 4 for the root partition but after the installation I get the message that no boot device can be found. But actually I made an extra uefi boot partition which is unencrypted. Here is also a screenshot I did from the configuration when installing the system. I also tried with deleting the second /boot partition but didn’t help.

What else could I try?

Thank you very much

There was a bug that I ran into when testing 13.1 at a pre-release stage. I’m not sure of the bug number. It was said to be fixed, but I had no sure way of testing.

What happened, was that after the install I found that “/boot” was empty (except for the “lost+found” directory). What was supposed to be in the “/boot” partition was actually in the “/boot” directory on the root partition and hidden under the mounted “/boot”. I “fixed” it by copying that to the proper “/boot” partition. I’m not sure if I had to also manually re-install grub.

As I recall, this apparently happened because my root partition had previously been formatted as “btrfs”, and I had specified reformatting as “ext4” during the install. Apparently that confused the installer.

I’m not sure if that is what you are seeing. You did not provide enough detail.

Thank you very much for your reply. So you mean the boot partition is now in the / (root) directory which is encrypted so it can’t be found? So i have to copy it from root to the right boot partition.

I also found this thread

I installed my installation via uefi and also uefi boot partition is there.

Sorry but I didn’t find the edit button for the previous post:(

So I have checked my harddisk and I have a partition


which contains the folders


  • bootx64.efi
  • fallback.efi
  • boot.csv
  • grub.cfg
  • grub.efi
  • grub64.efi
  • Shim.efi

and I have also /boot

which contains files like
which is the kernel. so I think everything ok.

But it’s not booting even if the relevant parts are not encrypted?

That all looks okay.

On second thoughts, it doesn’t look okay, but you probably just reported it wrongly.

“/boot/efi” should have “/EFI” and then “/EFI/boot” and “/EFI/opensuse”. The capitalization might be different (not important for a FAT partition).

Check “/boot/efi/EFI/opensuse”. Look at the file dates. Are they from your recent install, or are they older? If they are older, then something went wrong during the install.

Yes you are right it`s


then “Boot” or “opensuse”


Did you check the timestamp (i.e. date) of the files in that opensuse partition? That’s usually the date of install or most recent update. It should tell you whether they come from your recent install or were a left-over from an earlier install.

I have to say that I found no solution so I made a backup of my home directory and did an fresh installation.
Before I tried to reuse the lvm partitions and I formated the /boot and /boot/efi so the files there should have been fresh?

The only thing that I can think about is that whenever I install openSUSE I get a new boot entry in the UEFI/Bios. And I do have to start it through this entry. When I select the right hdd it does not work and I get the error that no OS has been found.

I found out about this because I also use Debian 9 and there I have also to select the Debian entry in the boot menue.
So maybe this hasn’t been updated?

I don’t think you have mentioned what kind of computer you have.

Is it possible that you have an Intel Atom processor? I ask, because those use 32-bit UEFI. And opensuse does not currently support 32-bit UEFI, but Debian does.

Thank you for your reply. No I’m using an Gigabyte Z77X-UD3H Mainboard which was built around 2012. I guess somewhere at this time was the switch between classic bios and the new UEFI. So this is a mainboard comes with both. I can use UEFI and legacy mode bios.

I got the information from this forum that I have to boot the installation disk from the drive with uefi in front of the boot menue. When I do a new installation I always remove all other hdd I don’t need. I have 4 of them: 1 for Debian, 1 for windows, 1 ssd for suse and 1 hdd for the home partition of suse (ssd is only 80gb). so each operating system has it’s own bootloader and uefi partition. Sometimes you have the problem that the operating system writes the bootloader automatically to sda (the first hdd in the system) which can also cause trouble.

It kind of more work when I have to do a fresh installation with new lvm setup because I have to backup the whole lvm/home which get formatted during the process.