After I type login it back to login immediately

After a failed try to update a software using a .ymp file (IIRC the extension of file) my OS started claimed about no left space on hard drive but a lot of free space is available. So I reboot the system to try solve this error but instead of I get another error on login: when I type the password, it accepts, but the system is not up and back to the login immediately. The same problem as this guy (but I also root user (the one which I’m logged right now) I just have one user in this system that I can’t login in) I’ve tried to run the commands as answer suggests althrough it ran without error it changes nothing the login error. If it’s relevant, here’s my open suse version:

# cat /etc/SuSE-release
openSUSE 12.1 (i586)
VERSION = 12.1
CODENAME = Asparagus

Hi, welcome.

IMHO one of the causes of your issues can be logging onto the desktop as root. If the system reports a full HD, don’t just assume that the disk is large enough, it may be just your root partition is full (/tmp flooded), but …

You also need to make a move. Support (don’t read “forums” here, but “updates/fixes”) for 12.1 has stopped months ago. Resulting in repos being no longer there.
If you have /home on a separate partition, you could easily reuse that, by importing the partitioning scheme during a new install.


Thanks again for quickly answer. So, it’s right about no left space for root user but the problem begun before that while I was using the user which doesn’t login anymore where a lot of space is available. I’ve see a guy with this same issue(using KDE but with different distro) that solved that using shell-command to update its distro and it just get back working. I’m doing it right now and if it still didn’t work I will update system version to a newly version. I’m not a Open Suse/Linux expect so I need some help here. When I installed the Open Suse I think that I’ve see some option to I use the files from /home/user instead of, it’s right? will I (re)install and keep all my files ok? does it include the programs I’ve in there? the program is the main cause because I just re-install the system when problem just started. I got a lot of them get all back and working will be a hard job.

Well, but if there is no space left for the root user, there will also be no space left on things like /tmp and /var/tmp (at least on a default installation), which will also prevent every user to log in.
And if that’s the case, an update/upgrade will also fail.

So you should really clean up some space on the / partition in any case. Maybe this in itself will fix your login problem already.

First things to clean would be /tmp, /var/tmp and /var/cache/zypp. Just delete anything in there.

Thanks. It worked fine. I get some free space and logged successfully in the other user but when I back logged as root to reply this to tell you it worked I get 0B free space again. What’s going on? Is this some software running in background and is saving files on my hard disk?

Better, how do I increase size of root space?

Well that is not easy you need to increase the size of the root partition. And depending it may require moving and resizing other partitions. And any time you play with partitions you need to backup any important data.

Show us the output of

fdisk -l

Note that is a lower case L not a one.

Please post output here with code tags. The # in the menu here

Forget that. I just rebooted and I can see the free space from the files I’ve deleted. Thanks very much. Your save my day