After auto-updates to Leap 15, boot menu says Tumbleweed -- can't boot.

Was running Leap 15. Religiously apply updates.
About 2 days ago one related to firmware.
First noticed that sound disappeared and usual fixes didn’t work.
More updates y’day, and much does not work, incl alt-ctl-Fn.
Did hard reboot.
Menu gives options: Tumbleweed (!); Windows 10 (worked ok); Suse 42.3 (! surprise!)
I choose Tumbleweed,

  1. very quick display: “acpi does not cover entire response…” – all I could read

  2. cyrptography [something] fails; & boot process offers box for password but does not accept it.
    Note that no encrypted disk is necessary for booting – they’re just data.

  3. modem manager fails; firewall fails

  4. after boot messages:
    …starting hold until boot process finishes…
    Starting X display manager
    Starting locale services
    [freeze] Hard reboot required.

  5. I think that when updating a couple of days ago, a quick screen indicated that some Tumbleweed repository was added.
    at least, some repository was added without my intervention. But I can’t check that.

Any advice how I can return to Leap 15.1?


Hi, most likely you installed a package via “One-click-install” and that added one or more Tumbleweed repositories…
Can you boot at least to a command line (just press “E” for “Edit” at the GRUB menu, then add the figure 3 to the boot command line and press F10 to boot)?
If so, you may login and check the repository list by issuing:

zypper lr -d

You can disable any TW repo issuing:

sudo zypper modifyrepo -d <number or alias of repo to be disabled>

Then a “zypper dup” with only Leap repos enabled should bring you back to a Leap system.

BTW: are you referring to Leap 15.1 (still at beta stage…) or to the current Leap 15.0?

  1. re my title

    “BTW: are you referring to Leap 15.1 (still at beta stage…) or to the current Leap 15.0?[/QUOTE]”
    Should be 15 . Sorry

  2. re your suggestion to init 3
    Adding param for runlevel 3 yields: (copied by hand – may be typos)
    [421257] tpm.crb Firmware bug ACPI Region does not cover commandline response buffer

You are in emergency mode …
/usr/sbin: /lib64/ … not found (required by /usr/sbin/sulogin)

Starting default target

The final three indented lines above repeat forever. At this point there is no keyboard response.

I tried also init 2, which got me through the firmware bug warning but then froze.


Are you on btrfs?

If you cannot boot even to single user maybe the cleanest way is to reinstall, keeping /home intact if it is on a separate partition.
If you have a Leap install media you may try to boot using the “More… > Boot Linux system” choice of the installer, maybe choosing an older kernel if you still have one installed.
If the latter doesn’t work, maybe there is a way to boot the “Rescue System” in the install media, mount the system partition you are trying to recover, then chroot to that system and try to fix things, but if your system is not heavily customized I would prefer to reinstall.

No, ext3 .

I was able to boot into 42.3 (which was available but didn’t appear on boot.cfg menu.
From there I changed repositories to Leap 15, and did zypper dup.

Output of grub 2 is
update-bootloader … /usr/lib/bootloader/grub2-efi failed …
No valid efi partition.
But such does exist, says Yast:

(continuation of previous – editing facility here is tricky)

grub says can’t write /boot/grub2/grub.cfg because there is no valid efi partition. Yet Yast partition sees it.
/nvme0n1p1 bios boot part, label EFI1, FAT

Misc. other problems, like unadjustable crude display resolution.

So … fresh install.