After a recent package upgrade, I am no longer offered a login window after screen lock. openSUSE 4

I ran Yast2 update a couple of hours ago. It installed 42 updates, which I only glanced at. The previous update was done 6 hours prior to this one. Since the most recent updates, I am no longer given a place to put my login credentials on the lock screen. After a reboot, the first login is normal, then the problem repeats once the screen locker is activated. I have to CTL,ALT,Backspace to force a restart of the Display manager in order to get a login window.

This happens with either kdm or sddm display managers. I have not tried others.

I keep the “automatic” function of the locker disabled, but have always activated it manually if I leave my computer, for privacy reasons. I have no clue

I will add that the mesa libraries were among those updated. This seems NOT to be a KDE or display manager issue. I just updated fglrx to the newest version from Sebastian Siebert minutes ago and that made no difference with this problem. .

It seems somewhat likely that a mesa update may have caused the problem, although it is only an educated guess. The mesa updates came from the “Update-OSS” repositories.

My problem, just recently started with Leap 42.1.13 version when I leave the machine logged in and come back to it, the display is frozen, the mouse moves but doesn’t enable clicking to start an application. I have to hard boot the machine off, then restart, then it does it again. It seems to have started with the version revision from 12 to 13, in the last few days. Also Ctrl+Alt+ backspace does not bring up log out screen, it does nothing, so I am a little stumpted as to why?

Maybe unrelated to your problem but I have a question, are you using ext4 or btrfs ? Because I had these problems with kd5 on btrfs.

Maybe unrelated to your problem but I have question, are you on ext4 or btrfs with kde5 ? Because I had these problems with btrfs.

The first time Leap 42.1 crashed on installation, it was setup with btrfs. After I reloaded a new version installation, I used ext4 on all partitions, except the boot partition which is on VFAT.

Today, Yast installed about 200 updates. Apparently a fix was among them. I no longer have the missing login window problem. Problem fixed.