Aeon with nvidia

Not sure what I have done wrong or is there some bugs but I can’t get Nvidia to work on aeon. Trying to nouveau or proprietary and card is not detected.

Search online for issues and I found there is bugs and issues on RC2 and there is kind of workaround for it, but I guess I need to wait for fix

@PhatLe Is this a hybrid system, or pure nvidia?

Hybrid system pretty new hardware less than 2 years old

Intel UHD as iGPUband RTX 3050 TI as dGPU

@PhatLe what does inxi -GSaz show? You installed the Nvidia rpms?

Never show any Nvidia nit even grep Nvidia on troubleshoot I found it was still assigned to nouveau and tainted kernel blocked, but even nouavue drivers no dGPU only iGPU is detected on OS and used testing now kalpa edition if that has same since some posts stated it is only on aeon

@PhatLe remember we are not in front or your system, so can only work from information requested and pasted. Also uses systemd-boot as well, so may need some different foo as nosimplefb=1 needs to be added.

Yes I know and support relies on input I provide no worries been testing things out still. I could go on nouveau if it could provide cauda since that is only thing I need on my workflow to run cuda to rendering.

Aeon is still the one I like gnome for life and that is what I will choose still just now testing the kalpa if there is same issues and if so then I know I did something wrong

Will provide more details little later after testing both and if I can figure out how I can add both NVME drives to aeon

I tried to search Nvidia wikis but those didint provide too much details on immutable Nvidia trouble shoot so there could be something I missed on setting it up too

@PhatLe then I would suggest joining the development channel for Aeon on Matrix and can interface direct.

1 Like

Give me matrix link I will make that…


1 Like

Got tested and installed kalpa with Nvidia and it works no issues kalpa sees my dGPU on nouavue and repeat Nvidia install works and Nvidia is working

@PhatLe since Kalpa is using MicroOS, it’s still using grub2, Aeon uses systemd-boot, so you need to investigate that.

Kalpa will be moving to the same systemd-boot setup that Aeon is using, it’s just not ready for public consumption yet. So it’s well worth sorting out how to do it. I don’t have any nvidia hardware to test on in the first place, so it’s not something that I will be able to assist with when Kalpa does move to systemd-boot.

Yeah that explains more so time to trouble shoot more on Nvidia and systemd I can live some time without Nvidia for now and use CPU for rendering when needs atleast on small work

I have a laptop with both an AMD and NVIDIA GPU and at least currently,
using the proprietary nvidia driver works fine for me.

First off, I blacklisted the nouveau driver by creating the file
/etc/modprobe.d/nouveau.conf with the content:

blacklist nouveau

I then installed the relevant packages for my GPU (in my case G06) with transactional-update:

transactional-update -i dup pkg in nvidia-drivers-G06 nvidia-driver-G06-kmp-default nvidia-video-G06 nvidia-gl-G06 nvidia-compute-G06

IIRC, I also updated the initrd in another transactional-update, not
sure if this is really needed or already triggered automatically in the
preceding transactional-update :thinking:. If you don’t reboot after
the last command, take care to pass the number of the last snaspshot
to the transactional-update command :

transactional-update -c <NUM_OF_SNAPSHOT_INCLUDING_NVIDIA_DRIVERS> initrd

After rebooting into the new snapshot, all was good.

1 Like

Thanks I will test this one later today