Advice for getting (very old) Civilization Call to Power to work

Hi all:

So, I have a puzzle that I’ve attempted to solve for about 3 months and can’t get anywhere with, so here I am.

Goal: To get Civilization Call to Power to run on Leap 15.2

Reason: My dad insists on two things: A) that he not run Windows or MacOS, and B) that the computer play his favorite game Civ CTP 1 (no, he will not settle for FreeCiv, it’s “too hard”). This makes bringing him into the modern hardware era a bit difficult but his older computer is starting to have hardware failures, so…

What I’ve tried:

  • We own the Loki Linux Port, but without the loki_update patch, I can’t get the map generator to work. I have this working to the point of loading a saved map, so theoretically, the game functions, it’s just the map generator that doesn’t.

  • Wine, this is also an option, as I’ve got the old Windows version of the game too. Seems to land me in a different problem area: Interestingly enough, the game installs, launches, turns black for awhile, then if you interrupt it by pressing any key, it goes to the launch screen except the buttons have no words. Exiting works, or you can try to start a game, again, buttons have no words, but you can click through menus, select things (blindly). Only crashes by stack overflow if you actually try to launch the game/start a game. We get a boatload of fixmes of the nature:

0009:fixme:amstream:IDirectDrawStreamSampleImpl_CompletionStatus (0211B5A8)->(2,0): stub
0009:fixme:amstream:IDirectDrawStreamSampleImpl_Update (0211B5A8)->(2,00000000,00000000,0): stub

And a couple of
0009:fixme:x11drv:X11DRV_desktop_SetCurrentMode Cannot change screen BPP from 32 to 16

This looks like a graphics thing to me, but I’m not quite sure what to do.

Suggestions anyone? On either getting the map generator to work in the old version or getting the wine version to behave graphically?


Have you tried installing it in “dosbox” ?
Here is a link to the Call to Power apolyton patch
It mentions map scenarios, maybe it will help.

Is this version a viable option?

Thank you both for the ides.

I haven’t tried a Dosbox yet; definitely something to experiment with.

I’ll read a bit more on the apolyton patch; I did mess around with it a little a few weeks back, but didn’t have a lot of luck.

CTP2 gives me the same problems as CTP on wine, I have an old windows version. But that looks like a linux build so thanks for that! I’ll see if I can get it to work. (Not convinced the ‘client’ will approve, but it’s worth a shot.)

Thanks for the suggestions everyone, please keep 'em coming. I’ll update when I try some new things.


Short update:
Tried DosBox, I get a beautiful error “this program cannot be run in DOS mode”. Which makes sense, given that I think the game came out sometime in '97-'99 era. I don’t have a Win95 or 98 cd image handy, so installing Win95 on DosBox is a bit of a dud at the moment.

Haven’t had time to try to build ctp2 yet.

On the wine issue: I’m getting these two errors, although now (after some continued messing around with libraries, I have sound)
fixme:x11drv:X11DRV_desktop_SetCurrentMode Cannot change screen BPP from 32 to 16
err:seh:setup_exception_record stack overflow 1696 bytes in thread 0009 eip 7bc46e66 esp 00230c90 stack 0x230000-0x231000-0x330000

So that is where I sit with this now. Ideas always welcome. Will work on building the ctp2 for linux at some point this week, after work quiets down a bit.


If a windows program install any Windows in a VM like VirtualBox

Thanks for the suggestion! Not going to lie, I know nothing about VMs or virtualization, so this one might take me a long time to figure out and try. I do know that if the VM looks like Windows, client will object.


If you decide to run in a virtualization technology, Virtualbox is very easy and intuitive. You’ll figure it all out within a day without opening a manual (maybe more than once or twoice).
But, Virtualbox is a little weak on the side of graphics performance.
If you get Civ2CTP running in Virtualbox but not satisfied with graphics, consider installing another similar virtualization app, VMware Player. Works the same way and everything you learn in Virtualbox is easily transferred to running VMware Player. Note that VMware Player is free, all other VMware products will cost.

A quick search turns up a couple other options, both are common with solid reputations…
The Lutris gaming platform



Maybe wine??? Many Windows games can run there. Check on the wine web page.

Note you can set up Windows so the game starts with windows start.

Thanks both for the advice!

tsu2: I’ll play around with VirtualBox this weekend likely. I haven’t had good luck with lutris in the past, but perhaps this will be different. I do notice that the lutris people have a package called asgard to run old Loki games, so that might be an option instead of lutris itself. I’m hesitant to go for Steam because of two reasons (1) client doesn’t have internet, (2) Steam only offers CTP2, which isn’t what the client wants.

gogalthorp: I’ve spent a few hours with wine and every version of the game I own (or could beg or borrow). I get the same errors every time, these are:
A boatload of fixme’s (referenced at top of original post), then

fixme:x11drv:X11DRV_desktop_SetCurrentMode Cannot change screen BPP from 32 to 16
err:seh:setup_exception_record stack overflow 1696 bytes in thread 0009 eip 7bc46e66 esp 00230c90 stack 0x230000-0x231000-0x330000

I’m thinking this is a graphics issue, but no idea how to ‘fixme’. Anyone run into this before? Is it something that the windows start would resolve in your experience? The winehq threads tend to end in ‘wine won’t run your program, give up’.


Thank you for sharing this. This is really viable for all features, I was searching about.