Advice for folks trying to get dual-head working

I’ve got 11.1 loaded on a ThinkPad X200 (intel integrated gfx) and I’ve been struggling for longer than I want to admit to get an extended desktop working WITH a quick & easy method to switch between docked / stand-alone / projector setups. My final config is below…

First thing standing in the way is the amount of out-dated advice that’s out there. Half the tips are either a waste of time or will break the XServer. (And SaX config was entirely worthless).

My final solution was delightfully simple:

  1. edit your xorg.conf and REMOVE the excess detail

The display is able to dynamically detect most settings. I completely commented out everything in the “Modes” section aside from the identifier, and everything in any “Monitor” section aside from the identifier and the DPMS option.

  1. increase your virtual real-estate

In my xorg.conf I added “Virtual 3840x1200” in the Section “Screen” in each Subsection “Display” entries.

  1. Probably optional, but I disabled my unused video outputs.

In the Section “Device” I added these entries, in addition to the normal Option “monitor-LVDS” “Monitor[0]” and Option “monitor-VGA” “VGA”…

Option “monitor-TV” “TV”
Option “monitor-HDMI-1” “HDMI-1”
Option “monitor-HDMI-2” “HDMI-2”

and then I created corresponding monitor sections for each…

Section “Monitor”
Identifier “XXXXX” #ie, “TV”, “HDMI-1”
Option “Ignore” “True”

  1. Manage with Xrandr, and helper scripts…

As an example, here is my script:
xrandr --output VGA --mode 1280x1024 --right-of LVDS
sleep 1
gconftool-2 --load docked_right.entries #load custom panels
killall gnome-panel #restart panels

  1. Another optional step, and to explain the gconftool-2 entry in the script above… since I’m using Gnome I wanted to create custom toolbar configs for each environment.

Get your panels set up the way you want them and then run:
gconftool-2 --dump /apps/panels > ~/<some directory>/current_config.entries

It’ll dump your current setup to the *.entries file, and then you can reload that config any time you switch modes.

Extra comments:
Because my virtual size exceeds the Intel cap of 2048x2048 I’m forced to disable Compiz. It’s not a big deal for me, the only thing in Compiz that’s more than eyecandy to me is the screenshot plugin. But I can manage with using Gimp.

If you absolutely MUST get Compiz running then I believe you can hunt around and get the latest Compiz builds, and also the specific updated Intel driver which allows for larger virtual workspaces.

I don’t know how useful this will be for anyone… but I thought I’d share, just in case.