Adventures/thoughts installing openSUSE 11.3

I downloaded the 64-bit dvd this morning. Took about 4 hrs. using the metalink. Not bad, but I’ve downloaded the dvd.iso other times in less than an hour from the direct download link.

Install took a little less than 20 min. from start to the completed configuration and the welcome screen. I used autoconfg which does everything in the background so I didn’t see any of that. The updater applet immediately told me there was no network found for updates so I started YaST to check network settings. Ifup was selected, but neither my wired or wireless connection was configured. There was no ethernet cable connected, so the wired interface not being configured was understandable, but I don’t know why wireless wasn’t configured. I switched to NetworkManager and configured it through System Settings with no problems.

I noticed that hal was installed by default, which wasn’t the case with RC1, and MariaDB is no longer installed, just mysql. My monitor was configured correctly with the nouveau driver.

The first time I started the YaST software manager, the usual updates and additional packages were already queued up for install. I added some of the community repos and updated everything that was available. No problems.

I added ‘nomodeset’ to menu.lst and installed the nvidia drivers with no problem. Compositing was automatically enabled.

I also added the KDE4:/UNSTABLE repo and updated to KDE 4.5 RC2. So far, so good. I’d be interested to know if using the manual configuration during install would result in wireless being configured correctly. I’m off to configure my laser printer next.

It is very interesting that your wireless was not configured to use Networkmanager. You might want to make a comment about this in the following thread to help clarify the issue.

11.3 not using networking manager by default?

I would like to add that overall the installations have went very well for me. I even had a very unusual issue in that I decided to switch to a gigabit network adapter. I have a dual boot computer with Windows 7 and the latest version of openSUSE. I popped in the network card and booted to Windows 7 first were the new card would not work. The brand was a Trennet and the model was TEG-PCITXR (version 3), its a PCIE gigabit network card and hopefully faster than the 10/100 on the motherboard. I do have a gigabit network switch it is connected to. After a visit to Trandnet on the internet (from another PC), I found no Windows 7 driver present and many people complaining about the problem. So, I decided to boot to openSUSE 11.3 to see if it worked there. Low and behold it did work and not only that, but it said it was a D-Link DGE-560T. So, I went to the D-Link web site and downloaded the Windows 7 driver for the DGE-560T (which I did not I know really had) and loading it in Windows 7 did indeed cause it to work. openSUSE was not fooled and worked right off the bat while Windows 7 had to be convinced the card was a different brand and model.

You just never know what kind of help Linux can be in your life.

Thank You,

If you had a hardwired connection when you installed, you probably would not have had the network manager - it would default to the suse ‘use traditional method with ifup’.
You can enable network manger by going to yast2>network devices/ network settings and choosing the network setting type in the global tab.

Not sure what you mean, whych. As I said above, using the autoconfig does default to ifup but nothing was configured.

I also meant to post earlier, there is no “repair install” option on the 11,3 dvd like there is with 11.2. Has anyone else noticed this? Is there an alternative to this that can be obtained separately?

I just used the repair feature yesterday to fix grub in 11.2 and it’s pretty handy.

Not sure what you mean, whych. As I said above, using the autoconfig does default to ifup but nothing was configured.

I also meant to post earlier, there is no “repair install” option on the 11,3 dvd like there is with 11.2. Has anyone else noticed this? Is there an alternative to this that can be obtained separately? I just used the repair feature yesterday to fix grub in 11.2 and it’s pretty handy.

Sorry, but just re-read the post.
I am still waiting for my dvd to download - don’t know if it’s an isp problem or just that the servers are too busy.
I have only used the milestones and rcs.
RC2 dvd never worked, but it has an option for repair on the main boot menu about fixing things (it’s worded differently to other versions and called rescue or something similar, from memory. I had to install and update to release version using a live image.)
I think the problem is with the ‘one size fits all’ auto setup.
But then I take it that you are more experienced and know how to fix the problem :wink:

I somehow managed to install 11.3 on a brand new Asus MB with an AMD 64 bit quad-core CPU with no problems whatsoever. rotfl!

I’m now downloading a bunch of applications and utilities with no problems whatsoever.

I’m using the on-board video, audio, network, and no plug in cards. I dread ever having to take on the ATI and Nvidia nightmares again. Of course, my prior bad experiences with video drivers were with left over W98 era “legacy” video cards. lol!

All this was mounted in my old HP Pavilion case that used to house a P-II 450 running W95 when I bought it. I’m going to get 20 years or more out of that case. :slight_smile:

Will report back if I run into any problems, but so far it’s been the easiest and slickest Linux install I’ve ever done, and I’ve done a whole lot of them tinkering around on my fleet of retired, obsolete office computers.

Okay, I’ve got all my stuff installed, and NO PROBLEMS WHATSOEVER. rotfl!

Could be helpful to know what vendor and type of onboard video chip, given the focus on xorg’s auto configuration with this new release?

BTW, Nice story. I did a similar type of replacement a few years ago with openSUSE 10.1, and it’s still running well with 11.2 and 11.3 installed.

Okay, got the MB manual in hand:

Asus M4A785TD-V EVO with a 3 GHz AMD Phenom PH II X4 945 CPU

4 gb DDR3 ram clocked at 800 MHz, interleaved for 1.6 GHz throughput (I think)

ATI Radeon HD 4200 GPU with onboard 128 mb DDR3 1333 MHz memory

VIA VT1708S High Definition 8 channel audio

openSuse 11.3 x64 installed with the KDE desktop

This is my first really up-to-date system - all my others are old retired office computers that got replaced with modern stuff. So, I have a lot of new terms and acronyms to look up on the web while holding the MB manual in the other hand. I went through the BIOS slowly and carefully, and only understood half of it. lol!

This thing is downright snappy compared to what I’m used to!

Thanks for the details, it looks snappy.

When you eventually feel comfortable with it, you might consider adding a line re the new MB to the HCL (Hardware Compatibility List) in the new openSUSE Wiki, via the Hardware portal. I haven’t checked to see if an entry already exists. It’s new to many of us, so if you need help with that you can ask in the Wiki Discussions forum (under Community section).

Something I forgot to mention. Years ago I decided that every Linux install I did was going to have a separate root and home partition or separate drives for root and home. That way when I do upgrades I just leave the /home partition alone and reformat and install on the root partition. Then I download all the usual packages I normally install and only have to do a little minor bit of reconfiguring anything after an upgrade.

I DO NOT upgrade existing installations any other way than completely renewing the whole root partition while saving my old /home partition. IT WORKS EVERY TIME.

I recently upgraded 4 or 5 openSUSE 11.1 installations to 11.2 by this method and everything worked perfectly.

I might continue using those 11.2 installations until support expires, but if I decided to upgrade to 11.3 on those old boxes it sure won’t be done the usual way that causes so many problems. I suffered greatly from upgrade experiences during the W95 and W98 eras and from my earliest Linux learning curve. Now, I always blow away all the old executables and libraries while saving all my /home data and configurations.

Nice motherboard , Asus M4A785TD-V EVO.

I have been using it since september last year with an AMD Athlon II X2 250 3Ghz.

OpenSUSE 11.3 is very nippy especially when compared to 11.2.

I have problems with the ATI driver HD 4200, it does’t compatible with Opsensuse 11.3 If you find how to install it, please post again. Thank you.

Did you try intalling the ati driver directly from the AMD site? In the absence of an ati repo, this may well be the way to go. Also look in the hardware section to see if anyone else is having problems with ati video cards. (I haven’t tried it on my ati pc but had problems with nvidia)